Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Petit souci

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Jean_01

avatar

Nombre de messages : 5382
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Petit souci   Lun 29 Oct 2007 - 15:26

Bonjour à tous,

Je suis tombé sur un problème ce matin en voulant personnaliser un TCO, je n'arrivais pas à modifier la couleur des voies dans le TCO et ce, quelles que soient les couleurs mises dans la fenêtre de personnalisation.

L'origine de ce problème vient de l'utilisation du dossier Images qui contient les signaux personnalisés (images des cibles de la signalisation mécanique en téléchargement sur ma page web).

Ce dossier contient les fichiers TrackLrg.bmp et Tracksm.bmp que TC charge si le dossier Images est présent dans le répertoire de TC. Résultat, vous avez toutes vos voies de la couleur des éléments du menu "Outils" et vous ne pouvez pas les modifier.

Solution du problème: renommer les deux fichiers, par exemple Tracksm.bmp_old et vous retrouverez toutes les fonctionnalités de la personnalisation du TCO.

Bonne fin de journée à tous,

Jean
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
bisounours

avatar

Nombre de messages : 65
Age : 43
Localisation : Lausanne - CH
Emploi : cheminot aux CFF
Date d'inscription : 25/06/2007

MessageSujet: Re: Petit souci   Lun 29 Oct 2007 - 17:35

Salut Jean,
je viens de tester, et j'ai ce problème aussi, mais uniquement avec la couleur noir.....

ça ressemble à un bug....

Bonne semaine
Christophe
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.amfrailroad.ch
Jean_01

avatar

Nombre de messages : 5382
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Petit souci   Lun 29 Oct 2007 - 17:45

Salut Christophe,

Je ne pense pas que ce soit un bug. Depuis que j'ai renommé les deux fichiers du dossier Images, ça fonctionne sur n'importe quelle couleur.

Regarde le contenu du répertoire Images, soit dans ton répertoire d'installation de TC, soit dans celui créé automatiquement dans /mes douments.

Jean
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
bisounours

avatar

Nombre de messages : 65
Age : 43
Localisation : Lausanne - CH
Emploi : cheminot aux CFF
Date d'inscription : 25/06/2007

MessageSujet: Re: Petit souci   Lun 29 Oct 2007 - 22:52

Salut,
je trouve pas ces deux fichiers crées par Train Controller....
Moi j'ai que le noire qui pose soucis, les autres couleurs fonctionnent parfaitement.

Je vais étudier ça à tête reposée :-)

Bonne semaine
Christophe
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.amfrailroad.ch
Jean_01

avatar

Nombre de messages : 5382
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Petit souci   Mar 30 Oct 2007 - 11:42

Christophe,

Si tu ne trouves pas les fichiers dont je parle, c'est que tu n'as pas installé le répertoire Images avec TC. Donc tu ne devrais pas avoir de problème.

Le noir fonctionne très bien, donc il ne doit pas y avoir de bug. Exemples:

Voies noires sur fond noir:


Et comme aurait dit Coluche, dans TC, il y a du noir clair et du noir foncé Very Happy Very Happy

Voies noires sur fond blanc:


Voies noires sur fond beurk Very Happy Very Happy


Et je peux vous en faire qui font beaucoup plus mal aux yeux Very Happy Very Happy

Jean
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
patrick 95

avatar

Nombre de messages : 91
Localisation : Pierrelaye Val d'Oise
Date d'inscription : 26/06/2007

MessageSujet: Re: Petit souci   Mer 31 Oct 2007 - 10:30

Bonjour,

Moi il y a longtemps que j'ai des problèmes avec la couleur des éléments surlignés des indicateurs.

Je mets en rouge les contacts d'arrêt et en bleu les contacts de freinage et la même couleur pour les éléments surlignés qui leur sont attribués et bien au bout de quelque temps les contacts gardent la bonne couleur par contre tous les éléments surlignés passe en JAUNE !!

J'ai refait plusieurs fois l'opération est maintenant j'ai laissé tombe !!

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
titrain



Nombre de messages : 44
Age : 80
Localisation : 52700 MILLIERES
Emploi : retraité
Loisirs : model HO radio amateur f6CHU
Date d'inscription : 25/07/2007

MessageSujet: inieté la color   Mer 31 Oct 2007 - 11:26

moi , j'ai des petits points rouge de toutes les couleurs

Jean-Marie TITRAIN
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5382
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Petit souci   Mer 31 Oct 2007 - 11:41

patrick 95 a écrit:
Bonjour,

Moi il y a longtemps que j'ai des problèmes avec la couleur des éléments surlignés des indicateurs.

Je mets en rouge les contacts d'arrêt et en bleu les contacts de freinage et la même couleur pour les éléments surlignés qui leur sont attribués et bien au bout de quelque temps les contacts gardent la bonne couleur par contre tous les éléments surlignés passe en JAUNE !!

J'ai refait plusieurs fois l'opération est maintenant j'ai laissé tombe !!


Maisnon, mais non, ce n'est pas au hasard, il y a une explication à tout cela, la voici:

1) les contacts comme voulus par Patrick: deux contacts assignés à un canton. Les deux contacts sont actifs et le canton occupé:



2) Maintenant, j'assigne un train au même canton et ce train conserve les deux contacts activés:



Les traits de surlignage des cantons sont devenus jaunes

3) J'enlève mon train du canton:



Les traits des deux contacts dans le TCO ont repris leur couleur initiale.

Dans le TCO, si des contacts sont jaunes bien qu'une autre couleur leur ait été attribuée quand ils sont actifs, c'est que ces contacts sont assignés à un canton et qu'un train est présent sur ce canton.

Voili, voilou Very Happy Very Happy

Jean
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
patrick 95

avatar

Nombre de messages : 91
Localisation : Pierrelaye Val d'Oise
Date d'inscription : 26/06/2007

MessageSujet: Re: Petit souci   Mer 31 Oct 2007 - 13:14

Ah ba ça alors !!!!!!!!!!!!! Shocked

Pourquoi ce décarcasser à changer de couleur alors puisque la finalité est d'assigner un train ??

Je trouve cela etrange, mais merci Jean, j'ai même songé un temps à un probléme de ma carte graphique !!!! jocolor
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Yann

avatar

Nombre de messages : 1664
Age : 35
Localisation : Suisse - Entre Lausanne et Vevey
Date d'inscription : 25/06/2007

MessageSujet: Re: Petit souci   Mer 31 Oct 2007 - 19:13

Je pense que cette possibilité remonte à la version <5 à l'époque le Dispatcher graphique et les rectangles de cantons n'existaient pas. Une aide était de mettre une couleur différente pour chaque locomotive.
Dans l'exemple de Jean il a choisi la couleur jaune pour sa locomotive:



Personnellement j'ai choisi d'appliquer la couleur rouge à toutes mes locomotives car le nom et le dessin de la locomotive dans le canton (que se soit sur le TCO ou le Dispatcher) me suffisent pour identifier le véhicule.

_________________
A+ Yann  
Mes tuto vidéo sur TrainController => http://www.youtube.com/TheDigitrain <=
Mon blog => http://blogyann.blogspot.ch <=
TC 8 Gold-Silver/+SmartHand Mobile/+Net/H0 3 rails/2rails/Tams MasterControl/rétro. bus Selectrix SLX 852/Compaq 2 GHz, iMac 3.5 GHz Intel Core i5/VMWare Fusion/Windows 7/XP Pro SP3/iPhone 6 iOS 11.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.digi-train.ch/
Jean_01

avatar

Nombre de messages : 5382
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Petit souci   Mer 31 Oct 2007 - 21:09

Bonsoir Yann,

Très bonne remarque. Je n'ai pas mis la couleur jaune, c'est celle qui est par défaut et je ne l'ai pas changée.

Ce que tu dis des versions antérieures à la V5 me rappelle quelque chose mais je n'ai plus la 4.7 installée, donc je ne peux pas vérifier. Je pense que tu as raison.

A tout bientôt en Valais Very Happy Very Happy

Jean
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
Contenu sponsorisé




MessageSujet: Re: Petit souci   

Revenir en haut Aller en bas
 
Petit souci
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Petit souci
» [résolu]Petit souci avec Avast pour le pare-feu : que faire pour éviter ces messages ?
» Petit souci pour graveur externe
» Infobulle dans un tableau petit souci
» Un petit bonjour / bonsoir !

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Divers-
Sauter vers: