Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez
 

 Problème séparation UM

Aller en bas 
Aller à la page : 1, 2  Suivant
AuteurMessage
rico

rico

Nombre de messages : 5719
Age : 54
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

Problème séparation UM Empty
MessageSujet: Problème séparation UM   Problème séparation UM EmptyDim 20 Jan - 21:14

Bonsoir,

J'ai un petit problème lors d'une séparation d'UM, mes attelages Kadee reste en traction et je n'obtiens pas le décrochage physique désiré. Il suffit pour régler le problème de rapprocher de 1 ou 2 mm les 2 locos.

Mais je n'arrive pas à faire avancer la loco de derrière ou faire reculer la loco de devant...

Que faut-il faire?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Joel

Joel

Nombre de messages : 1326
Age : 75
Localisation : Rennes
Emploi : Retraité T.D.F.
Loisirs : Chorale Bridge Modélisme ferroviaire voile
Date d'inscription : 03/12/2011

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyDim 20 Jan - 21:20

Ben alors Rico, c'est dimanche et peut être que l'apéro était trop fort. Il me manque la signification de UM !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01
Ignare immobile
Jean_01

Nombre de messages : 5981
Age : 72
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyDim 20 Jan - 21:22

UM = Unité Multiple ... en français dans le texte, deux ou plusieurs locos qui unissent leurs forces de traction.

C'est bon, tu peux passer au digestif Razz Razz

Jean Smile

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver), V9 Gold (Silver) Intellibox I et S88, DCC,  PC sous  W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
DiCoS69

DiCoS69

Nombre de messages : 11856
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyLun 21 Jan - 1:36

rico a écrit:
Bonsoir,

J'ai un petit problème lors d'une séparation d'UM, mes attelages Kadee reste en traction et je n'obtiens pas le décrochage physique désiré. Il suffit pour régler le problème de rapprocher de 1 ou 2 mm les 2 locos.

Mais je n'arrive pas à faire avancer la loco de derrière ou faire reculer la loco de devant...

Que faut-il faire?
Il me semble qu'en UM, TC refuse de faire rouler les locos en sens contraire.
Peut être qu'en séparant d'abord l'UM virtuellement, tu pourras en faire bouger une toute seule ensuite, mais, c'est sans garantie, je n'ai pas essayé...
Tout ça dans une macro...??
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Mcar

Mcar

Nombre de messages : 1123
Age : 62
Localisation : Haucourt Moulaine (54)
Emploi : en vacances éternelles
Loisirs : Modélisme ferroviaire/Usinage métaux
Date d'inscription : 29/03/2010

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyLun 21 Jan - 5:17

DiCoS69 a écrit:

Il me semble qu'en UM, TC refuse de faire rouler les locos en sens contraire.
Peut être qu'en séparant d'abord l'UM virtuellement, tu pourras en faire bouger une toute seule ensuite, mais, c'est sans garantie, je n'ai pas essayé...
Tout ça dans une macro...??

Non Elie même comme cela ça ne marche pas !

J'en ai parlé ici :

http://traincontroller.forum-actif.net/t1600-defaire-une-um-avec-des-kadee

Rico si tu trouves la solution je suis preneur


Dernière édition par Mcar le Lun 21 Jan - 8:42, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Capitole
Un mini-canton sinon rien
Capitole

Nombre de messages : 3003
Age : 66
Localisation : Région Toulousaine
Date d'inscription : 14/02/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyLun 21 Jan - 8:31

Bonjour.
Pas réussi non plus, jusqu'ici, je fais la séparation manuellement avant de lancer la procédure.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

rico

Nombre de messages : 5719
Age : 54
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyLun 21 Jan - 8:40

Et bien je vais repasser en Silver si ça continue!!!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
bijave66

bijave66

Nombre de messages : 2095
Age : 69
Localisation : 66 Laroque des Albères
Emploi : retraité
Loisirs : modélisme ferroviaire
Date d'inscription : 31/01/2011

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyLun 21 Jan - 9:12

Waff, waff, waff; pour l'upgrade Gold-->silver, tu vas trouver ça ou ? study
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

rico

Nombre de messages : 5719
Age : 54
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyLun 21 Jan - 9:24

En appliquant la mi vitesse sur une des 2 machines, je peux obtenir la compression d'attelage désirée. C'est moyen mais doit fonctionner.

Maintenant, ma manœuvre a lieu en refoulant, or je ne sais pas appliquer une fonction décodeur sur la machine arrière. Je sais le faire sur la machine avant par contre...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

rico

Nombre de messages : 5719
Age : 54
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyLun 21 Jan - 11:25

Donc, j'adapte ma question puisque apparemment, ce que je voulais faire initialement n'est pas possible.

Comment dans une UM, appliquer une fonction uniquement sur la deuxième loco?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

DiCoS69

Nombre de messages : 11856
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyLun 21 Jan - 15:12

Tu dis que tu sais appliquer une fonction sur la machine avant...
Commence ta manœuvre avec la fonction "1/2 vitesse" appliquée aux 2 locos, puis, au dernier moment, tu la désactives sur la loco de tête... clown Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

rico

Nombre de messages : 5719
Age : 54
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyLun 21 Jan - 15:28

Effectivement Elie, j'y ai pensé! Je n'ai pas trouvé mieux pour l'instant!

J'espérais que quelqu'un me livrerait les secrets de cette version Gold que je ne maitrise pas dans tous les recoins!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

DiCoS69

Nombre de messages : 11856
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyLun 21 Jan - 15:39

Si tu daignes faire un petit effort de l'index droit, il y a aussi, en V8, la possibilité d'activer, je pense, la fonction "1/2 vitesse" en cliquant dessus dans la fenêtre de conduite de la seconde machine.
Ce qui m'amène à penser que ce doit-être aussi faisable en automatique, par l'intermédiaire d'un bouton poussoir placé au TCO et commandé par un élément quelconque... à voir...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01
Ignare immobile
Jean_01

Nombre de messages : 5981
Age : 72
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyLun 21 Jan - 15:45

J'ai une petite idée, mais je n'ai pas testé.

Il faut que les décodeurs équipant les locos soient capables de gérer la fonction de dételage comme pour des dételeurs automatiques Krois par exemple.

Si je me souviens bien, cette fonction inclut une petite marche arrière pour dégager les attelages. Donc on doit pouvoir:

- Installer cette fonction sur les locos de l'UM
- En fin de trajet de l'UM, séparer logiquement les deux locos
- Désactiver la propagation de fonction
- Activer la fonction de dételage.

A voir, c'est juste une idée pour faire avancer le bazard.

Jean Smile Smile

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver), V9 Gold (Silver) Intellibox I et S88, DCC,  PC sous  W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
DiCoS69

DiCoS69

Nombre de messages : 11856
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyLun 21 Jan - 16:07

Pour en revenir à la fonction "1/2 vitesse" et à la "propagation de fonction", il serait préférable que la loco de tête ne la possède pas, du moins pas activée dans TC.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

rico

Nombre de messages : 5719
Age : 54
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyLun 21 Jan - 21:34

Pour la fonction dételage, c'est raté. Mes deux 63000 sont en Lenz Silver...

Merci des idées, je regarderai ça demain, si je trouve un peu de temps!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

rico

Nombre de messages : 5719
Age : 54
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyMar 22 Jan - 7:49

Bonjour et merci pour votre aide.

En ce moment, je n'ai pas beaucoup le temps pour jouer au train et d'essayer tout ça. Quelques problèmes de voiture m'occupent mon temps libre... De plus , je bosse samedi et le samedi suivant!

Je retiens l'idée d'Elie sur la demi vitesse, qui n'est pour le moment pas programmée sous TC pour aucune des 2 locos. Effectivement, si seule la deuxième possède la fonction sous TC, il y a une chance que ça marche.

Si quelqu'un a autre chose à proposer, je fais feu de tout bois!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

rico

Nombre de messages : 5719
Age : 54
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyVen 25 Jan - 10:27

Bonjour,

Pas eu le temps de tester la demi vitesse. J'espère avoir le temps dimanche.

Pour l'instant, le peu de temps libre est consacré au réglage d'une 141 R 460 Jouef.

Superbe loco qui faut finir soi même...pour qu'elle fonctionne. Je le savais, mais la super promo était tentante!

Alors Jean01, tu avais l'air d'avoir une solution pour cette UM?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Christophe

Christophe

Nombre de messages : 2482
Age : 61
Localisation : Nantes
Emploi : Journaliste
Date d'inscription : 07/06/2009

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyVen 25 Jan - 10:43

rico a écrit:
Alors Jean01, tu avais l'air d'avoir une solution pour cette UM?

Bon ben j'en ai une qui marche mais ça dépend !

Un premier trajet permet la formation de l'UM en faisant atteler la machine entrante derrière la machine de tête. Un second les fait rouler, à l'arrêt une macro sépare les machines. Un troisième trajet fait partir la machine menée en sens inverse dans mon cas.

Mais... cette machine part seulement dans le cas ou le trajet est lancé manuellement. Si ce troisième trajet est lancé en successeur du second, TC essaye de faire partir la machine menante en arrière et reste bloqué là. Sans messages ou quoi que ce soit... Embarassed

Mais trajet par trajet ça marche à tous les coups !!! Smile Smile Smile

Je me dis qu'on doit pouvoir faire mieux... Je vois mal pourquoi J Freywald aurait intégré la possibilité de constituer des UM, mais pas de solution pour les défaire...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://traindejardin.free.fr
rico

rico

Nombre de messages : 5719
Age : 54
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyVen 25 Jan - 11:05

Comme tu le dis, ta macro sépare, mais ne rapproche pas les locos... Dommage!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01
Ignare immobile
Jean_01

Nombre de messages : 5981
Age : 72
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyVen 25 Jan - 15:19

rico a écrit:
Pour la fonction dételage, c'est raté. Mes deux 63000 sont en Lenz Silver...

Merci des idées, je regarderai ça demain, si je trouve un peu de temps!

Je viens de regarder le manuel des Lenz Silver, la fonction dételage est bien présente, dans les CV 145 à 148.

A mon avis, c'est un bon moyen de faire faire un mouvement à une loco sans que TC en soit partie prenante puisqu'on ne fait transiter aucun ordre de vitesse par le logiciel.

Jean Smile

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver), V9 Gold (Silver) Intellibox I et S88, DCC,  PC sous  W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
rico

rico

Nombre de messages : 5719
Age : 54
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyVen 25 Jan - 15:24

Merci Jean, je regarde ça. Ce sont des vieux Silver, je ne suis pas sur que ça existe...

Sinon c'est une excellente solution.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

rico

Nombre de messages : 5719
Age : 54
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyVen 25 Jan - 16:18

D'après mes archives, mes décodeurs sont 10-331 et non pas des 10-331-01...

Ces CV ne sont pas prévus, dommage.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01
Ignare immobile
Jean_01

Nombre de messages : 5981
Age : 72
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyVen 25 Jan - 16:39

Je vais essayer de tester pendant le week-end. Il faut que je vérifie la version de mes Lenz direct dans mes 63000.

Pour activer les fonctions de dételage en avant et en arrière, j'ai posé la question sur le forum LR car les CV 145 et 146 concernées ne peuvent prendre que les valeurs 0 à 7, d'après la notice, et si je veux affecter les sorties C et D du décodeur, il me faudrait mettre 4 dans CV 145 et 8 dans CV 146, ce qui ne me paraît pas possible.

Il y a donc un truc qui m'échappe quelque part. Si quelqu'un a une idée, à votre bon coeur Smile Smile

Jean Smile

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver), V9 Gold (Silver) Intellibox I et S88, DCC,  PC sous  W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
Mcar

Mcar

Nombre de messages : 1123
Age : 62
Localisation : Haucourt Moulaine (54)
Emploi : en vacances éternelles
Loisirs : Modélisme ferroviaire/Usinage métaux
Date d'inscription : 29/03/2010

Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM EmptyVen 25 Jan - 21:26

Bonsoir à tous,

La CV 145 permet de définir quelle sortie de fonction sera associée au dételage coté Av de la machine
la CV 146idem l'autre coté de la machine.
il faut ici incrire en decimal
1 pour la sortie de fonction A,
2 pour la sortie B
4 pour la sortie C
8 pour la sortie D
16 pour la sortie E
Jean ne suit pas la notice pirat
évidemment pour l'application à Rico (defaire une UM) la sortie ne sera pas branchée puisqu'elle est fictive, et nous servira uniquement de faire approcher la loco de sa rame ou reculer ,en fonction de l'activation de CV 145 ou 146.
imaginons que la sortie de fonction E est libre donc mettre 16 en decimal en CV 145 et 146
puis il faut ensuite choisir le numero de fonction (F?) définie pour la CV 145 et 146
par exemple nous allons choisir F7 et F8
donc mettre en CV 41 et 42 le decimal 16
ensuite il faut definir la durée du deplacement , ca se fait en CV 148 avec "valeur CV" x 0,016 sec.
les valeurs sont comprises entre 0-255 donc si on met 100 (en decimal)
100 x 0,016 = 1,6 sec. donc la machine va se déplacer de 1,6 seconde.
voilà,
Pour le reste il ne reste plus qu'à définir les fonctions F7 et F8 dans TC, mais là vous savez






Dernière édition par Mcar le Ven 25 Jan - 21:40, édité 2 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




Problème séparation UM Empty
MessageSujet: Re: Problème séparation UM   Problème séparation UM Empty

Revenir en haut Aller en bas
 
Problème séparation UM
Revenir en haut 
Page 1 sur 2Aller à la page : 1, 2  Suivant

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Les Trajets et Itinéraires-
Sauter vers: