Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  GalerieGalerie  RechercherRechercher  S'enregistrerS'enregistrer  Connexion  

Partagez
 

 Problème avec Autotrain...

Aller en bas 
AuteurMessage
fhp2

fhp2

Nombre de messages : 963
Age : 57
Localisation : Paris
Date d'inscription : 25/01/2012

Problème avec Autotrain... Empty
MessageSujet: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 11:56

Bonjour,
Depuis la mise en place de la version B4, j'ai des problèmes avec Autotrain qui après quelques minutes ne fonctionne plus...
En plus aucun message ne s'affiche dans Dr Railroad indiquant un éventuel problème.
Je suis obligé de tout relancer (CS2 et PC) pour retrouver la fonction mais qui s'arrête après quelques minutes...
Il semblerait aussi qu'en fermant TC et en le relancant après avoir effacé le fichier .yrs (bien sûr je sauvegarde avant la position des trains et le la recharge ensuite dans TC), Autotrain refonctionne, mais là encore pour quelques minutes seulement...
Par ailleurs ce problème est intervenu après des difficultés avec une rame MFX (le BR403 de chez marklin) dont le decodeur s'est mis à faire un bruit de cliquetis et des sto-and-go. Il a fallu là aussi que je relance la CS2 (pas un redémarrage à chaud, mais un arrêt complet) et TC pour régler le problème. Je ne sais pas si c'est lié mais après ce problème les difficultés Autotrain sont apparues surtout (me semble-t-il...) avec les machines MFX mais pas seulement...
Merci d'avance de votre aide, François.
Revenir en haut Aller en bas
Joel

Joel

Nombre de messages : 1352
Age : 76
Localisation : Rennes
Emploi : Retraité T.D.F.
Loisirs : Chorale Bridge Modélisme ferroviaire voile
Date d'inscription : 03/12/2011

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 12:00

Hier j'ai fait tourner autotrain (wagon nettoyeur), je n'ai pas rencontré de dysfonctionnement
Revenir en haut Aller en bas
Christophe

Christophe

Nombre de messages : 2711
Age : 61
Localisation : Nantes
Emploi : Journaliste
Date d'inscription : 07/06/2009

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 12:49

J'ai un peu de mal à comprendre le lien que tu fais entre Autotrain et les soucis de décodeurs...
Je vois mal comment l'utilisation d'une fonction dans le logiciel aurait une influence particulière liée à cette fonction... mais admettons !
Lorsque tu lances un trajet que se passe t-il ?

_________________
amicalement,
Christophe


licence RRTC Gold V9 A3, sur Mac Mini 10.11.6 avec W7 SP1 émulé avec Parallels Desktop 11

réseau RhB, Iim (LGB) en extérieur, http://traindejardin.free.fr
- pour la commande et l'alimentation de la voie, (traction et signalisation) :
Lenz LZV 100 + 2(LV 102) (soit 22 V 12 A) LAN
- pour la rétro-signalisation :
HSI LDT RS232 avec détecteurs Dicos69 + modules RM-88-N-O, (fiable à l'extérieur, même avec 45 mètres de câbles RJ45) et RM-GB-8-N pour la partie intérieure (garage du réseau).
+SmartHand sur iphone et Safari via wifi.
Utilisation de l'app TouchCab sur iOS en wifi.
Utilisation du Navigator Massoth, via un émetteur/récepteur Massoth raccordé en XpressNet sur la centrale Lenz.
Petit réseau RhB en H0m pour m'amuser à l'intérieur. Avec la même LZV 100 (sur 16V) et une rétro RS-8 de LDT. Et les mêmes commandes externes sans fils.
Revenir en haut Aller en bas
http://traindejardin.free.fr
fhp2

fhp2

Nombre de messages : 963
Age : 57
Localisation : Paris
Date d'inscription : 25/01/2012

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 13:28

Je ne sais pas s'il y a un lien, mais l'apparition des problèmes sur Autotrain est arrivé juste après...
Ensuite, le fait que ce problème de décodeur ait complètement bloqué la centrale au point de devoir la relancer à froid, pourrait influencer le fonctionnement de TC au niveau de la centrale...? Il faut aussi savoir que les decodeurs MFX ne sont pas gérés directement par TC mais sont dans la base de données de la CS2 à laquelle TC est raccordé (pour creer une loco mfx sous TC, il faut d'abord la creer dans la cs2 puis lire la base de données de la cs2 à partir de TC puis charger la fiche de la loco une fois lue par TC...!).
Les trajets ont l'air de fonctionner correctement...!
Revenir en haut Aller en bas
Christophe

Christophe

Nombre de messages : 2711
Age : 61
Localisation : Nantes
Emploi : Journaliste
Date d'inscription : 07/06/2009

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 16:23

Effectivement ça à l'air compliqué pour autant, si tes trains roulent par trajets... la centrale ne sait pas faire la différence entre la manière dont ils ont été conçus dans TC !Very Happy Very Happy Very Happy

Je ne sais pas ce qu'en pensent les autres, mais il y a un truc qui me chagrine, c'est ton besoin de transférer des fichiers lors des upload ou mises à jour...
Aucun des 4 fichiers de base n'a a être manipulé séparément... Je serais toi, je rechargerais TC, puis lui demanderais d'ouvrir le fichier réseau.

_________________
amicalement,
Christophe


licence RRTC Gold V9 A3, sur Mac Mini 10.11.6 avec W7 SP1 émulé avec Parallels Desktop 11

réseau RhB, Iim (LGB) en extérieur, http://traindejardin.free.fr
- pour la commande et l'alimentation de la voie, (traction et signalisation) :
Lenz LZV 100 + 2(LV 102) (soit 22 V 12 A) LAN
- pour la rétro-signalisation :
HSI LDT RS232 avec détecteurs Dicos69 + modules RM-88-N-O, (fiable à l'extérieur, même avec 45 mètres de câbles RJ45) et RM-GB-8-N pour la partie intérieure (garage du réseau).
+SmartHand sur iphone et Safari via wifi.
Utilisation de l'app TouchCab sur iOS en wifi.
Utilisation du Navigator Massoth, via un émetteur/récepteur Massoth raccordé en XpressNet sur la centrale Lenz.
Petit réseau RhB en H0m pour m'amuser à l'intérieur. Avec la même LZV 100 (sur 16V) et une rétro RS-8 de LDT. Et les mêmes commandes externes sans fils.
Revenir en haut Aller en bas
http://traindejardin.free.fr
rico

rico

Nombre de messages : 5874
Age : 54
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 16:31

Rentrant de vacances, j'évite de penser...

Mais comme Christophe, j'ouvre l'ancien fichier sans me poser de questions!
Revenir en haut Aller en bas
fhp2

fhp2

Nombre de messages : 963
Age : 57
Localisation : Paris
Date d'inscription : 25/01/2012

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 16:47

C'est bien ce que j'avais fait... Mais suite aux différentes dernières updates et à l'utilisation des compléments +Street, Smarthand et +4DSound, j'avais des doublons Français/Anglais dans les intitulés de la barre de menu... La solution a été trouvée grâce à Jean en supprimant les 2 fichiers yrw et yrs puis en rechargeant le fichier réseau yrr.
Par ailleurs ayant mon réseau dans une maison de campagne où je vais le WE, pendant la semaine j'utilise une copie des fichiers afin de faire des paramétrage "hors-ligne" que je teste le WE ou encore pour faire mes profils de vitesse sur une voie droite dédiée avec une seconde centrale chez moi à Paris...L'idée est de gagner du temps pour profiter du réseau le WE...!
Je pensais de toute façon que TC recréait ces 2 fichiers yrs et yrw à chaque sauvegarde du fichier réseau yrr...?
Revenir en haut Aller en bas
DiCoS69

DiCoS69

Nombre de messages : 12453
Age : 72
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : loisirs techniques
Date d'inscription : 10/12/2008

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 19:51

fhp2 a écrit:

Je pensais de toute façon que TC recréait ces 2 fichiers yrs et yrw à chaque sauvegarde du fichier réseau yrr...?
C'est bien ce qui se passe normalement quand des modifications sont enregistrées.
Toutefois, vu que ça persiste, sauvegarde ton fichier .yrr, refais un téléchargement et une installation de la dernière version de TC sur tes PC. Après avoir réouvert ton fichier de réseau et à nouveau enregistré, utilise bien ce dernier pour travailler en hors ligne sur ton PC parisien.
Utilises-tu la même version de Windows sur les 2 PC ?
Revenir en haut Aller en bas
fhp2

fhp2

Nombre de messages : 963
Age : 57
Localisation : Paris
Date d'inscription : 25/01/2012

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 19:56

Helas non... Mon PC de réseau est sous W7 tandis qu'à Paris j'ai un portable Apple sur lequel j'emule W7 grâce au logiciel Parallel 8.0...
Revenir en haut Aller en bas
DiCoS69

DiCoS69

Nombre de messages : 12453
Age : 72
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : loisirs techniques
Date d'inscription : 10/12/2008

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 20:03

Il est donc possible qu'il y ai quelques contrariétés sur les fichiers .yrs et .yrw
Le mieux est de ne pas les transférer sur ton PC de réseau.
Revenir en haut Aller en bas
Christophe

Christophe

Nombre de messages : 2711
Age : 61
Localisation : Nantes
Emploi : Journaliste
Date d'inscription : 07/06/2009

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 20:36

Objectivement la question des ordis ne joue pas. Es tu certain que tu transfère à chaque utilisation les 4 fichiers contenus dans le dossier ?

Soit le fichier .BAK, le fichier TrainController file et les fichiers .YRS et .YRW portant le même nom de ton choix, si tu les dissocies évidemment TC ne retrouve pas ses petits !

_________________
amicalement,
Christophe


licence RRTC Gold V9 A3, sur Mac Mini 10.11.6 avec W7 SP1 émulé avec Parallels Desktop 11

réseau RhB, Iim (LGB) en extérieur, http://traindejardin.free.fr
- pour la commande et l'alimentation de la voie, (traction et signalisation) :
Lenz LZV 100 + 2(LV 102) (soit 22 V 12 A) LAN
- pour la rétro-signalisation :
HSI LDT RS232 avec détecteurs Dicos69 + modules RM-88-N-O, (fiable à l'extérieur, même avec 45 mètres de câbles RJ45) et RM-GB-8-N pour la partie intérieure (garage du réseau).
+SmartHand sur iphone et Safari via wifi.
Utilisation de l'app TouchCab sur iOS en wifi.
Utilisation du Navigator Massoth, via un émetteur/récepteur Massoth raccordé en XpressNet sur la centrale Lenz.
Petit réseau RhB en H0m pour m'amuser à l'intérieur. Avec la même LZV 100 (sur 16V) et une rétro RS-8 de LDT. Et les mêmes commandes externes sans fils.
Revenir en haut Aller en bas
http://traindejardin.free.fr
rico

rico

Nombre de messages : 5874
Age : 54
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 20:51

Demain, je demande à mon patron pour repartir en vacances! Je ne comprends rien à vos trucs...

Il y a 3 fichiers (ou 4 si on compte le *.bak qui ne sert à rien) à copier coller, point barre!

Les seules fois où j'ai vu TC un peu patiner dans les barres d'outils, c'est quand on met la version anglaise sans le fichier de Jean. On obtient un magnifique mélange!
Revenir en haut Aller en bas
double

double

Nombre de messages : 918
Age : 63
Localisation : MARCIGNY ( 71 )
Emploi : Plus.... et c'est parfait
Loisirs : Ferromodélisme-bricolage
Date d'inscription : 13/12/2010

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 20:57

moi, pas de problèmes avec autotrain !!!
Rico si ton patron est ok, je t'héberge qq jours encore Razz  bounce
Revenir en haut Aller en bas
rico

rico

Nombre de messages : 5874
Age : 54
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 21:48

Je te communique en MP le numéro de mon boss et tu négocies avec lui!
Revenir en haut Aller en bas
DiCoS69

DiCoS69

Nombre de messages : 12453
Age : 72
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : loisirs techniques
Date d'inscription : 10/12/2008

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyLun 26 Aoû 2013 - 22:57

Christophe a écrit:
Objectivement la question des ordis ne joue pas. Es tu certain que tu transfère à chaque utilisation les 4 fichiers contenus dans le dossier ?

Soit le fichier .BAK, le fichier TrainController file et les fichiers .YRS et .YRW portant le même nom de ton choix, si tu les dissocies évidemment TC ne retrouve pas ses petits !
A vrai dire, le seul .yrr est suffisant, les autres étant créés ou modifiés à chaque fois que l'on ferme le logiciel...
Revenir en haut Aller en bas
fhp2

fhp2

Nombre de messages : 963
Age : 57
Localisation : Paris
Date d'inscription : 25/01/2012

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyJeu 29 Aoû 2013 - 10:58

Bonjour à tous. Je viens de trouver la cause de mon problème Autotrain...
Ayant coché dans les règles Autotrain l'option "ignorer les distances", lorsque je lançais un trajet Autotrain avec des cantons de départ et d'arrivée non contigus alors rien ne se passait (Autotrain ne fonctionnait pas...). Dès que j'ai décoché, tout est rentré dans l'ordre...
Est-ce que quelqu'un pourrait m'expliquer ce phénomène ?
Merci, François.
Revenir en haut Aller en bas
Geo69



Nombre de messages : 4660
Age : 71
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... EmptyJeu 29 Aoû 2013 - 12:36

Bonjour,

Si "ta" fonction Autotrain fonctionne à nouveau, tant mieux ... Very Happy mais  la règle "Ignorer les distances" concerne le choix du cheminement fait par TC dans les cas ou il a le choix entre plusieurs chemins ... Chez moi, Autotrain  fonctionne (pour des cantons contigus ou pas) que cette règle soit cochée ou pas ... Smile 

A+
Georges
Revenir en haut Aller en bas
Contenu sponsorisé




Problème avec Autotrain... Empty
MessageSujet: Re: Problème avec Autotrain...   Problème avec Autotrain... Empty

Revenir en haut Aller en bas
 
Problème avec Autotrain...
Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Autotrain-
Sauter vers: