Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 démarrage d'une machine loksound

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
kennoutch



Nombre de messages : 53
Age : 32
Localisation : Québec
Emploi : Professionnel de Recherche
Loisirs : modelisme, pc, astronomie
Date d'inscription : 30/03/2012

MessageSujet: démarrage d'une machine loksound   Lun 20 Oct - 3:04

Salut à tous,

Je reviens après quelques mois d’absence ^^

Bon aller, on rentre dans le vif du sujet !!!

Je viens de paramétrer un loksound de BB67400 au petit oignons mais je n'arrive pas à résoudre un problème avec rrtc.
Je m'explique:
Comme vous avez pu le voir (pour ceux qui ont des loksound), la machine ne démarre pas tout de suite, il y a d'abord le son de l'accélération du régime moteur puis elle démarre.

Pour avoir une belle accélération progressive de la machine seule, j'ai mis l'inertie d'accélération dans rrtc à 500% et CV3=1. Par contre, là où ça ne va pas, c'est au moment où rrtc augmente la vitesse au démarrage d'un trajet, la loco ne part pas, elle fini son cycle du son et puis PAF, elle décolle super rapidement au cran qu'indiqué par rrtc donc plus de démarrage progressif, je suis dégouté ^^.
Bien sur, ça ne le fait pas quand il n'y a pas le loksound d'activé.

Avez vous résolu ce "problème" ?? car cela implique aussi un problème avec les marqueurs virtuels qui s'activent plus tôt que prévu puisque RRTC pense que la machine est plus loin.

Bonne journée

Kennoutch
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
bijave66

avatar

Nombre de messages : 1982
Age : 68
Localisation : 66 Laroque des Albères
Emploi : retraité
Loisirs : modélisme ferroviaire
Date d'inscription : 31/01/2011

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 5:53

Bonjour, quelle valeur as tu mise au CV6, il te faut le 1/3, voire 1/4 du CV5. Et si ce n'est pas le cas, refaire le profil de vitesse après avoir modifié. Ensuite, je mets 30 au CV3 et 25 au CV4. Ce n'est que mon expérience et ça me va très bien.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
coquelicot94

avatar

Nombre de messages : 3454
Age : 65
Localisation : MAROEUIL 62
Emploi : Retraité
Loisirs : Devinez
Date d'inscription : 03/09/2008

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 6:46

Bonjour, pour les locos sonorisées, il faut faire un test sans TC pour mesurer le temps de "chauffe" réel avant démarrage de la loco.

- Ensuite dans les options du canton de départ du trajet, ajouter un temps d'attente correspondant au temps de "chauffe" Wink

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dudule

avatar

Nombre de messages : 1175
Age : 65
Localisation : fourques
Emploi : Papé à temps plein. au 01 01 14
Loisirs : modélisme air et fer et autres conceptions inutiles stockeur de stylo publicitaire (+ de 3000 dans les caisses)
Date d'inscription : 05/04/2008

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 7:44

bonjour, le profil de vitesse a t'il été fait avec le son activé?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Capitole
Un mini-canton sinon rien
avatar

Nombre de messages : 2891
Age : 64
Localisation : Région Toulousaine
Date d'inscription : 14/02/2008

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 8:14

kennoutch a écrit:
Salut à tous,
Pour avoir une belle accélération progressive de la machine seule, j'ai mis l'inertie d'accélération dans rrtc à 500% et CV3=1.
Kennoutch
Peur être une piste :
J'ai précisé à de nombreuses reprises qu'il était parfois préférable de laisser des inerties logicielles à 0, et de mettre de l'inertie au niveau décodeur (CV3 & 4) ensuite faire le profil de vitesse, mais il est recommandé de ne plus modifier ces 2 CV après profil.

En effet les sons moteurs sont indexés sur les inerties décodeur et  le déplacement de la machine, dans la mesure ou l'on place des inerties logicielles, on fausse artificiellement le comportement de la machine et bien entendu les sons.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
kennoutch



Nombre de messages : 53
Age : 32
Localisation : Québec
Emploi : Professionnel de Recherche
Loisirs : modelisme, pc, astronomie
Date d'inscription : 30/03/2012

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 11:53

salut a tous,

Je vais essayer chacune des solutions que vous m'avez donné ^^

A coquelicot94: Si je met un temps d'attente au démarrage du trajet, cela ne changera en rien le problème vu que le temps d'attente décale juste le démarrage dans rrtc et non pas le décalage entre démarrage dans rrtc et démarrage réelle. Ou alors je me trompe ???

A Dudule: Non, le profil de vitesse a était fait sans le son.

A capitole: Mais si tu laisses l'inertie au niveau décodeur, comment fais tu pour faire le profil de vitesse car avec l'inertie mise en CV3 et CV4, le profil de vitesse risque d'etre faussé ? non ? car la machine mettra un certain moment avant d'arriver à sa vitesse maximal au cran donné et de se fait, la vitesse indiqué dans rrtc ne correspondra pas à la vitesse de la machine.

Je voudrais rajouter aussi que le profil de vitesse est bon, on met ensuite l'inertie dans le logiciel en plus des CV 3 et 4 à 1 et que mon problème pour le coup, ce n'est pas le profil de vitesse mais le démarrage d'une loco sound qui est décaler entre elle même et rrtc ^^ RRTC m'indique qu'elle va, par exemple à 10km/halors qu'en reelle, celle-ci est en chauffe. Voyez vous ??
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

avatar

Nombre de messages : 5440
Age : 52
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 12:03

Je vois très bien le problème et on ne peut pas l'éviter. Mettre un peu de CV3 permet de gommer l'effet démarrage Gordini, sans pour autant gêner le profil. Il suffit juste d'augmenter un peu la distance de chaque côté du canton de mesure.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5380
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 12:44

Je crois qu'il faut diviser le problème en trois sous-problèmes: la phase de démarrage du moteur et le démarrage de la locomotive, c'est à dire le début du roulage avec la montée en régime et enfin l'arrêt.

1) la phase de démarrage du moteur. La loco est à l'arrêt, moteur coupé et on veut effectuer le démarrage du moteur avec ses bruits annexes jusqu'à ce que le moteur soit au ralenti, loco prête à démarrer.
Cela se résout par une temporisation dans les opérations au début du trajet. Comme il a été dit, il suffit de chronométrer la durée de cette phase et d'agir en conséquence dans TC.

2) le début du roulage. Cela ne se résout facilement qu'en laissant l'inertie de CV3 identique à sa valeur d'usine ou à peine plus basse. Inconvénient, si la loco doit s'arrêter dans le canton suivant le canton de départ, elle risque de ne pas avoir atteint la bonne vitesse à la sortie du premier canton et donc de freiner un peu plus brutalement que prévu. Dès le troisième canton, le problème n'existe plus.

3) Le ralentissement et l'arrêt. là, il vaut mieux laisser TC se débrouiller avec ça. Donc CV4 à la valeur la plus basse possible.

En procédant ainsi on met les meilleurs chances de son côté, notamment pour la précision des arrêts. Enfin, pour le profil de vitesse, en observant ces règles simples, on peut le faire sans activer le son.

C'est la méthode que j'emploie.

Jean Smile


_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
kennoutch



Nombre de messages : 53
Age : 32
Localisation : Québec
Emploi : Professionnel de Recherche
Loisirs : modelisme, pc, astronomie
Date d'inscription : 30/03/2012

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 16:06

Merci Jean pour cette explication.
Le point 1 et 3, je les connaissais mais pas le point 2 (qui est mon problème).
Par contre, pour le profil de vitesse, le CV3 doit-il etre à 1 ou alors à la valeur d'usine ?
car de se fait, sur le canton de mesure, si le cv3 n'est pas à 1, la loco atteindra sa vitesse max dans ce canton et non pas dès l'entrée dans celui-ci.

Kennoutch
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5380
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 16:10

Il faut faire ton profil avec CV3 à valeur d'usine. Il faudra donc poser la loco un peu plus loin de la zone de mesure de façon qu'elle ait atteint la vitesse voulue à l'entrée de la zone de mesure.

Jean

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
Capitole
Un mini-canton sinon rien
avatar

Nombre de messages : 2891
Age : 64
Localisation : Région Toulousaine
Date d'inscription : 14/02/2008

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 17:16

Je pense que les réponses données complètent ma première réponse.

Pour faire des profils avec des valeurs importantes dans les CV, pas de problème, comme le précise Jean, il faudra juste donner un peu plus de "distance" et de poser la loco plus loin, mais ce dernier point uniquement pour le réglage de la V max.

Par contre point très important, ne plus modifier CV 3 & 4 après profil.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
kennoutch



Nombre de messages : 53
Age : 32
Localisation : Québec
Emploi : Professionnel de Recherche
Loisirs : modelisme, pc, astronomie
Date d'inscription : 30/03/2012

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 18:35

Alors là, il va falloir que l'on m'explique plus en détails car si j'applique votre technique, c'est comme si je faisais le profil de vitesse sans inertie a l'accélération et que je mettais l'inertie après, puisque vous me dites qu'il faut mettre la loco  plus loin et donc qu'elle soit a sa vitesse voulue à l'entrée de la zone de mesure.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5380
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 19:11

Non, non, ce n'est pas la même chose.

Le fait de mettre de l'inertie au décodeur va permettre à la loco, pour un cran de marche donné, d'arriver sur la zone de mesure avec une vitesse V coordonnée avec le son dans le décodeur.

C'est cela que tu souhaites, me semble-t-il.

Par ailleurs, la vitesse à laquelle la zone de mesure sera parcourue sera constante, ce qui te donnera un profil de vitesse correct.

Jean

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
bijave66

avatar

Nombre de messages : 1982
Age : 68
Localisation : 66 Laroque des Albères
Emploi : retraité
Loisirs : modélisme ferroviaire
Date d'inscription : 31/01/2011

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 19:19

Je pars du principe que tant que l'effet des CV 3 et 4 ne dépasse pas les effets des inerties logicielles, tout se passe très bien, TC le gère bien et je n'ai aucun souci.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5380
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 19:32

Maurice,

Ce que tu dis ressemble beaucoup à une illusion d'optique.

Les inerties logicielles sont des paramètres de TC qui sont intégrés dans les formules de calcul pour la vitesse des trains. Au niveau des profils de vitesse, TC les ignore lors du calcul des profils et les réintègre ensuite lors de l'exploitation.

Les inerties de CVs, TC ne les connaît pas et ne peut donc pas les intégrer dans ses calculs de vitesse ni dans les profils. C'est pour cela qu'il faut lui faire croire que ces inerties sont inexistantes.

Bref, tout est dans le doigté de celui qui fait le profil de vitesse ... Smile

Jean

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
bijave66

avatar

Nombre de messages : 1982
Age : 68
Localisation : 66 Laroque des Albères
Emploi : retraité
Loisirs : modélisme ferroviaire
Date d'inscription : 31/01/2011

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 19:41

Bonsoir Jean, peut être as tu raison, mais je pense que si TC fait baisser progressivement la vitesse de la loco de 60 à 40, puis à 20 jusqu'à zéro et si le CV4 est trop élevé, TC ne gère pas cette vitesse puisque c'est le décodeur qui prends le dessus. Par contre, si le CV4 est inférieur au taux de ralentissement de TC, à ce moment là, TC gère parfaitement la vitesse de la loco.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5380
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 19:49

Reprends mas derniers posts ... je n'ai évoqué que CV3 et l'inertie à l'accélération.

Pour la décélération, j'ai dit qu'il fallait mettre CV4 à sa valeur minimale et TC se débrouiller avec car les longueurs de ralentissement peuvent être très variables d'un canton à un autre et je ne parle pas des arrêts en milieu de quai et autres joyeusetés du même genre qui font que le taux de ralentissement de TC va être très variable alors que celui de CV4 ne le sera pas.

Dans ces cas de figure, en mettant dans CV4 des valeurs plus ou moins exotiques, on s'expose à des ennuis.

D'un autre côté, en se fiant à TC, on n'aura presque plus jamais le bruit des freins dans les 5 derniers cm car l'arrêt sera trop en douceur.

Ce n'est que mon avis, bien sûr.

Jean Smile

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
bijave66

avatar

Nombre de messages : 1982
Age : 68
Localisation : 66 Laroque des Albères
Emploi : retraité
Loisirs : modélisme ferroviaire
Date d'inscription : 31/01/2011

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 19:54

Oui, je comprends, mais pour avoir un bruit de frein avec un loksound, il faut monter le CV4 au moins à 22. Wink
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Geo69



Nombre de messages : 3748
Age : 69
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 20:01

Bonsoir,

Jean_01 a écrit:
... D'un autre côté, en se fiant à TC, on n'aura presque plus jamais le bruit des freins dans les 5 derniers cm car l'arrêt sera trop en douceur...
Voilà, modestement, ce que j'ai fait pour faire crisser les freins jusqu'à l'arrêt de mon unique machine sonorisée : ICI

A+
Georges
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9916
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 20:26

N'ayant pas de machine sonorisée, je n'ai pas de problème.... Very Happy
Cependant, comme Maurice, j'ai remarqué qu'il est possible d'ajouter de l'inertie décélération par CV4 sans trop perturber la distance d'arrêt, si on pousse l'inertie logicielle au maximum.
Cela s'explique par le fait que TC fait alors diminuer la vitesse lentement, ce qui permet aux crans du décodeur d'être sensiblement synchronisés bien que mettant un certain temps pour passer de l'un à l'autre.
Ceci adoucit encore un peu plus le ralentissement.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
kennoutch



Nombre de messages : 53
Age : 32
Localisation : Québec
Emploi : Professionnel de Recherche
Loisirs : modelisme, pc, astronomie
Date d'inscription : 30/03/2012

MessageSujet: Re: démarrage d'une machine loksound   Lun 20 Oct - 21:13

Merci pour ces réponses.

J'ai de quoi faire ^^
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: démarrage d'une machine loksound   

Revenir en haut Aller en bas
 
démarrage d'une machine loksound
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» démarrage d'une machine loksound
» problème démarrage
» Loksound et profil de vitesse
» Démarrage application impossible ... [RESOLU]
» [Résolu] AVAST! démarrage impossible

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Trucs - Astuces - Solutions-
Sauter vers: