Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Défauts liés à "l'empilage" dans un canton

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : Précédent  1, 2, 3, 4, 5  Suivant
AuteurMessage
DiCoS69

avatar

Nombre de messages : 9320
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Dim 6 Nov - 18:45

Geo69 a écrit:


DiCoS69 a écrit:
... Pas plus que jouer sur la charge pour améliorer le démarrage des machines... Laughing  Laughing ...
ça, c'est mesquin !... Laughing Laughing Laughing

A+
Georges

Meuh non, je fais pareil..! Very Happy Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Manu



Nombre de messages : 66
Age : 46
Localisation : Manage Belgique
Loisirs : Le bricolage
Date d'inscription : 28/02/2011

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mer 9 Nov - 18:15

Bonsoir à tous,

J'ai bien le même problème que Rico concernant empilage/dépilage et le fait de mettre une pause de 20 sec entre les trajets ne change rien.Par contre si je fait le test avec le compteur à 1 pas de soucis.
J'essaye de faire un nouveau ficher de test simplifié avec le problème de manière a vous le faire partager.

En attendant voici la copie d'écran d'une partie de mon TCO avec les blocks entre lesquels je fais mes tests.



Je fait l'empilage/dépilage entre les blocks "Garage 12" et "Accès Garage 1 à 9" et utilise un compteur pour faire sortir le nombre de loco voulut et ensuite utilise la flèche gauche ou droite pour lancer les trajets.

Dans le pire des cas, j'ai dans le canton de départ X loco qui partent dans un sens (sans contrôle car pas lié au trajet) et une autre qui part dans le bon sens et au même moment l'ensemble des locos du canton d'arrivée qui bougent bref n'importe quoi.

A+

Manu
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9320
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Jeu 10 Nov - 0:09

Comment procèdes-tu initialement pour mettre tes locos dans le canton 12..?
Parce que si elles ne sont pas orientées correctement dans la formation de la "rame", tu peux avoir des départs erratiques.
Autre chose, chaque fois que tu veux démarrer un trajet pour une machine de la "rame" du canton 12, il faut au préalable la "séparer" des autres, donc effectuer d'une façon ou d'une autre cette séparation virtuelle (idem dans l'autre sens, bien sûr...).
Sur ton écran, c'est correct pour la loco de gauche, mais recommences-tu l'opération à chaque départ...?
Aucun nouveau départ de trajet "dépilage" ne doit avoir lieu tant que le précédent n'est pas terminé.

Quel est le déclencheur du signaleur du canton "accès Gge 1 à 9" ?
Il faut que l'activation du signaleur soit conditionnée à l'occupation du canton... est-ce fait ?
L'empilage ne semble pas correct dans le canton "accès Gge 1 à 9" car les 2 machines devraient être séparées tant qu'une troisième n'est pas rentrée... il doit y avoir une anomalie dans ton paramétrage...
Le signaleur est relâché et les marqueurs non activés... comment as-tu paramétré l'onglet "mémoire" du signaleur et des marqueurs ?

Ça fait beaucoup de questions, mais on n'a pas ton fichier sous les yeux... Very Happy Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Manu



Nombre de messages : 66
Age : 46
Localisation : Manage Belgique
Loisirs : Le bricolage
Date d'inscription : 28/02/2011

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Jeu 10 Nov - 6:17

Merci Elie pour ton analyse.

Pour le placement des locos dans le canton, je pense qu'il est bon car si je les faits sortir une à une (7 X l'opération de mettre le compteur à 1 et lancement de l'opération avec le bouton flèche à côté) pas de problème => je pense que cela enlève le doute sur la direction des locos.

Pour la séparation avant chaque départ, il est fait par les opérations lancées par le bouton flèche.



Je pense aussi que l'image ci-dessus te montre que j'attends la fin du trajet pour un lancer un autre grâce à la fonction "prerequisite"

Pour la question sur le signaleur, voilà comment je fais.



Par contre je ne tiens pas compte de l'occupation du canton. Cela peut-il poser problème?

Pour la mémoire voici la configuration




J'espère avoir répondu à la plupart de tes questions et oui il serait plus simple que je puisse partager mon fichier.

Merci et bonne journée à tous.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

avatar

Nombre de messages : 5266
Age : 51
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Jeu 10 Nov - 11:00

Je ne vois pas pourquoi tu forces une vitesse de 10 km/h. De surcroit sans fixer la direction au préalable, je ne sais pas dans quel sens peut partir ta loco.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Manu



Nombre de messages : 66
Age : 46
Localisation : Manage Belgique
Loisirs : Le bricolage
Date d'inscription : 28/02/2011

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Jeu 10 Nov - 11:07

Rico,

Justement ce parametre de vitesse n'etait pas pris en compte. La raison est sans doute le manque de direction definit avant.

Merci pour cette info. A tester ce soir.

Manu
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Manu



Nombre de messages : 66
Age : 46
Localisation : Manage Belgique
Loisirs : Le bricolage
Date d'inscription : 28/02/2011

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Jeu 10 Nov - 11:58

Rico,

Suite à ta remarque je viens de me rendre compte de mon erreur d'interprétation du paramètre speed.
Je pensais que celui-ci permettait de définir la vitesse pour mon trajet mais je comprends maintenant que celui-ci permet de bouger une loco à une vitesse donnée => le besoin de définir une direction.

Merci beaucoup, je suis impatient de tester ce soir.



Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9320
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Jeu 10 Nov - 12:59

Voila, ça avance...!
Rien de tel que des copies d'écrans pour trouver les erreurs... Very Happy Very Happy

Je pense que tu peux aussi ajouter "canton x occupé" dans les conditions de déclenchement du signaleur, car dans la mesure où il y a un marqueur d'arrêt attaché à l'indicateur d'occupation dans le même sens, il n'est pas nécessaire de faire déclencher le signaleur si le canton est libre...


Dernière édition par DiCoS69 le Jeu 10 Nov - 13:07, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Manu



Nombre de messages : 66
Age : 46
Localisation : Manage Belgique
Loisirs : Le bricolage
Date d'inscription : 28/02/2011

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Jeu 10 Nov - 13:06

Oui ça avance même à 10 km/h Laughing
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9320
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Jeu 10 Nov - 13:08

Note bien que la limitation de vitesse peut être faite dans les cantons spécifiques au trajet...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Manu



Nombre de messages : 66
Age : 46
Localisation : Manage Belgique
Loisirs : Le bricolage
Date d'inscription : 28/02/2011

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mar 15 Nov - 16:40

Bonjour à tous,

Depuis la suppression de l'action speed dans les opérations, je n'ai plus le problème des locos qui partent dans tous les sens par contre il me reste un problème qui est la non séparation de la loco dans le canton de gauche => l'ensemble des locos présente se mettent en mouvement.
Si je fais l'opération avec le compteur à 1 à ce pour chaque loco alors pas de problème la fonction séparation se passe bien.

J'ai essayé de mettre une tempo entre la fin du trajet précédent et la séparation mais pas d'amélioration.

Voici mes opérations avec tempo et log pour comprendre un peut mieux



Voici les logs



Merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
double

avatar

Nombre de messages : 759
Age : 60
Localisation : FAYENCE ( 83 )
Loisirs : Ferromodélisme-bricolage
Date d'inscription : 13/12/2010

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mar 15 Nov - 17:12

Bonsoir Manu,
tu peux pas nous mettre TC en Francais STP
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Manu



Nombre de messages : 66
Age : 46
Localisation : Manage Belgique
Loisirs : Le bricolage
Date d'inscription : 28/02/2011

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mar 15 Nov - 17:29

Désolé, voici les informations en Français





Merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

avatar

Nombre de messages : 5266
Age : 51
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mar 15 Nov - 18:25

Tu peux essayer en Allemand si tu veux Laughing  Laughing

Personnellement, je ne comprends pas tes explications ni ton problème. C'est le dépilage ou l'empilage qui ne va pas? A quoi sert le compteur (ou décompteur étant donné ta programmation) ? Le "canton de gauche", c'est le canton d'arrivée?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Geo69



Nombre de messages : 3453
Age : 68
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mar 15 Nov - 19:41

Bonsoir,

Manu a écrit:
... il me reste un problème qui est la non séparation de la loco dans le canton de gauche => l'ensemble des locos présente se mettent en mouvement.
Si je fais l'opération avec le compteur à 1 à ce pour chaque loco alors pas de problème la fonction séparation se passe bien.

J'ai essayé de mettre une tempo entre la fin du trajet précédent et la séparation mais pas d'amélioration...

As-tu regardé le détail des messages  (Bouton "Détails" dans la fenêtre "Messages") pour voir si il y avait une différence entre le cas ou tu as une séparation effective et le cas qui pose problème ?

A+
Georges
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Manu



Nombre de messages : 66
Age : 46
Localisation : Manage Belgique
Loisirs : Le bricolage
Date d'inscription : 28/02/2011

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mar 15 Nov - 19:42

J'appelle le dépilage le passage des locos du canton "Garage12" vers "accès garage 1 à 9". Ce cas fonctionne quel que soit le nombre mis dans compteur et donc le nombre de locos sortit du canton

L'empilage est pour moi la remise en place des locos du canton "Accès Garage 1 à 9 vers "Garage 12"

Le compteur me permet juste de définir combien de X je boucle mon trajet et donc combien de machine je désire sortir de la voie de garage.

Regarde ma liste d'opération sur le bouton ainsi que les boutons en fin de voie de garage 10,11,12 et je pense que tu comprendras.

J'espère être plus clair.



Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

avatar

Nombre de messages : 5266
Age : 51
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mar 15 Nov - 20:20

Manu a écrit:
J'appelle le dépilage le passage des locos du canton "Garage12" vers "accès garage 1 à 9". Ce cas fonctionne quel que soit le nombre mis dans compteur et donc le nombre de locos sortit du canton

L'empilage est pour moi la remise en place des locos du canton "Accès Garage 1 à 9 vers "Garage 12"

Le compteur me permet juste de définir combien de X je boucle mon trajet et donc combien de machine je désire sortir de la voie de garage.

Regarde ma liste d'opération sur le bouton ainsi que les boutons en fin de voie de garage 10,11,12 et je pense que tu comprendras.

J'espère être plus clair.




Toujours pas tout compris...Ce que je comprend est que ton dépilage de "Garage 12" donne de toute façon de l'empilage dans "Accès garage 1 à 9"?
C'est ce qui est réalisé par les opérations de ton bouton? Je ne sais toujours pas si c'est le dépilage ou l'empilage qui débloque dans ce trajet!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9320
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mar 15 Nov - 23:59

Manu a écrit:

il me reste un problème qui est la non séparation de la loco dans le canton de gauche => l'ensemble des locos présente se mettent en mouvement.
Si je fais l'opération avec le compteur à 1 et ce pour chaque loco alors pas de problème la fonction séparation se passe bien.
Merci

C'est donc que l'opération de séparation n'est pas enclenchée à tous les pas du compteur... peut-être parce que c'est tout "détaillé".
Tu devrais essayer en mettant la liste d'opérations dans une macro, et appeler seulement cette macro...
Aussi, y a-t-il des conditions ?
Quel élément "presse" le bouton ?
Quel type d'action bouton utilises-tu ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Manu



Nombre de messages : 66
Age : 46
Localisation : Manage Belgique
Loisirs : Le bricolage
Date d'inscription : 28/02/2011

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mer 16 Nov - 4:45

Rico a écrit:
Toujours pas tout compris...Ce que je comprend est que ton dépilage de "Garage 12" donne de toute façon de l'empilage dans "Accès garage 1 à 9"?
C'est ce qui est réalisé par les opérations de ton bouton? Je ne sais toujours pas si c'est le dépilage ou l'empilage qui débloque dans ce trajet!

Tu as bien compris: le dépilage d'un canton entraine l'empilage de l'autre.Mes commentaires sont toujours par rapport au canton "Garage12"

J'utilise le bouton flèche vers la gauche au bout du canton "garage 12" pour le dépilage et l'autre pour l'empilage

C'est l'empilage qui ne fonctionne pas.

Bonne journée

Manu
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

avatar

Nombre de messages : 5266
Age : 51
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mer 16 Nov - 7:46

Ok j'ai bien compris. C'est donc la séparation qui ne se fait que si ton compteur est à 1.

Est-ce vrai même pour la première loco sortie?

Peux-tu nous donner la configuration de ton compteur?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Manu



Nombre de messages : 66
Age : 46
Localisation : Manage Belgique
Loisirs : Le bricolage
Date d'inscription : 28/02/2011

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mer 16 Nov - 9:08

Ce n'est pas vraie pour la première loco. En effet si je met par exemple 3 dans le compteur et lance l'opération, la première loco se sépare bien par contre lors du 2 éme passage de la boucle la séparation ne se fait plus.

Pour la gestion du compteur tu as déjà l'information dans les captures d'écran. Il n'y a rien d'autre à part le bouton + et - ou je fais juste + ou - 1 sur ce compteur. Le reste ce trouve dans les opérations des boutons flèches gauche ou droite ou tu peux trouver plus haut la capture d'écran.

Merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Geo69



Nombre de messages : 3453
Age : 68
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mer 16 Nov - 10:34

Bonjour Manu,

Geo69 a écrit:
As-tu regardé le détail des messages  (Bouton "Détails" dans la fenêtre "Messages") pour voir si il y avait une différence entre le cas ou tu as une séparation effective et le cas qui pose problème ?
Tu ne m'as pas répondu. Des fois, en pointant le détail des messages (c'est plus facile en les imprimant) on trouve une piste ...  Smile

Par curiosité, tu peux nous donner ta formule d'empilage ?

A+
Georges
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Manu



Nombre de messages : 66
Age : 46
Localisation : Manage Belgique
Loisirs : Le bricolage
Date d'inscription : 28/02/2011

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mer 16 Nov - 10:49

Bonjour Georges,

En effet je ne t'ai pas répondu car je suis au travail et donc pas d'accès aux détails.

Je vais essayer d'avoir l'information ce soir.

Pour la formule j'utilise la suivante:
X-%BA-10

Bonne journée
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9320
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mer 16 Nov - 14:29

Il y a aussi d'autres questions plus haut auxquelles tu n'as pas répondues... Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

avatar

Nombre de messages : 5266
Age : 51
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   Mer 16 Nov - 18:29

Manu a écrit:
Ce n'est pas vraie pour la première loco. En effet si je met par exemple 3 dans le compteur et lance l'opération, la première loco se sépare bien par contre lors du 2 éme passage de la boucle la séparation ne se fait plus.

Ça confirme ce que je pense, c'est ton paramétrage de compteur qui ne doit pas être bon.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Défauts liés à "l'empilage" dans un canton   

Revenir en haut Aller en bas
 
Défauts liés à "l'empilage" dans un canton
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 3 sur 5Aller à la page : Précédent  1, 2, 3, 4, 5  Suivant
 Sujets similaires
-
» Détection de mouvement dans un canton...
» Entrée dans un canton occupé
» arret dans canton occupé
» Sortie de trajets et détection de train
» train ne respectant plus les arret dans le canton

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Technique-
Sauter vers: