Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Problème pont tournant Roco.

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2  Suivant
AuteurMessage
olid

avatar

Nombre de messages : 261
Localisation : Tonneins Lot & Garonne
Date d'inscription : 17/07/2007

MessageSujet: Problème pont tournant Roco.   Dim 26 Juin - 10:28

Bonjour,

J'ai du rater un épisode avec mon pont, mais je n'arrive pas à le faire fonctionner avec des trajets automatiques.

1. Le décodeur a été programmé suivant la procédure sur 180°. La voie de référence correspond bien à mon TCO. J'ai créé les boutons poussoirs pour les commandes et les voies. J'accède à toutes les voies dans les 2 sens en utilisant les boutons poussoirs.

2. Ca commence à merdouiller lorsque je clique sur la voie dans la fenêtre du pont. Seules les commandes d'accès aux voies 1 à 12 fonctionnent correctement.  Pour les 13 à 24, le pont se déplace sur le TCO mais pas physiquement. Petit tour vers les boutons poussoirs, et là je constate que seul le poussoir turn right ou left est activé, pas celui qui commande le déplacement vers la voie.

3. Quand je lance un trajet, la loco reste bloquée dans le canton d'entrée au rouge, mais l'itinéraire vers le pont est activé alors que celui ci n'est pas en position.


Merci pour votre aide.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Francis d'Auray

avatar

Nombre de messages : 128
Age : 66
Localisation : Pays d'Auray
Emploi : Retraité
Loisirs : Bricolage - modélisme - jardinage - micro
Date d'inscription : 26/12/2011

MessageSujet: Re: Problème pont tournant Roco.   Dim 26 Juin - 12:59

Bonjour,

Quand je regarde ton symbole de plaque tournante, je compte 24 sorties.
1er point il faut avoir le même nombre de voie actives que de sorties actives dans les propriétés de la plaque.
A priori je pense que ton décodeur est bien programmé avec 12 voies dont 3 ont une sortie diamétralement opposée. Pour le décodeur cela ne fait que 12 voies, les voies à double sortie ne comptent que 1 fois (12 diamètres).
Dans les propriétés de la plaque tu devrais avoir 15 voies actives à gauche et à droite dont 3 à double sortie.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.rail56.org/
olid

avatar

Nombre de messages : 261
Localisation : Tonneins Lot & Garonne
Date d'inscription : 17/07/2007

MessageSujet: Re: Problème pont tournant Roco.   Dim 26 Juin - 13:08

Bonjour,

J'ai 15 actives et 9 passives. Sur l'image, j'ai gardé pour les test que les cantons rétrosignalés (mais j'ai les voies de sortie du pont correctement en place)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Francis d'Auray

avatar

Nombre de messages : 128
Age : 66
Localisation : Pays d'Auray
Emploi : Retraité
Loisirs : Bricolage - modélisme - jardinage - micro
Date d'inscription : 26/12/2011

MessageSujet: Re: Problème pont tournant Roco.   Dim 26 Juin - 14:21

Ce que tu me dis c'est sur la fenêtre de gauche. A droite on ne représente que les voies actives, donc 15 et ne pas oublier de se mettre ensuite sur la voie 1 et de cliquer sur assigner. Il est impératif d'avoir 15 voies actives de chaque côté
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.rail56.org/
Claudius4454



Nombre de messages : 178
Age : 79
Localisation : Loire Atlantique
Emploi : Retraité
Loisirs : Modelisme ferroviaire + Randonnées
Date d'inscription : 29/08/2012

MessageSujet: Re: Problème pont tournant Roco.   Dim 26 Juin - 14:36

Bonjour,

je pense qu'il te faut recommencer la programmation en suivant point par point les conseils de jean01. Vas sur son site :http://perso.numericable.fr/dagron.jean/ dans Paquet cadeau !..
j'ai moi même mis un certain temps pour bien paramétrer.
On n'assigne que les voies actives !

Bon courage
Claudius4454
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5345
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Problème pont tournant Roco.   Dim 26 Juin - 15:31

Francis a raison.

Sur ton symbole de plaque tournante on ne devrait voir que tes 15 voies actives. Il te faut au moins revoir ton paramétrage dans l'onglet "Voies" des propriétés de la plaque.

Jean

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean En ligne
olid

avatar

Nombre de messages : 261
Localisation : Tonneins Lot & Garonne
Date d'inscription : 17/07/2007

MessageSujet: Re: Problème pont tournant Roco.   Dim 26 Juin - 15:37

Oui, je viens juste de le modifier et je n'ai plus de pb pour bouger le pont à la souris. je n'avais pas enlevé les voies passives sur la partie droite. Je teste les trajets.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
olid

avatar

Nombre de messages : 261
Localisation : Tonneins Lot & Garonne
Date d'inscription : 17/07/2007

MessageSujet: Re: Problème pont tournant Roco.   Dim 26 Juin - 16:12

En fait, c'est exactement pareil. Quand je teste un déplacement à la souris, ça ne fonctionne que si la cabine reste dans la partie 1-12. Je reprogramme Sad
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
olid

avatar

Nombre de messages : 261
Localisation : Tonneins Lot & Garonne
Date d'inscription : 17/07/2007

MessageSujet: Re: Problème pont tournant Roco.   Dim 26 Juin - 17:14

Bon, j'ai modifié mon pont et j'ai reparamétré. ca donne ca :



Et ça ne marche toujours pas.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
olid

avatar

Nombre de messages : 261
Localisation : Tonneins Lot & Garonne
Date d'inscription : 17/07/2007

MessageSujet: Re: Problème pont tournant Roco.   Dim 26 Juin - 22:33

Bon, j'ai corrigé le plan, j'ai reprogrammé par acquis de conscience et .....
Cette fois ci les trajets fonctionnent. le pont se déplace correctement sur le tco, les cantons restent au rouge tant que le pont n'est pas correctement positionné.
Le hic, c'est qu'en fonction de la position du pont, il ne démarre pas nécessairement. Le contact de rétro du pont sert au moins à maintenir verrouillée l'entrée sur le pont, mais ça ne m'avance pas beaucoup.
Je fait tous les déplacement depuis 1 à 11 coté cabine vers 12 en horaire et de 12 à 1 en anti horaire
mais impossible de faire 1 vers 24 en antihoraire ou13 - 16 en horaire. Le poussoir turn s'active et c'est le seul.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Claudius4454



Nombre de messages : 178
Age : 79
Localisation : Loire Atlantique
Emploi : Retraité
Loisirs : Modelisme ferroviaire + Randonnées
Date d'inscription : 29/08/2012

MessageSujet: Re: Problème pont tournant Roco.   Lun 27 Juin - 7:34

Bonjour,

Chaque que tu fais une reprogrammation, il ne faut jamais oublier de réinitialiser le pont et RRTC, car la centrale ou le Décodeur TT-DEC finissent toujours par garder une petite partie de la précédente programmation me semble t-il !
Par ailleurs lors de la programmation de la dernière position, il faut appuyer sur "end" et surtout ne pas passer à la position de référence pour appuyer sur "end".
j'ai mis un certain temps pour comprendre de petit détail qui n'est pas bien précisé dans les mises en oeuvre. Mais tu vas y arriver !
Claudius4454
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
olid

avatar

Nombre de messages : 261
Localisation : Tonneins Lot & Garonne
Date d'inscription : 17/07/2007

MessageSujet: Re: Problème pont tournant Roco.   Lun 27 Juin - 10:24

Je le fait. Aujourd'hui, j'ai créé une plaque dans un nouveau fichier, tous les boutons poussoirs, et en simulation, quand je clique sur la position 24 en antihoraire, seul le poussoir turn left s'actionne, pas le voie 11.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Francis d'Auray

avatar

Nombre de messages : 128
Age : 66
Localisation : Pays d'Auray
Emploi : Retraité
Loisirs : Bricolage - modélisme - jardinage - micro
Date d'inscription : 26/12/2011

MessageSujet: Re: Problème pont tournant Roco.   Lun 27 Juin - 12:05

Bonjour,

Peux-tu me préciser qu'elle est la voie 1 et me confirmer que l'assignation a bien été faite. Les coches avant ou arrière sont-elles activées pour chaque voie. A ce stade je pense qu'il vaut mieux ne pas les activer pour laisser libre le sens de déplacement du pont.
Je te propose de créer un bouton en mode "perform operation" et dans l'onglet opération, choisir la plaque tournante et en cliquant dessus dans colonne de droite, sélectionner une voie à atteindre dans le mode marqueur cabine. Dans ce mode ce sera toujours la cabine qui viendra devant la voie appelée. En changeant le n° de voie, tu pourras tester toutes les positions en s'affranchissant des conditions de sortie du pont.
Pour tester le décodeur tu peux aussi faire un bouton, (ou une commande d'aiguillage sur la centrale) en mode connecté cette fois à partir de l'adresse 213 ou 229 selon le plan d'adressage choisi voie 1 = "dévié" rouge et voie 2 = "droit" vert. Cela te permettra de tester le décodeur en incrémentant les adresses et les positions "déviée" ou "droit". Dans ce mode l'image du TCO ne tournera pas.
Vérifies aussi que la voie 1 est bien reconnue comme voie de référence par le décodeur. Je ne sais pas quel décodeur tu utilises, ce n'est pas indiqué dans ta signature.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.rail56.org/
olid

avatar

Nombre de messages : 261
Localisation : Tonneins Lot & Garonne
Date d'inscription : 17/07/2007

MessageSujet: Re: Problème pont tournant Roco.   Lun 27 Juin - 15:15

Je viens de faire un test rapide :

En utilisant directement les boutons poussoirs turn left + voie 12 le pont se positionne correctement sur la voie 24.
En utilisant un poussoir avec les différentes options opérations de plaque : que dalle. Il n'y a que le poussoir turn left ou right qui s'active.

Et mon décodeur est un TT-Dec de LDT.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
olid

avatar

Nombre de messages : 261
Localisation : Tonneins Lot & Garonne
Date d'inscription : 17/07/2007

MessageSujet: Re: Problème pont tournant Roco.   Mar 28 Juin - 21:44

Cette fois ci je déprime pour de bon Crying or Very sad
J'ai tout repris à zéro.

Reset du décodeur (TT-DEC -R)
Programmation du décodeur
Paramétrage du pont





Le TCO


La voie 1 est bien assignée à la position de référence.
L'image du pont est bien synchronisée avec sa position réelle.
Tous les ordres donnés avec les poussoirs sont pris en compte.
Juste cette foutue cabine qui tient à rester absolument dans le demi cercle supérieur. Tout ordre à la souris ou par un trajet  devant la conduire dans la partie inférieure entraine le déclenchement d'un Turn mais pas d'ordre de voie. Les seuls déplacements qui permettent de la déplacer dans la partie inférieure sont les deux step et le 180°.

J'ai crée un nouveau fichier avec juste une plaque et rien d'autre. Même chose.

J'ai fait les tests préconisés par Francis. Pareil.

J'ai pris des sauvegardes d'il y a 2 ans. Idem.

Je dois sûrement faire la même conn.... à chaque fois mais je ne vois pas laquelle. J'en perds mon RRTC.


Dernière édition par olid le Mer 29 Juin - 15:54, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9825
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Problème pont tournant Roco.   Mar 28 Juin - 23:34

Et si tu décoches la "cabine à droite"...?
Mais je dis n'importe quoi...je n'ai pas de pont... Very Happy
As-tu positionné le jumper sur position 3 rails sur le TT-DEC ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Mcar

avatar

Nombre de messages : 1103
Age : 60
Localisation : Budapest (HU) / Longwy (54)
Loisirs : Modélisme ferroviaire
Date d'inscription : 29/03/2010

MessageSujet: Re: Problème pont tournant Roco.   Mer 29 Juin - 11:05

Dans l'onglet opération, sur chaque position de voie, as tu mis quelque chose ?
verifier sur toutes les positions

" />
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
olid

avatar

Nombre de messages : 261
Localisation : Tonneins Lot & Garonne
Date d'inscription : 17/07/2007

MessageSujet: Re: Problème pont tournant Roco.   Mer 29 Juin - 15:54

Citation :
Et si tu décoches la "cabine à droite"...?
Ca ne change rien.
Citation :
As-tu positionné le jumper sur position 3 rails sur le TT-DEC ?
Oui
Citation :
Dans l'onglet opération, sur chaque position de voie, as tu mis quelque chose ?
verifier sur toutes les positions
C'est vide pour toutes les opérations pour les 24 voies actives ou passives.

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
olid

avatar

Nombre de messages : 261
Localisation : Tonneins Lot & Garonne
Date d'inscription : 17/07/2007

MessageSujet: Re: Problème pont tournant Roco.   Jeu 30 Juin - 15:46

En désespoir de cause, un log des messages lorsque je lance un trajet :

Trajet qui fonctionne cabine du pont sur voie 7 devant aller vers voie 10

Push Button '' executes operation of Schedule 'Triage - Fret 1 --> Pont tournant'.
***** Try to start Schedule 'Triage - Fret 1 --> Pont tournant' for any train by Schedule 'Triage - Fret 1 --> Pont tournant'. *****
The settings of Schedule 'Triage - Fret 1 --> Pont tournant' prevent the use of the occupied Block 'Fret 1 - Entrée B1 B2/Sortie B1 B2' by '-'.
Block 'PT 10 - Par triage' available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 10 - Par triage' available for Engine 'L47 - DB E 120'.
Block 'PT' available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 12' available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 10 - Par triage' reserved for Engine 'L47 - DB E 120'.
Block 'PT' reserved for Engine 'L47 - DB E 120'.
Schedule 'Triage - Fret 1 --> Pont tournant' successfully initialized for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 12' not available for Engine 'L47 - DB E 120'.
Engine 'L47 - DB E 120' started by Schedule 'Triage - Fret 1 --> Pont tournant' in Block 'PT 10 - Par triage'.
Route 'PT<-->PT 10 - Par triage' executes operation of Turntable 'Pont tournant'.
***** Event from railroad received for Contact Indicator 'Pont tournant - Position atteinte'. *****
Contact Indicator 'Pont tournant - Position atteinte' is turned off.
Route 'PT<-->PT 12' not available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 11' not available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 10 - Par triage' executes operation of Route 'PT<-->PT 10 - Par triage'.
***** Event from railroad received for Route 'PT<-->PT 10 - Par triage'. *****
Route 'PT<-->PT 10 - Par triage' is activated.
Route 'PT<-->PT 12' not available for Engine 'L47 - DB E 120'.
Main signal has changed for Engine 'L47 - DB E 120' on Schedule 'Triage - Fret 1 --> Pont tournant'.
Execute After-Stop Operation for Engine 'L47 - DB E 120' on Schedule 'Triage - Fret 1 --> Pont tournant' at Block 'PT 10 - Par triage'.
***** Event from railroad received for Contact Indicator 'Pont tournant - Position atteinte'. *****
Contact Indicator 'Pont tournant - Position atteinte' is turned on.

Trajet qui ne fonctionne pas départ cabine voie 1 vers voie 10 :

***** Event from railroad received for Push Button 'Pont tournant - V02'. *****
Try to execute Schedule 'Triage - Fret 1 --> Pont tournant' from the user interface or by timetable.
***** Try to start Schedule 'Triage - Fret 1 --> Pont tournant' for any train by Schedule 'Triage - Fret 1 --> Pont tournant'. *****
The settings of Schedule 'Triage - Fret 1 --> Pont tournant' prevent the use of the occupied Block 'Fret 1 - Entrée B1 B2/Sortie B1 B2' by '-'.
Block 'PT 10 - Par triage' available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 10 - Par triage' available for Engine 'L47 - DB E 120'.
Block 'PT' available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 12' available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 10 - Par triage' reserved for Engine 'L47 - DB E 120'.
Block 'PT' reserved for Engine 'L47 - DB E 120'.
Schedule 'Triage - Fret 1 --> Pont tournant' successfully initialized for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 11' not available for Engine 'L47 - DB E 120'.
Engine 'L47 - DB E 120' started by Schedule 'Triage - Fret 1 --> Pont tournant' in Block 'PT 10 - Par triage'.
Route 'PT<-->PT 10 - Par triage' executes operation of Turntable 'Pont tournant'.
***** Event from railroad received for Push Button ''. *****
Route 'PT<-->PT 12' not available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 11' not available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 12' not available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 10 - Par triage' executes operation of Route 'PT<-->PT 10 - Par triage'.
***** Event from railroad received for Route 'PT<-->PT 10 - Par triage'. *****
Route 'PT<-->PT 10 - Par triage' is activated.
Route 'PT<-->PT 11' not available for Engine 'L47 - DB E 120'.
Main signal has changed for Engine 'L47 - DB E 120' on Schedule 'Triage - Fret 1 --> Pont tournant'.
Execute After-Stop Operation for Engine 'L47 - DB E 120' on Schedule 'Triage - Fret 1 --> Pont tournant' at Block 'PT 10 - Par triage'.

J'ai cet ordre bizarre venant de je ne sais ou qui active le poussoir adresse 229 contact 1 donc qui conduit le pont sur les voies 2 - 14

Dans l'inspecteur, rien qui utilise ce bouton




Trajet qui ne fonctionne pas départ cabine voie 3 vers voie 10 :

***** Event from railroad received for Push Button 'Pont tournant - Turn'. *****
Push Button '' executes operation of Schedule 'Triage - Fret 1 --> Pont tournant'.
***** Try to start Schedule 'Triage - Fret 1 --> Pont tournant' for any train by Schedule 'Triage - Fret 1 --> Pont tournant'. *****
The settings of Schedule 'Triage - Fret 1 --> Pont tournant' prevent the use of the occupied Block 'Fret 1 - Entrée B1 B2/Sortie B1 B2' by '-'.
Block 'PT 10 - Par triage' available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 10 - Par triage' available for Engine 'L47 - DB E 120'.
Block 'PT' available for Engine 'L47 - DB E 120'.
Route 'PT 01<-->PT' available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 10 - Par triage' reserved for Engine 'L47 - DB E 120'.
Block 'PT' reserved for Engine 'L47 - DB E 120'.
Schedule 'Triage - Fret 1 --> Pont tournant' successfully initialized for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 09' not available for Engine 'L47 - DB E 120'.
Engine 'L47 - DB E 120' started by Schedule 'Triage - Fret 1 --> Pont tournant' in Block 'PT 10 - Par triage'.
Route 'PT<-->PT 10 - Par triage' executes operation of Turntable 'Pont tournant'.
***** Event from railroad received for Push Button ''. *****
Route 'PT 03<-->PT' not available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 09' not available for Engine 'L47 - DB E 120'.
Route 'PT 24<-->PT' not available for Engine 'L47 - DB E 120'.
Route 'PT<-->PT 09' cannot be activated - Turntable 'Pont tournant' is in use by another route.
Engine 'L47 - DB E 120' is waiting for continuation on Schedule 'Triage - Fret 1 --> Pont tournant' ...
Engine 'L47 - DB E 120' terminated Schedule 'Triage - Fret 1 --> Pont tournant' in Block 'PT 07'.
Cannot start any train on Schedule 'Triage - Pont 15' -schedule contains less than 2 blocks.
Cannot start any train on Schedule 'Triage - Pont 16' -schedule contains less than 2 blocks.
Unable to start a successor of Schedule 'Triage - Fret 1 --> Pont tournant'.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5345
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Problème pont tournant Roco.   Jeu 30 Juin - 17:28

Dans le premier trajet qui ne fonctionne pas, tu veux aller de Voie 1 à Voie 10.

Tu as choisi pour ta plaque tournante, la plage d'adresses à partir de l'adresse 225.

Si on prend le tableau de paramétrage du TT-Dec, l'adresse 229 est la voie 1. Si tu as un bouton poussoir à la même adresse, et que ton trajet active l'adresse 229, il est normal que ton poussoir reçoive un ordre.

J'ai comme l'impression que ta programmation du décodeur n'est pas correcte. Cela dit, je ne suis pas spécialiste.

Jean  Smile

P.S: si tu francisais TC, les non anglophones pourraient mieux te donner un coup de main. Mais bon, ce que j'en dis. Mad

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean En ligne
olid

avatar

Nombre de messages : 261
Localisation : Tonneins Lot & Garonne
Date d'inscription : 17/07/2007

MessageSujet: Re: Problème pont tournant Roco.   Jeu 30 Juin - 18:50

Mon pont est positionné en voie 1 et le train démarre du canton PT10.
Donc le premier ordre devrait être un déplacement du pont vers ce PT10, ce qui se passe parfaitement en simulation. Sauf que pour aller sur PT10 il me faudrait un ordre soit tourner à droite voie 10 soit tourner à gauche voie 10. Vue la configuration, le plus rapide est d'amener le pont coté sans cabine en 10 donc gauche 10. C'est à ce moment que ça coince, les poussoirs restent parfaitement immobiles. Mais je me contenterais d'un droite 10 qui lui fonctionne parfaitement.
Ce qui m'interpelle et que je ne comprends pas c'est que lorsque le trajet fonctionne, je ne vois pas de  commande de pont dans le log et lorsque ça ne marche pas, j'ai des commandes de pont incongrues.
Pour la programmation du pont, l'utilisation des différentes combinaisons de poussoirs fonctionne parfaitement. Je présume que le décodeur est bien programmé.

Ce qui coince ce sont tous les déplacements qui font franchir la ligne de séparation V1-V12 à la cabine. Et je ne sais pas pourquoi.

Citation :
P.S: si tu francisais TC, les non anglophones pourraient mieux te donner un coup de main. Mais bon, ce que j'en dis. Mad
C'est fait depuis des années Very Happy
Mais j'ai refait une install propre de RRTC pour tester.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9825
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Problème pont tournant Roco.   Jeu 30 Juin - 22:48

olid a écrit:
C'est à ce moment que ça coince, les poussoirs restent parfaitement immobiles. Mais je me contenterais d'un droite 10 qui lui fonctionne parfaitement.

Que les poussoirs ne bougent pas ne veut pas dire qu'ils ne sont pas actionnés.

En tous cas, le problème semble venir d'un défaut d'adressage puisque le pont est envoyé sur une autre voie que celle demandée...
Le pont est déclaré en 24 voies, alors, pourquoi choisir l'adresse de base 225...?
Ne serait-ce pas plus indiqué de choisir 209..?
Autre chose, as-tu bien utilisé vert pour "contact 1" et rouge pour "contact 2" dans le paramétrage des boutons ?
D'après tes descriptions de dysfonctionnement, je serais tenté de penser que ta voie de référence n'est pas la bonne...


Dernière édition par DiCoS69 le Jeu 30 Juin - 23:39, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
olid

avatar

Nombre de messages : 261
Localisation : Tonneins Lot & Garonne
Date d'inscription : 17/07/2007

MessageSujet: Re: Problème pont tournant Roco.   Jeu 30 Juin - 23:32

j'ai créé les poussoirs nécessaires à la programmation du pont (1ère colonne) et ceux permettant d'atteindre les voies (colonne 2)



Lorsque je donne un ordre de déplacement à la souris par exemple clic droit sur la voie 4, je vois les poussoirs turn right et voie4 s'activer et le pont fonctionne parfaitement. Si je donne un ordre clic gauche sur la voie 24, je vois seulement le poussoir turn left s'activer Le pont se déplace sur le TCO, mais pas en réel. Idem lorsque je lance un trajet en auto. Si par contre, c'est moi qui active les poussoirs, le pont se déplace à la position désirée (mais pas sur le TCO). En fait, lorsqu'un ordre est donné par TC (soit par un trajet, soit par la souris), il ne fonctionne correctement que si la cabine peut rester dans le demi cercle supérieur. Si la cabine doit franchir la ligne de séparation pour aller dans la partie inférieure (comme pour aller de 1 à 24 où c'est l'extrémité sans cabine qui doit en fait remonter vers la voie 12), seul l'ordre turn (right ou left) s'exécute. De plus si j'exécute à la souris un demi tour, ça fonctionne parfaitement, ça retourne la cabine dans le demi cercle inférieur, et ce sont tous les déplacements qui lui ferait franchir la ligne pour repasser dans la partie supérieure qui ne fonctionnent plus (sauf le 1/2 tour)

Je pense que le pont est correctement indexé puisque toutes les commandes fonctionnent correctement, mais qu'il y a un problème entre le pont et TC qui n'arrive pas à interpréter correctement certaines commandes.

J'ai fait et refait la procédure plusieurs fois sans résultat. J'ai créé un nouveau fichier avec seulement un pont, les boutons poussoirs et rien d'autre et j'ai toujours le même problème en réel ou en simulation. Je dois probablement oublier ou rater un morceau, mais je ne vois pas lequel.

Nb : le pont est sur sa position de réf sur les images et les voies actives sont de 1 à 12, 16, 23 et 24
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9825
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Problème pont tournant Roco.   Jeu 30 Juin - 23:45

As-tu essayé avec le bloc d'adresses 14 (209 à 224) ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
olid

avatar

Nombre de messages : 261
Localisation : Tonneins Lot & Garonne
Date d'inscription : 17/07/2007

MessageSujet: Re: Problème pont tournant Roco.   Jeu 30 Juin - 23:48

Oui, mais qu'en simulation et c'est la même chose.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Problème pont tournant Roco.   

Revenir en haut Aller en bas
 
Problème pont tournant Roco.
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 2Aller à la page : 1, 2  Suivant

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Les Trajets et Itinéraires-
Sauter vers: