Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Switchpilot servo

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
pat'N38



Nombre de messages : 24
Localisation : isere
Emploi : retraité
Loisirs : rando vtt bateau mécanique
Date d'inscription : 14/04/2016

MessageSujet: Switchpilot servo   Dim 6 Nov - 18:26

Bonsoir,
je voudrais vous faire part d'un problème que je rencontre de façon systématique avec mes 7 switchpilot servo, et savoir si c'est un problème connu et s'il y a des solutions palliatives.
Je décris d'abord ma conffig :
- centrale LENZ LZV100 + TR100 pour l'alim
- bornes TrkA/B des switchpilot servo connectées à J/K du LZV100
- bornes PwA/B des SPS connectées à une alim DC 16V -3A (kit Conrad)
- chaque SPS raccordé à 4 servos SG90 tower pro.
La programmation des adresses, position et vitesse des servos s'est déroulée parfaitement et j'étais enchanté de ces appareils, hormis le phénomène que j'essaye de décrire ci-dessous:

Constat :systématiquement à chaque mise sous tension de l'alim externe, bagottage intempestif des servos. De plus à la fin du bagottage (qui ne dure qu'une fraction de seconde), les servos ne stoppent pas nécessairement à leur position d'arrêt préprogrammée.
Je suspecte la faiblesse de l'alim externe car si on table sur un appel de ct ~300mA par servo x 28 servos = un pic de ct de presque 10A qui ne peut vraisemblablement pas être fourni par mon alim!
J'ai essayé le modifier la CV50 avec valeur 4 (coupure alim si pas d'impulsion) : plus de bagottage à la mise sous tension, mais cela dégrade le débattement lors de la commande de mouvement, comme si le bagottage se produisait à ce moment là!

Je me demande si ce phénomène a vraiment une solution car je me souvient de mes années aéromodélismes où effectivement les servos oscillaient aussi à la mise  sous tension?!

Merci de vos expériences et conseils
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Francis d'Auray

avatar

Nombre de messages : 128
Age : 65
Localisation : Pays d'Auray
Emploi : Retraité
Loisirs : Bricolage - modélisme - jardinage - micro
Date d'inscription : 26/12/2011

MessageSujet: Re: Switchpilot servo   Dim 6 Nov - 18:48

Bonsoir,

Sur notre réseau  du club nous avons exclusivement des switchpilot (24). Nous avons eu ce phénomène. Les pistes à creuser:

Interférences avec les câbles de puissance, éloigner les câbles de servo des feeders pour séparer les courants faibles des courants forts
Action sur la CV50 qui coupe le courant une fois la position atteinte sur les switch V2
Préférer une alimentation continue, en alternatif c'est pire!
Actualiser le réseau après démarrage (menu caché du menu RRTC)

Voilà ce que je peux t'indiquer d'après expérience.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.rail56.org/
pat'N38



Nombre de messages : 24
Localisation : isere
Emploi : retraité
Loisirs : rando vtt bateau mécanique
Date d'inscription : 14/04/2016

MessageSujet: Switchpilot servo    Dim 6 Nov - 19:04

Merci Francis de ta réponse. Effectivement je n'ai pas pensé aux câbles et vu les longueurs que j'ai, peut être que....
Pour ce qui est de la CV50 j'avais bien essayé mais je suis revenu en arrière à cause de la commande de mouvements qui ne me parait pas "propre".
Je vais néanmoins réessayer méthodiquement ces recommandations.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9417
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Switchpilot servo   Dim 6 Nov - 19:04

Oui, il y a une instabilité quasi obligatoire de la position des servos au moment de la mise sous tension, c'est plus ou moins sensible en fonction des modèles de servos.
La faiblesse de l'alim. peut aussi être en cause (pour 64 servos, j'utilise une alim. 5vcc de 30A, mais pas avec des SPS Esu).
Pour tenter de minimiser le phénomène essaie de démarrer l'alim. 16v avant de lancer le DCC... le résultat n'est pas garanti, ce peut être pire, tout dépend comment les décodeurs traitent la commande des servos.
En tout état de cause, ce qui est plus gênant, c'est s'ils ne se positionnent pas correctement à leur point programmé... la cause peut venir des servos eux-même... (manque de finesse des pas).
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
pat'N38



Nombre de messages : 24
Localisation : isere
Emploi : retraité
Loisirs : rando vtt bateau mécanique
Date d'inscription : 14/04/2016

MessageSujet: Switchpilot servo    Dim 6 Nov - 19:34

C'est bien ce que je crains Elie, et ds ce cas celà ruine un peu le mode de commande par servo ce qui est vraiment dommage. je vais aussi tenter de démarrer séquentiellement les SPS pour moins solliciter l'alim mais je crains que l'on ne puisse pas éliminer totalement le phénomène. Le pire c'est que je crois que ds les cas de bagottage "sévère" il peut y avoir, me semble t-il, désynchronisation de la position du servo donc de la lame d'aiguillage par rapport au contact du NO/NF de l'extension du SPS! (à confirmer qd même).

Quelqu'un a t-il une expérience des modules TAM VALLEY DEPOT (octopus, quad pic..), pour savoir s'il présentent la même anomalie?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Gaetan974

avatar

Nombre de messages : 557
Age : 59
Localisation : Ile de la Réunion
Emploi : En Vacances Eternelles
Loisirs : Modelisme
Date d'inscription : 09/02/2013

MessageSujet: Re: Switchpilot servo   Dim 6 Nov - 20:03

Bonsoir tout le monde  Very Happy

Je viens alimenter la discussion sur le sujet des switch pilots.

C'est la même chose pour moi, la version des switch pilots est la V1, les alimentations 16 V sont aux nombres de 3 que je mets en route avec un écart de 2 s, le mouvement des servos ne dépasse pas 1.5 s





Depuis le début ça danse mais cela fonctionne très bien.


Par contre, j'ai fini le câblage général et il me manquait un switch pilot, j'ai pris dans mon stock les nouvelles versions V 2 qui ont des petites leds.





J'ai tester un premier, je lui mets son adresse, je connecte les quatre servos, essais tout vas bien.

Je redémarre le réseau et la, vibration des servos pas du tout comme pour les Version 1, en plus le boitier chauffe.

J'ouvre le boitier, c’est l’espèce de triac deux pattes soudés mais celle du milieu, on dirait qu’elle est coupée.

J’ai contrôlé les 6 SPS neuf encore dans leur boite et toujours le même problème.

Est-ce que quelqu’un aurait eu ce défaut  confused  Suspect
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
pat'N38



Nombre de messages : 24
Localisation : isere
Emploi : retraité
Loisirs : rando vtt bateau mécanique
Date d'inscription : 14/04/2016

MessageSujet: Re: Switchpilot servo   Dim 6 Nov - 20:42

Bonsoir Gaetan, si tu parles du composant en haut à gauche (7805) il s'agit du régulateur 5V; selon l'alimentation (16V ds ton cas) il doit évacuer 16-5=11V x l'intensité consommée ce qui fait qq watts donc échauffement inévitable.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9417
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Switchpilot servo   Lun 7 Nov - 0:19

Gaëtan, j'ai répondu dans ton autre post...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9417
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Switchpilot servo   Lun 7 Nov - 0:20

pat'N38 a écrit:
C'est bien ce que je crains Elie, et ds ce cas celà ruine un peu le mode de commande par servo ce qui est vraiment dommage. je vais aussi tenter de démarrer séquentiellement les SPS pour  moins solliciter l'alim mais je crains que l'on ne puisse pas éliminer totalement le phénomène. Le pire c'est que je crois que ds les cas de bagottage "sévère" il peut y avoir, me semble t-il, désynchronisation de la position du servo donc de la lame d'aiguillage par rapport au contact du NO/NF de l'extension du SPS! (à confirmer qd même).

Quelqu'un a t-il une expérience des modules TAM VALLEY DEPOT (octopus, quad pic..), pour savoir s'il présentent la même anomalie?

Tu as aussi maintenant Digikeijs qui propose un décodeur pour servos ICI
Est inclus la commande pour des relais auxiliaires de polarisation qui sont aussi au catalogue... la doc. pdf téléchargeable comporte le français.
Distribué par Boutique train ICI


Dernière édition par DiCoS69 le Lun 7 Nov - 0:43, édité 5 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9417
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Switchpilot servo   Lun 7 Nov - 0:25

pat'N38 a écrit:
Bonsoir Gaetan, si tu parles du composant en haut à gauche (7805) il s'agit du régulateur 5V; selon l'alimentation (16V ds ton cas) il doit évacuer 16-5=11V x l'intensité consommée ce qui fait qq watts donc échauffement inévitable.

As-tu essayé d'alimenter en 12VAC au lieu de 16VAC, à mon avis, c'est jouable, car le reste de l'électronique doit aussi fonctionner sous 5V...
Peut-être même que 9VAC serait suffisants...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Larist



Nombre de messages : 772
Age : 69
Localisation : 72
Emploi : retraité
Loisirs : Voyages bricolage modélisme
Date d'inscription : 07/09/2011

MessageSujet: Re: Switchpilot servo   Mer 9 Nov - 12:24

Bonjour,

J'ai constaté un phénomène similaire avec des servos Y-3009 Modelcraft sur un SwitchPilot V2 alimenté en 16V AC.
J'ai fait de multiples essais en combinant les valeurs de cv50 avec d'autres cv (je ne me souviens plus desquels). Je n'ai jamais réussi à avoir un fonctionnement correct et installé à la place des ESU qui fonctionnent très bien.

Mais en installant les Y-3009 sur SwitchPilot V1 ils fonctionnent bien.

A+

Alain
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
pat'N38



Nombre de messages : 24
Localisation : isere
Emploi : retraité
Loisirs : rando vtt bateau mécanique
Date d'inscription : 14/04/2016

MessageSujet: Re: Switchpilot servo   Mer 9 Nov - 16:38

Merci Alain pour cette info. Pareil j'ai essayé à peu près toutes les combinaisons de CV sans résultat. Je viens de commander une alim bcp plus puissante (10A) pour voir mais je doute du résultat. Je vais aussi faire l'essai avec des servos de modélisme ROBBE à priori plus sérieux...
A suivre!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9417
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Switchpilot servo   Mer 9 Nov - 23:26

Un bon micro-servo à un prix raisonnable: le RX55 Rextor ICI

Pas trop rapide, il a une bonne finesse de pas propice à notre utilisation...
J'en ai une dizaine en activité que j'ai (malheureusement) payés plus chers... bien avant qu'ils ne soient en promo..!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Gaetan974

avatar

Nombre de messages : 557
Age : 59
Localisation : Ile de la Réunion
Emploi : En Vacances Eternelles
Loisirs : Modelisme
Date d'inscription : 09/02/2013

MessageSujet: Re: Switchpilot servo   Jeu 10 Nov - 4:41

Bonjour Patrick Very Happy

Je rejoins ELIE sur la qualité des servos, pour ne pas avoir de soucis comme j'ai eu avec le SPS v2, il faut des servos d'un minimum de 6 € (35 frs).

Cela tombait bien, j'ai des élevages de servos dans mon atelier, avec tout les tests, le problème de la vibration vient de la recopie potentiométrique, en fonction de la qualité, il retrouve + ou - vite son zéro study
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Capitole
Un mini-canton sinon rien
avatar

Nombre de messages : 2750
Age : 64
Localisation : Région Toulousaine
Date d'inscription : 14/02/2008

MessageSujet: Re: Switchpilot servo   Jeu 10 Nov - 8:26

Bonjour à tous.

Il faut tirer une conclusion de tout cela :
Les Switcpilot's V2 apportent plus de possibilités de paramétrage, mais exigent des servos de bonne qualité.
La version V1 acceptait plus facilement des servos de basse qualité.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Larist



Nombre de messages : 772
Age : 69
Localisation : 72
Emploi : retraité
Loisirs : Voyages bricolage modélisme
Date d'inscription : 07/09/2011

MessageSujet: Re: Switchpilot servo   Jeu 10 Nov - 11:13

Même 6 € mini n'est pas garanti. Pour info le Y-3009 Modelcraft qui ne fonctionne pas est à 6,39 € chez Conrad. Le ESU est à 14.95 € chez CDF avec un support de fixation intéressant.

A+

Alain
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9417
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Switchpilot servo   Jeu 10 Nov - 12:42

Le prix seul ne fait pas la qualité, car selon le vendeur, il peut varier considérablement... mais il donne une indication en comparant les prix chez le même vendeur...
Le servo que j'indique, par exemple, était à 9€ il y a quelques mois... et même à 12€ chez certains...
Cependant, il vaut mieux se fier aux indications des utilisateurs... sachant que dans une série, il y a parfois des loupés, et que de nos jours, c'est le client qui "débogue"..!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Switchpilot servo   

Revenir en haut Aller en bas
 
Switchpilot servo
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» programmation servo avec switchpilot servo. Intellibow IR.
» Laurentr
» Switchpilot servo
» switchpilot de ESU ?
» switchpilot

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Technique-
Sauter vers: