Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Probleme avec la G1?

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Mcar

avatar

Nombre de messages : 1051
Age : 60
Localisation : Budapest (HU) / Longwy (54)
Loisirs : Modelisme ferroviaire et moto sur piste
Date d'inscription : 29/03/2010

MessageSujet: Probleme avec la G1?   Ven 6 Jan - 20:15

bonsoir à vous tous,

voilà mon problème,
créer un bouton poussoir, un switch on-off , un compteur
dans "opérations" du bouton poussoir , mettre à l’état 1 le switch on-off
dans opérations de ce bouton on-off switch on incrémente le compteur
résultat :
le compteur s’incrémente autant de fois que j'appuie sur le bouton poussoir
de mon point de vue le compteur doit s’incrémenter une seule fois, en fait le premier appui sur le bouton poussoir, et c'est tout. pour qu'il se reincremente de +1 le switch on-off doit repasser par à 0.

je n'ai plus les anciennes version pour tester,
pour info, je suis en version anglaise
un avis ? est ce normal ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5276
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Probleme avec la G1?   Ven 6 Jan - 21:20

Test effectué avec la V8.F6, le comportement est le même qu'avec la V8.G1, tel que tu l'as décrit, le compteur est incrémenté à chaque appui sur le bouton poussoir.

Pour obtenir le comportement que tu souhaites, il faut mettre l'état "off" de l'interrupteur comme condition dans le bouton poussoir.

Le résultat est identique avec la V8.F4.

Jean Smile

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
Mcar

avatar

Nombre de messages : 1051
Age : 60
Localisation : Budapest (HU) / Longwy (54)
Loisirs : Modelisme ferroviaire et moto sur piste
Date d'inscription : 29/03/2010

MessageSujet: Re: Probleme avec la G1?   Sam 7 Jan - 8:42

Merci Jean pour cette réponse,
mais honnêtement, ce comportement me semble illogique.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

avatar

Nombre de messages : 5293
Age : 52
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

MessageSujet: Re: Probleme avec la G1?   Sam 7 Jan - 10:42

Je viens de faire le test en V8 G2, le résultat est le même! Ce n'est effectivement pas très logique...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9472
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Probleme avec la G1?   Sam 7 Jan - 13:17

Oui et non...
Supposons, par exemple, que tu veuilles faire le contraire :
- un inter de validation
- un poussoir d'incrémentation
- un compteur
Tant que l'inter est ON, chaque impulsion du poussoir incrémente le compteur (condition dans le compteur).
Quand l'inter est OFF, les impulsions ne passent plus.

Je pense que Freiwald à construit son circuit virtuel comme un circuit matériel brut...



Pour un fonctionnement différent, il faut mettre des conditions.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Probleme avec la G1?   

Revenir en haut Aller en bas
 
Probleme avec la G1?
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» probleme avec les cellules d'excel sur la mise en forme
» Probleme avec connection en version mobile.
» Probleme avec le script de formulaire
» Probleme avec la gestion des codes javascript
» probleme avec les membres

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Les Conditions complexes-
Sauter vers: