Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Le réseau de Nico31

Aller en bas 
Aller à la page : Précédent  1, 2, 3
AuteurMessage
nico31

avatar

Nombre de messages : 51
Age : 31
Localisation : région toulousaine
Loisirs : bricolage
Date d'inscription : 18/05/2012

MessageSujet: Re: Le réseau de Nico31   Mer 10 Jan - 17:49

Sur les tests que j'avais fais il y a quelques années (un petit ovale avec une voie d'évitement) dès que je faisais l'aiguille en manuel TC ne le voyais pas et ne refaisait pas le changement et c'était a l'époque le seul moyen que j'avais trouvé pour corriger le problème.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.rmf31.fr
DiCoS69

avatar

Nombre de messages : 11076
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Le réseau de Nico31   Mer 10 Jan - 23:03

dudule a écrit:
si je ne me trompe TC envoi toujours l'ordre de position quand il fait l'itinéraire quelle que soit la position de l'aiguille
les spécialistes me corrigeront si nécessaire  

C'est tout à fait exact... Smile
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 11076
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Le réseau de Nico31   Mer 10 Jan - 23:14

nico31 a écrit:
Sur les tests que j'avais fais il y a quelques années (un petit ovale avec une voie d'évitement) dès que je faisais l'aiguille en manuel TC ne le voyais pas et ne refaisait pas le changement et c'était a l'époque le seul moyen que j'avais trouvé pour corriger le problème.

Si tu changes de système, tu n'auras plus le soucis de communication, à condition que centrale et PC soient interconnectés au moment de l'action.
Si tu utilises la centrale seule, TC ne sera évidemment pas informé, mais comme indiqué plus haut, quand il reprend la main avec un trajet, TC envoie systématiquement les commandes d'aiguilles...  il y a également une autre solution, c'est de paramétrer une position de base des aiguilles dans les "opérations" d'un bouton poussoir, et d'activer ce bouton avant d'entamer une session...
Mais la meilleure méthode est de se servir de TC aussi en manuel... comme ça pas de problème de position d'aiguille ni d'emplacement des trains dans les cantons...
Note que les positions de trains peuvent aussi être enregistrées dans un fichier (onglet RRTC de la V9), lequel peut être appelé avec l'action "Restaurer" au même endroit.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Capitole
Un mini-canton sinon rien
avatar

Nombre de messages : 2959
Age : 65
Localisation : Région Toulousaine
Date d'inscription : 14/02/2008

MessageSujet: Re: Le réseau de Nico31   Jeu 11 Jan - 11:12

Bonjour.

Tout à fait d'accord avec Elie, l'astuce du bouton de ré-initialisation des aiguilles que l'on utilise systématiquement en début de session ou à la demande est une excellente solution.

J'ai, il y a belle lurette créé ce bouton, voici la liste des opérations :
1) je liste toutes les aiguilles et décrocheurs en position opposée à celle par défaut,
2) suivi d'un délai qui permet de réaliser l'ensemble de ces opérations,
3) je re-liste tous ces accessoires dans la position par défaut cette fois ci,
4) nouveau délai comme en 2,
5) activation d'un son, que vous choisirez suivant votre humeur, dans mon cas c'est le klaxon d'un vieil autorail Billard à voie métrique. Quand on entend ce son, la réinitialisation est terminée

Pourquoi je fais 2 séries de changement de position, car j'ai constaté que dans certain cas, le logiciel ne déplaçait pas certaines aiguilles si il les voyait dans le sens de la liste par défaut. Je sais cela va à l'encontre de ce qui est écrit dans les réponses plus haut, ce n'est pas systématique, mais c'est pourtant un constat. Donc tant pis c'est un peu plus long, mais c'est plus sur.

D'ailleurs lors du ballastage, j'avais créé des macro qui tournaient en boucle (goto etc) qui activaient en permanence un groupe d'aiguille du côté ou je travaillais, cela m'a évité de retrouver des lames d'aiguilles collées.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 11076
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Le réseau de Nico31   Jeu 11 Jan - 12:51

Capitole a écrit:


D'ailleurs lors du ballastage, j'avais créé des macro qui tournaient en boucle (goto etc) qui activaient en permanence un groupe d'aiguille du côté ou je travaillais, cela m'a évité de retrouver des lames d'aiguilles collées.

Hé, hé... c'est malin, ça...! Very Happy Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Geo69



Nombre de messages : 4149
Age : 70
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

MessageSujet: Re: Le réseau de Nico31   Jeu 11 Jan - 13:54

Bonjour,

Ah bin oui, merci Patrick du tuyau ...  Very Happy  j'essaierais de m'en souvenir lors du ballastage car lorsque j'avais remis de la colle sur les aiguillages qui bougeaient, je mettais le réveil toute les 2 heures !...  Embarassed Dans la vie, il y a les malins et les besogneux ... Laughing

A+
Georges
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Capitole
Un mini-canton sinon rien
avatar

Nombre de messages : 2959
Age : 65
Localisation : Région Toulousaine
Date d'inscription : 14/02/2008

MessageSujet: Re: Le réseau de Nico31   Jeu 11 Jan - 15:02

Ben oui

Tu te fais baiser avoir une fois, pas deux bounce
Bon ça marche avec des Tortoises ou des servos, avec des Peco ou des Seep, pas certain qu'il n'y ait pas quelque chose qui crame  Exclamation
Je suis toujours content d'éviter les embuches aux copains et amis.

Il m'est arrivé aussi de coller un aimant de décrocheur Kadee en position haute, heureusement étant d'un naturel prévoyant, les bêtes en question sont démontables facilement par dessous, 2 écrous à désserrer et ça descend tout seul, enfin presque.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
nico31

avatar

Nombre de messages : 51
Age : 31
Localisation : région toulousaine
Loisirs : bricolage
Date d'inscription : 18/05/2012

MessageSujet: Re: Le réseau de Nico31   Lun 1 Oct - 19:51

Bonjour a tous,
Je vous donne quelques nouvelles de l'avancer des travaux, cela fait bientôt un an que les parties cachées sont terminées et fonctionnelles, j'ai pu tester pas mal de fonctionnalité dans TC, fais quelques profile de vitesse, des trajets spécifique (attelage / dételage, rodage....) validé le cantonnement et ma boucle de retournement via un relais bistable commandé par un switch pilote et, je dois dire que pour le moment tous ce passe a merveille enfin presque puisque j'ai dans 80% des cas quand je manipule le réseau, toujours une aiguille qui ne ce met pas dans la bonne position et du coup cour circuit alors que a chaque début de séance, j'ai pris l'habitude d'actualisé le réseau via TC. je me suis dis que cela venait peu etre de l'interface de paco et ai testé avec une central multiZENTRALE pro de roco + HSI88 mais le problème persiste du coup, je pense cablé la retro signalisation des aiguilles qui a ce jour est en attente.

Voici une petite vue d'ensemble du réseau, la partie visible devrait être attaqué avant la fin de l'année.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.rmf31.fr
DiCoS69

avatar

Nombre de messages : 11076
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Le réseau de Nico31   Lun 1 Oct - 22:11

nico31 a écrit:
j'ai dans 80% des cas quand je manipule le réseau, toujours une aiguille qui ne ce met pas dans la bonne position et du coup cour circuit alors que a chaque début de séance, j'ai pris l'habitude d'actualisé le réseau via TC. je me suis dis que cela venait peu etre de l'interface de paco et ai testé avec une central multiZENTRALE pro de roco + HSI88 mais le problème persiste du coup, je pense cablé la retro signalisation des aiguilles qui a ce jour est en attente.

A part éviter (peut-être...) le court-circuit, la rétro de position ne solutionnera rien...
J'ai remarqué que ce genre de problème se produit surtout tant que l'on fait des modifications de paramètres... cela se calme lorsque l'on reste quelques temps sans toucher à rien.
Je dis cela pour le cas où le défaut est aléatoire et pas toujours sur la même aiguille, sinon bien sûr, il faut chercher ce qui engendre l'erreur... pour ce cas, le changement radical d'adresse peut être salutaire...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
nico31

avatar

Nombre de messages : 51
Age : 31
Localisation : région toulousaine
Loisirs : bricolage
Date d'inscription : 18/05/2012

MessageSujet: Re: Le réseau de Nico31   Mar 2 Oct - 4:19

Citation :
A part éviter (peut-être...) le court-circuit, la rétro de position ne solutionnera rien...
Au contraire, TC verra que l'aiguille n'est pas dans la bonne position est renverra l'ordre de basculement de l'aiguille et dans le pire des cas le train s’arrêtera avant de déclencher un court circuit.

Citation :
J'ai remarqué que ce genre de problème se produit surtout tant que l'on fait des modifications de paramètres... cela se calme lorsque l'on reste quelques temps sans toucher à rien.
La cela se produit même sans que je fasse de modification, sur un trajet ou il peut y avoir une seul aiguille a bouger ou 10. Je suis juste en train de faire circuler une machine et paf une aiguille ne bascule pas. Mais je pense que cela vient d'une latence du décodeur...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.rmf31.fr
Geo69



Nombre de messages : 4149
Age : 70
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

MessageSujet: Re: Le réseau de Nico31   Mar 2 Oct - 10:03

Bonjour,

nico31 a écrit:
... Au contraire, TC verra que l'aiguille n'est pas dans la bonne position est renverra l'ordre de basculement de l'aiguille et dans le pire des cas le train s’arrêtera avant de déclencher un court circuit...
Avec une "vrai" rétro de position remontée à TC, si l'aiguille n'est mécaniquement pas faite, je ne pense pas que TC renvoi l'ordre mais lors d'un trajet l'itinéraire ne sera pas actif et donc le train ne partira pas ou s'arrêtera ...  Smile La sécurité sera donc assurée mais si cela se reproduit régulièrement, c'est exaspérant quand même !...  Mad

nico31 a écrit:
... La cela se produit même sans que je fasse de modification, sur un trajet ou il peut y avoir une seul aiguille a bouger ou 10. Je suis juste en train de faire circuler une machine et paf une aiguille ne bascule pas. Mais je pense que cela vient d'une latence du décodeur...
Ce phénomène (environ 1 changement sur 20 ou 30 pour moi) d'aiguille pas faite de manière aléatoire m'a gâchée la vie pendant deux ans !... Sad  Pour moi, c'était un problème de couple LS150/Seep que j'ai résolu en partie avec servos/67810 Uhlenbrock et Seep/CDF à décharge capacitive... Smile

A+
Georges
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 11076
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Le réseau de Nico31   Mar 2 Oct - 11:39

nico31 a écrit:


Citation :
J'ai remarqué que ce genre de problème se produit surtout tant que l'on fait des modifications de paramètres... cela se calme lorsque l'on reste quelques temps sans toucher à rien.
La cela se produit même sans que je fasse de modification, sur un trajet ou il peut y avoir une seul aiguille a bouger ou 10. Je suis juste en train de faire circuler une machine et paf une aiguille ne bascule pas. Mais je pense que cela vient d'une latence du décodeur...

As-tu essayé de jouer sur l'intervalle d'envoi dans la fenêtre de configuration des systèmes numériques ?

Quel décodeur utilises-tu, et avec quels moteurs ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
nico31

avatar

Nombre de messages : 51
Age : 31
Localisation : région toulousaine
Loisirs : bricolage
Date d'inscription : 18/05/2012

MessageSujet: Re: Le réseau de Nico31   Mar 2 Oct - 15:19

Non je n avais jamais fait attention a ca. J'utilise le décodeur de servos de paco. Sur le réseau modulaire de mon club on utilise le même système mais avec la retro sur les aiguilles et nous n'avons jamais constaté ce problème mais j'avoue que l'intervalle d'envoi peut, peut être, solutionner ça.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.rmf31.fr
Bernard

avatar

Nombre de messages : 2242
Age : 67
Localisation : Sailly lez Lannoy
Emploi : Architecte
Loisirs : Modélisme.... alpinisme...
Date d'inscription : 20/02/2009

MessageSujet: Re: Le réseau de Nico31   Mer 3 Oct - 5:44

Je pense que tu conclue peut être un peu vite et met en cause TC sans vraiment avoir détecté la cause réel de la mauvaise position de certains aiguillages.
Comme l'a dit Elie la rétro signalisation des aiguilles ne résoudra rien la rétro ça sert à savoir si le canton est occupé.
Si une aiguille ne bascule pas il y plusieurs causes possibles :
- TC n'as pas envoyé l'ordre
- L'ordre n'a pas été reçu ou pas exécuté
Mais aussi il y a plusieurs causes possibles :
- Cause électronique
- Cause électrique et/ou mécanique

Tu semble éliminer complétement ces deux dernières causes, qui sous entendent que l'ordre à bien été envoyé mais pas exécuté....
A titre d'exemple :
Je suis en train de câbler des moteurs de type PL11 dans des gares cachées au club. Les cartes maison de commandes d'aiguillages sont neuves, testées et ne sont donc pas en cause. Le numérique proprement dit n'est pas en cause non plus puisque non connecté, notre carte possède une entrée de commande par boutons poussoirs classiques prévue notamment pour les test. De plus deux leds témoignent de l'inversion électronique prouvant que la carte a bien basculé l'aiguillage.
Et bien j'ai quelques aiguillages qui ne basculent pas. La cause est purement mécanique dans le cas présent et l’électronique, l'électricité, ou le numérique ne sont absolument pas en cause.
J'ai quelques moteurs qui ne sont pas bien alignées coincent un peu et parfois de façon alléatoire....
En conclusion es tu sur de tes montages?
En outre les cartes du PACO sont des constructions un peu anciennes et pas toujours très sur qui utilisent pour certaines des composants anciens, j'en ai fait l'expérience il y en a même pour lesquelles on ne trouve pratiquement plus les composants....
Alors ça plus ça il y a peut être de la marge avant d'accuser TC de tous les maux.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Bernard

avatar

Nombre de messages : 2242
Age : 67
Localisation : Sailly lez Lannoy
Emploi : Architecte
Loisirs : Modélisme.... alpinisme...
Date d'inscription : 20/02/2009

MessageSujet: Re: Le réseau de Nico31   Mer 3 Oct - 5:46

Je pense que tu conclus peut être un peu vite et mets en cause TC sans vraiment avoir détecté la cause réelle de la mauvaise position de certains aiguillages.
Comme l'a dit Elie la rétro signalisation des aiguilles ne résoudra rien la rétro ça sert à savoir si le canton est occupé.
Si une aiguille ne bascule pas il y plusieurs causes possibles :
- TC n'a pas envoyé l'ordre
- L'ordre n'a pas été reçu ou pas exécuté
Mais aussi il y a plusieurs causes possibles :
- Cause électronique
- Cause électrique et/ou mécanique

Tu semble éliminer complétement ces deux dernières causes, qui sous entendent que l'ordre à bien été envoyé mais pas exécuté....
A titre d'exemple :
Je suis en train de câbler des moteurs de type PL11 dans des gares cachées au club. Les cartes maison de commandes d'aiguillages sont neuves, testées et ne sont donc pas en cause à priori. Le numérique proprement dit n'est pas en cause non plus, puisque non connecté, notre carte possède une entrée de commande par boutons poussoirs classiques prévue notamment pour les test. De plus deux leds témoignent de l'inversion électronique prouvant que la carte a bien basculé l'aiguillage.
Et bien j'ai quelques aiguillages qui ne basculent pas. La cause est purement mécanique dans le cas présent et l’électronique, l'électricité, ou le numérique ne sont absolument pas en cause.
J'ai quelques moteurs qui ne sont pas bien alignées coincent un peu et ce parfois de façon aléatoire....
En conclusion es tu sur de tes montages?
En outre les cartes du PACO sont des constructions un peu anciennes et pas toujours très sur qui utilisent pour certaines des composants anciens, j'en ai fait l'expérience, il y en a même pour lesquelles on ne trouve pratiquement plus les composants....
Alors ça plus ça il y a peut être de la marge avant d'accuser TC de tous les maux.[/quote]
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Bernard

avatar

Nombre de messages : 2242
Age : 67
Localisation : Sailly lez Lannoy
Emploi : Architecte
Loisirs : Modélisme.... alpinisme...
Date d'inscription : 20/02/2009

MessageSujet: Re: Le réseau de Nico31   Mer 3 Oct - 5:47

[quote="Bernard"]Je pense que tu conclus peut être un peu vite et mets en cause TC sans vraiment avoir détecté la cause réelle de la mauvaise position de certains aiguillages.
Comme l'a dit Elie la rétro signalisation des aiguilles ne résoudra rien la rétro ça sert à savoir si le canton est occupé.
Si une aiguille ne bascule pas il y plusieurs causes possibles :
- TC n'a pas envoyé l'ordre
- L'ordre n'a pas été reçu ou pas exécuté
Mais aussi il y a plusieurs causes possibles :
- Cause électronique
- Cause électrique et/ou mécanique

Tu semble éliminer complétement ces deux dernières causes, qui sous entendent que l'ordre à bien été envoyé mais pas exécuté....
A titre d'exemple :
Je suis en train de câbler des moteurs de type PL11 dans des gares cachées au club. Les cartes maison de commandes d'aiguillages sont neuves, testées et ne sont donc pas en cause à priori. Le numérique proprement dit n'est pas en cause non plus, puisque non connecté, notre carte possède une entrée de commande par boutons poussoirs classiques prévue notamment pour les test. De plus deux leds témoignent de l'inversion électronique prouvant que la carte a bien basculé l'aiguillage.
Et bien j'ai quelques aiguillages qui ne basculent pas. La cause est purement mécanique dans le cas présent et l’électronique, l'électricité, ou le numérique ne sont absolument pas en cause.
J'ai quelques moteurs qui ne sont pas bien alignées coincent un peu et ce parfois de façon aléatoire....
En conclusion es tu sur de tes montages?
En outre les cartes du PACO sont des constructions un peu anciennes et pas toujours très sur qui utilisent pour certaines des composants anciens, j'en ai fait l'expérience, il y en a même pour lesquelles on ne trouve pratiquement plus les composants....
Alors ça plus ça il y a peut être de la marge avant d'accuser TC de tous les maux.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
double

avatar

Nombre de messages : 868
Age : 61
Localisation : MARCIGNY ( 71 )
Emploi : Plus.... et c'est parfait !
Loisirs : Ferromodélisme-bricolage
Date d'inscription : 13/12/2010

MessageSujet: Re: Le réseau de Nico31   Mer 3 Oct - 5:51

Bernard a le hoquet.............
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 11076
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Le réseau de Nico31   Mer 3 Oct - 10:53

double a écrit:
Bernard a le hoquet.............

A moins que ce soit "Parkingson"... Laughing Laughing
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
nico31

avatar

Nombre de messages : 51
Age : 31
Localisation : région toulousaine
Loisirs : bricolage
Date d'inscription : 18/05/2012

MessageSujet: Re: Le réseau de Nico31   Mer 3 Oct - 16:07

Bernard,

Citation :
Je pense que tu conclus peut être un peu vite et mets en cause TC sans vraiment avoir détecté la cause réelle de la mauvaise position de certains aiguillages.
Je ne vois pas très bien ou je met en cause TC puisque pour moi cela ne vient pas de TC mais d'une latence du décodeur!!

Citation :
Comme l'a dit Elie la rétro signalisation des aiguilles ne résoudra rien la rétro ça sert à savoir si le canton est occupé.
La rétro peut également si elle est bien utilisée servir de remonter d'info de position d'aiguille pour TC

Citation :
Si une aiguille ne bascule pas il y plusieurs causes possibles :
- TC n'a pas envoyé l'ordre
Je pense que TC envoie bien les ordres mais que le décodeur n'a pas le temps de tous les traiter.

Citation :
- L'ordre n'a pas été reçu ou pas exécuté
Mais là aussi il y a plusieurs causes possibles :
- Cause électronique
- Cause électrique et/ou mécanique
Tu semble éliminer complétement ces deux dernières causes, qui sous entendent que l'ordre à bien été envoyé mais pas exécuté....
Aucun problème de ce coté la puisque individuellement tous fonctionne normalement.

Citation :
Je suis en train de câbler des moteurs de type PL11 dans des gares cachées au club. Les cartes maison de commandes d'aiguillages sont neuves, testées et ne sont donc pas en cause à priori. Le numérique proprement dit n'est pas en cause non plus, puisque non connecté, notre carte possède une entrée de commande par boutons poussoirs classiques prévue notamment pour les test. De plus deux leds témoignent de l'inversion électronique prouvant que la carte a bien basculé l'aiguillage.
Et bien j'ai quelques aiguillages qui ne basculent pas. La cause est purement mécanique dans le cas présent et l’électronique, l'électricité, ou le numérique ne sont absolument pas en cause.
J'ai quelques moteurs qui ne sont pas bien alignées coincent un peu et ce parfois de façon aléatoire....
On connait tous, je pense, la fiabilité de ces moteurs qui n'ont rien a voir avec du tortoise ou du servo... et pour info ton problème, je l'ai rencontrer chez un voisin qui utilise des LS150 avec des moteurs roco.

Citation :
En conclusion es tu sur de tes montages?
Oui a 100% pour la partie électronique c'est se qui me fait penser a une latence du pic car je ne sais pas a quelle vitesse il travaille vu que la programmation ne vient pas de moi.

Citation :
En outre les cartes du PACO sont des constructions un peu anciennes et pas toujours très sur qui utilisent pour certaines des composants anciens, j'en ai fait l'expérience, il y en a même pour lesquelles on ne trouve pratiquement plus les composants....
Si les cartes de paco sont un peu ancienne que dire de leur équivalent chez nos amis fabriquant qui utilise le même principe de base et nous rajoute une chose inutile pour pouvoir nous vendre çà le prix fort... si je prends les cartes S88 par exemple, que ce soit chez paco(qui au passage ne sont pas vraiment de lui mais plutôt du MERG), chez LDT ou chez roco, le principal composant reste le registre a décalage couplé a des bascules RS.

Pour ce qui est de la difficulté de trouvé ses composants, je ne vois pas ou elle est, étant donné que ces montages sont tous a base de composants basique en électronique (résistances, diodes, régulateur de tension, pic, condensateur) et même les décodeurs de notre ami Elie.

Enfin bref, mon but était simplement de vous faire par de mon retour d'expérience par rapport au matériel qui j'utilise et non de devoir me "justifier" de tous mes choix. Je prends vos remarques en considération, test et, si ca ne me convient pas, je refais des modifs.

Je préfère largement faire mes propres montages moi même ou je comprends d’où peu venir le le problème en cas de dysfonctionnement plutôt que d'acheter des modules prêt a l'emploi.

@Elie : je n'ai pas encore pris le temps de tester de modifier l'intervalle d'envoi mais je vous tiendrez au courant des que cela sera fait.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.rmf31.fr
DiCoS69

avatar

Nombre de messages : 11076
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Le réseau de Nico31   Mer 3 Oct - 17:30

nico31 a écrit:

Citation :
En conclusion es tu sur de tes montages?
Oui a 100% pour la partie électronique c'est se qui me fait penser a une latence du pic car je ne sais pas a quelle vitesse il travaille vu que la programmation ne vient pas de moi.

Le 12F629 équipant tes modules décodeurs travaille avec une horloge de 20MHz, ce qui est bien suffisant pour le DCC... mais apparemment, ici, sans quartz...
De plus, en regardant le schéma, je vois que l'alimentation des servos est tirées sur la régulation 5V alimentant le PIC, elle-même issue du redressement du DCC.
Je pense que cette solution n'est pas bonne car les moteurs des servos font constamment des appels de courant faisant fluctuer la tension, voir engendrant des perturbations du signal... encore pire si tu utilises des servos numériques dont la consommation est plus élevée et les retours de parasites plus agressifs.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
nico31

avatar

Nombre de messages : 51
Age : 31
Localisation : région toulousaine
Loisirs : bricolage
Date d'inscription : 18/05/2012

MessageSujet: Re: Le réseau de Nico31   Mer 3 Oct - 17:56

En réalité j'ai deux types de décodeur, le réseau du club m'ayant servis de test, on s'est aperçu qu'a la mise sous tension il y avait un fort appel de courant supérieur a 5A (mesuré a l'oscilloscope) du coup on a fait un système qui enclenche les cartes en décalées. Sur mon réseau j'ai 3 ou 4 cartes qui tire leur alimentation du DCC avec 1 booster dédie et les autres cartes sont alimenter en 12V (alim de PC). J'avais aussi fait une modif sur toutes les cartes afin d'ajouter une LED pour vérifier la sortie du 5V visuellement. Pour les servos j'utilise des htx900 acheté chez hobbyking mais je ne sais pas s'il sont numérique.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.rmf31.fr
DiCoS69

avatar

Nombre de messages : 11076
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Le réseau de Nico31   Mer 3 Oct - 18:38

Oui, à la mise sous tension il y a un appel de courant... on peut le minimiser en retardant (avec le PIC) la commutation de la tension alimentant les servos de sorte que le signal de commande soit établi avant l'arrivée de la tension d'alimentation des servos... ça complique un peu le schéma... mais réduit le battement.
Tes autres cartes ont donc une alimentation externe ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
nico31

avatar

Nombre de messages : 51
Age : 31
Localisation : région toulousaine
Loisirs : bricolage
Date d'inscription : 18/05/2012

MessageSujet: Re: Le réseau de Nico31   Mer 3 Oct - 18:53

oui la même alim que le HSI mais le "problème" se présente sur les 2 types.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.rmf31.fr
DiCoS69

avatar

Nombre de messages : 11076
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Le réseau de Nico31   Jeu 4 Oct - 8:42

Si les 2 types sont basés sur le même schéma, alors oui, il est possible que cela vienne du firmware du µC... dans ce cas, l'intervalle d'envoi de TC pourra peut-être jouer un rôle... à voir...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Christophe

avatar

Nombre de messages : 2288
Age : 60
Localisation : Nantes
Emploi : Journaliste
Date d'inscription : 07/06/2009

MessageSujet: Re: Le réseau de Nico31   Ven 5 Oct - 7:33

nico31 a écrit:
Je préfère largement faire mes propres montages moi même ou je comprends d’où peu venir le le problème en cas de dysfonctionnement plutôt que d'acheter des modules prêt a l'emploi.

Je respecte ton choix, mais on a encore jamais vu de modules LDT tomber en rade. Ah si, une fois chez moi quand la foudre est tombée sur la maison de la voisine ! Embarassed
Objectivement c'est increvable, même à l'extérieur !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://traindejardin.free.fr
Contenu sponsorisé




MessageSujet: Re: Le réseau de Nico31   

Revenir en haut Aller en bas
 
Le réseau de Nico31
Revenir en haut 
Page 3 sur 3Aller à la page : Précédent  1, 2, 3
 Sujets similaires
-
» Le début de mon réseau, Nord-EST......
» Le réseau que vous ne verrez pas dans les magazines
» Mon réseau - Mont St Olmes
» Ligne 132 Bis, un réseau modulaire
» Windows 7 et carte réseau sans fil

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: Les Membres :: Les réseaux-
Sauter vers: