Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez
 

 Connexion Zimo MX1

Aller en bas 
AuteurMessage
Larist



Nombre de messages : 864
Age : 71
Localisation : 72
Emploi : retraité
Loisirs : Voyages bricolage modélisme
Date d'inscription : 07/09/2011

Connexion Zimo MX1 Empty
MessageSujet: Connexion Zimo MX1   Connexion Zimo MX1 EmptyDim 11 Aoû - 17:46

Bonjour Yann, Very Happy

C'est la valeur par défaut donc la 1.
Je ne me suis jamais posé la question de modifier ce paramètre vu que cela fonctionne correctement, hormis ce défaut qui est aléatoire selon les sessions.

Sur le forum de Freiwald cet ennui a été signalé par plusieurs TCistes. Freiwald a répondu que c'était un problème matériel. Ceux qui ont constaté cela ont souvent signalé une perte de connexion au bout d'un certain temps d'inactivité et moi idem. Pour contourner cela j'ai défini un aiguillage fantôme à qui j'ai attribué une adresse sous contrôle de la centrale. Cet aiguillage est basculé toutes les 30 secondes via l'horloge. Depuis plus de soucis. Mais ça ne fonctionne pas lors des profils de vitesse lors des premiers parcours qui sont longs. Alors j'appuie à la main sur une touche de fonction de la commande à main pour "réveiller" la centrale qui, sans doute ?, doit communiquer avec le PC et j'arrive ainsi à faire mes profils. Sinon quasi impossible.

A+

Alain
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Yann

Yann

Nombre de messages : 1815
Age : 37
Localisation : Suisse - Entre Lausanne et Vevey
Date d'inscription : 25/06/2007

Connexion Zimo MX1 Empty
MessageSujet: _test   Connexion Zimo MX1 EmptyLun 12 Aoû - 11:35

Bonjour,
Larist a écrit:
de temps en temps j'ai des déconnexions entre TC et cette centrale.

Pour chacun des 2 systèmes quelle option à été choisie concernant l'envoi des fonctions à la connexion ?

Désolé j'ai pas de RRTC sous la main, juste dire 1ère, 2ème, 3ème ou 4ème.

Connexion Zimo MX1 Digita10


_________________
A+ Yann  
Mes tuto vidéo sur TrainController => https://www.youtube.com/TheDigitrain <=
Mon site => http://www.digi-train.ch <=
TC 9 Gold / +SmartHand Mobile / +Net / H0 3 rails / H0 2 rails / Tams MasterControl / Rétro. et commande des signaux: Selectrix Businterface Peter Stärz / PC 3,3 GHz / Win XP, 7, 10 / iPhone 6 iOS 12.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.digi-train.ch/
Yann

Yann

Nombre de messages : 1815
Age : 37
Localisation : Suisse - Entre Lausanne et Vevey
Date d'inscription : 25/06/2007

Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 EmptyLun 12 Aoû - 11:46

Larist a écrit:
C'est la valeur par défaut donc la 1.

Pour tester pouvez-vous essayer de mettre le SPROG avec le 4ème paramètre?

_________________
A+ Yann  
Mes tuto vidéo sur TrainController => https://www.youtube.com/TheDigitrain <=
Mon site => http://www.digi-train.ch <=
TC 9 Gold / +SmartHand Mobile / +Net / H0 3 rails / H0 2 rails / Tams MasterControl / Rétro. et commande des signaux: Selectrix Businterface Peter Stärz / PC 3,3 GHz / Win XP, 7, 10 / iPhone 6 iOS 12.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.digi-train.ch/
Larist



Nombre de messages : 864
Age : 71
Localisation : 72
Emploi : retraité
Loisirs : Voyages bricolage modélisme
Date d'inscription : 07/09/2011

Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 EmptyLun 12 Aoû - 18:24

Ok je regarde cela dans la semaine, je pense refaire un profil de vitesse.

Sinon par curiosité quelle est l'idée ? Car les déconnexions touche la centrale Zimo mais pas le Sprog.

A+

Alain
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Yann

Yann

Nombre de messages : 1815
Age : 37
Localisation : Suisse - Entre Lausanne et Vevey
Date d'inscription : 25/06/2007

Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 EmptyLun 12 Aoû - 18:53

Larist a écrit:
Ok je regarde cela dans la semaine, je pense refaire un profil de vitesse.
Sinon par curiosité quelle est l'idée ? Car les déconnexions touche la centrale Zimo mais pas le Sprog.

Certains systèmes numérique ne supportent pas très bien une grande quantité de données et peuvent bloquer et du coup engendrer un timeout d'où le message de déconnection par TrainController. En utilisant la dernière ou l'avant dernière option on peut l'imiter les données qui sont envoyées à la connexion avec le système numérique. Plus on descend dans la liste moins il y a d'info envoyées.
Vous pouvez aussi tester ces options sur le système Zimo.
N'oublier pas de stopper votre horloge pour les tests afin que votre aiguillage fantôme ne commute plus  Wink
Si ça ne change rien revenez à votre configuration précédente.

_________________
A+ Yann  
Mes tuto vidéo sur TrainController => https://www.youtube.com/TheDigitrain <=
Mon site => http://www.digi-train.ch <=
TC 9 Gold / +SmartHand Mobile / +Net / H0 3 rails / H0 2 rails / Tams MasterControl / Rétro. et commande des signaux: Selectrix Businterface Peter Stärz / PC 3,3 GHz / Win XP, 7, 10 / iPhone 6 iOS 12.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.digi-train.ch/
Larist



Nombre de messages : 864
Age : 71
Localisation : 72
Emploi : retraité
Loisirs : Voyages bricolage modélisme
Date d'inscription : 07/09/2011

Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 EmptyLun 12 Aoû - 19:36

La déconnexion survient justement quand il n'y a pas, ou très peu, d'activité entre TC d'une part et la centrale et le Sprog d'autre part.
Lors des premiers aller-retour d'un profil de vitesse il ne se passe quasiment rien au niveau des échanges. Quand la loco parcoure la zone centrale en théorie il n'y a aucun échange. C'est pour cela que je force un échange (du moins c'est ce que je pense) en appuyant de temps en temps sur une touche de fonction de la commande à main de la Zimo. TC ne fait qu'attendre que la loco ait atteint la zone de sortie. Et comme il ne se passe rien d'autre sur le réseau, le Sprog n'a aucune activité.

Néanmoins je vais essayer différentes combinaisons de ce paramètre.


A+

Alain
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

DiCoS69

Nombre de messages : 11856
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 EmptyLun 12 Aoû - 23:02

Larist a écrit:
La déconnexion survient justement quand il n'y a pas, ou très peu, d'activité entre TC d'une part et la centrale et le Sprog d'autre part.
A+
Alain

Est-ce que ton PC est utilisé pour autre chose que le réseau (connexion internet) ?
Personnellement j'ai noté des déconnections ou des ratés de marqueurs fréquentes lors de mises à jour automatiques de mon antivirus...!!??
C'était en pleine nuit, mais pas pour moi... Very Happy Very Happy
Maintenant, je prend les devants et je n'ai plus de problème.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Larist



Nombre de messages : 864
Age : 71
Localisation : 72
Emploi : retraité
Loisirs : Voyages bricolage modélisme
Date d'inscription : 07/09/2011

Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 EmptyMar 13 Aoû - 8:51

Bonjour Elie, Very Happy

Mon PC est un portable qui n'a pas de connexion Internet quand il est utilisé sur le réseau.

Mais je n'ai que 3 prises USB et je suis obligé de mettre mes périphs, dont la centrale, sur un Hub qui est alimenté électriquement. J'ai des soupçons concernant ce Hub. Je vais aussi essayer de faire un test en branchant la centrale directement sur le PC.
Les autres périphs sur le Hub ne se déconnectent pas ou bien très rarement avant que je ne mette mon aiguillage fantôme.
Actuellement mes 3 prises sont pour la clé TC, la souris et le Hub.

J'ai vérifié le paramétrage de la centrale mais il n'y a rien qui pourrait influencer.

A+

Alain
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

DiCoS69

Nombre de messages : 11856
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 EmptyMar 13 Aoû - 10:16

Par contre, n'y a-t-il pas de tâches sous-jacentes...?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Skull1

Skull1

Nombre de messages : 699
Age : 52
Localisation : Finistère 29 Sud
Emploi : Electronicien & Informaticien
Loisirs : Trains HO 100% numérique - RC: Hélicoptères, planeurs, voiliers
Date d'inscription : 21/07/2015

Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 EmptyMar 13 Aoû - 11:31

Bonjour,
Autre piste: As-tu regardé au niveau de la gestion d'alimentation des ports USB ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Larist



Nombre de messages : 864
Age : 71
Localisation : 72
Emploi : retraité
Loisirs : Voyages bricolage modélisme
Date d'inscription : 07/09/2011

Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 EmptyMar 13 Aoû - 12:35

Elie non à priori pas d'autres tâches polluantes dans le PC, je vérifie de temps en temps la charge des composants et les activités en cours et ça me parait normal. J'ai fait une surveillance lors d'un profil de vitesse et aucune surcharge, calme plat.
Toutefois, mais sans rapport, je me suis rendu compte que l'antivirus Avast bouffait pas mal, notamment de la mémoire et je l'ai récemment supprimé au bénéfice de Windows Defender fournis en standard avec Windows. Depuis je n'ai pas fait de circulation sur le réseau mais le PC a retrouvé de l'air quand je fais autre chose, il est contraint en mémoire avec 3 GB sous W10

David la gestion de l'alimentation électrique USB pourrait être une piste. J'en suis méfiant depuis une drôle d'histoire.
J'avais acheté un PC portable Compaq il y a une quinzaine d'années et toutes les 20 minutes pile poil  je perdais la connexion avec tous les périphs USB. Et ça ne se produisait que lorsque le PC était branché sur le secteur, jamais quand il était sur batterie. Après 2 retours au SAV ils ont fini par me le rembourser sans me fournir d'explication technique.
Pour en revenir à mon problème, je ne sais pas comment contrôler cette alimentation électrique. Quand TC est actif le PC est toujours sous branchement secteur. Je devrais essayer sur batterie, un test de plus à faire.

A+

Alain
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Yann

Yann

Nombre de messages : 1815
Age : 37
Localisation : Suisse - Entre Lausanne et Vevey
Date d'inscription : 25/06/2007

Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 EmptyMar 13 Aoû - 15:53

Bonjour,

Vu qu'il s'agit d'un problème de déconnexion "au bout d'un moment" d'inactivité il est possible que les périphériques USB se mettent en veille.
Vous trouverez sur cette page la procédure pour accéder à la fenêtre de paramétrages avancés.
https://www.commentcamarche.net/faq/44520-windows-10-comment-activer-le-mode-economie-d-energie
Sous paramètres USB vous pouvez essayer de désactiver la suspension sélective.
Voir aussi dans le gestionnaire de périphériques décocher "autoriser l'ordinateur à éteindre ce périphérique...":
https://www.astronamis.net/t6044-desactiver-la-mise-en-veille-des-peripheriques-usb-peut-sauver-vos-nuits
Voilà... à tester...

_________________
A+ Yann  
Mes tuto vidéo sur TrainController => https://www.youtube.com/TheDigitrain <=
Mon site => http://www.digi-train.ch <=
TC 9 Gold / +SmartHand Mobile / +Net / H0 3 rails / H0 2 rails / Tams MasterControl / Rétro. et commande des signaux: Selectrix Businterface Peter Stärz / PC 3,3 GHz / Win XP, 7, 10 / iPhone 6 iOS 12.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.digi-train.ch/
Larist



Nombre de messages : 864
Age : 71
Localisation : 72
Emploi : retraité
Loisirs : Voyages bricolage modélisme
Date d'inscription : 07/09/2011

Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 EmptyMar 13 Aoû - 19:10

Bonne remarque Yann. J'ai vérifié et tout était correct que ce soit en fonctionnement sur secteur ou batterie.
Merci.

A+

Alain
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Yann

Yann

Nombre de messages : 1815
Age : 37
Localisation : Suisse - Entre Lausanne et Vevey
Date d'inscription : 25/06/2007

Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 EmptySam 17 Aoû - 20:31

Bonjour,
Larist a écrit:
Bonne remarque Yann. J'ai vérifié et tout était correct que ce soit en fonctionnement sur secteur ou batterie.
Merci.
Correct... c'est-à-dire? quel option est choisi?
Est-ce que les problèmes de déconnexions sont toujours là?

_________________
A+ Yann  
Mes tuto vidéo sur TrainController => https://www.youtube.com/TheDigitrain <=
Mon site => http://www.digi-train.ch <=
TC 9 Gold / +SmartHand Mobile / +Net / H0 3 rails / H0 2 rails / Tams MasterControl / Rétro. et commande des signaux: Selectrix Businterface Peter Stärz / PC 3,3 GHz / Win XP, 7, 10 / iPhone 6 iOS 12.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.digi-train.ch/
Larist



Nombre de messages : 864
Age : 71
Localisation : 72
Emploi : retraité
Loisirs : Voyages bricolage modélisme
Date d'inscription : 07/09/2011

Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 EmptyDim 18 Aoû - 11:37

Yann j'avais déjà tous les paramètres d'économie d'énergie désactivés pour tous les périphériques ainsi que la suspension sélective de l'USB désactivée. J'ai aussi passé en revue tous les autres paramètres avancés de l'option d'alimentation.

J'ai refait un profil comme auparavant afin d'avoir une référence avant de faire d'autres essais. Il est allé au bout sans interruption. J'en ai refait un autre. Lors de l'avant dernier parcours final, la loco ne s'est jamais arrêtée. Comme le parcours est sur une boucle la loco l'a parcouru et quand elle est rentrée à nouveau dans ce canton de sortie la rétro s'est déclenchée et le profil est reparti jusqu'au bout sans autre incident. Evidemment la courbe a mauvaise mine !

N'étant pas devant l'écran à ce moment là je ne sais pas ce qui s'est passé. Défaillance de la rétro ? A quel niveau ?

Je vais poursuivre mais avant cela 3 semaines de voyage.

Donc à plus tard pour la suite.

Alain
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Yann

Yann

Nombre de messages : 1815
Age : 37
Localisation : Suisse - Entre Lausanne et Vevey
Date d'inscription : 25/06/2007

Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 EmptyDim 18 Aoû - 17:55

Ok, mais apparement plus de déconnexion inopinée.

_________________
A+ Yann  
Mes tuto vidéo sur TrainController => https://www.youtube.com/TheDigitrain <=
Mon site => http://www.digi-train.ch <=
TC 9 Gold / +SmartHand Mobile / +Net / H0 3 rails / H0 2 rails / Tams MasterControl / Rétro. et commande des signaux: Selectrix Businterface Peter Stärz / PC 3,3 GHz / Win XP, 7, 10 / iPhone 6 iOS 12.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.digi-train.ch/
Contenu sponsorisé




Connexion Zimo MX1 Empty
MessageSujet: Re: Connexion Zimo MX1   Connexion Zimo MX1 Empty

Revenir en haut Aller en bas
 
Connexion Zimo MX1
Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Technique-
Sauter vers: