Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Affichage du signal ne correspond pas à la programmation

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : Précédent  1, 2, 3  Suivant
AuteurMessage
ALBULA



Nombre de messages : 68
Date d'inscription : 17/08/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Mer 22 Sep - 11:05

Très bien Yann, mais ce qui m'intéresserais, c'est de connaître la méthode à employer pour paramétrer ce signal dans TC...

Je possède aussi des LS-DEC-SBB qui vont commander des signaux RHB à 4 aspects :

- rouge
- vert
- vert + orange
- orange + orange
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
RAILO5

avatar

Nombre de messages : 857
Age : 58
Localisation : VISE (BELGIQUE)
Date d'inscription : 21/01/2009

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Mer 22 Sep - 11:18

Bonjour Yann Very Happy ,

Je suis aussi preneur des informations pour le paramétrage (j'ai prévu l'achat de LS-DEC-NMBS).

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5380
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Mer 22 Sep - 14:34

Pour répondre aux inquiétudes d'Albula, je ne pense pas que le paramétrage des signaux dans TC ne soit le fruit du hasard ni ne nécessite beaucoup d'itérations, à condition, bien sûr, d'avoir une notice du décodeur bien faite.

Je vais essayer d'expliquer, le plus clairement possible, en prenant pour base la notice des signaux CFF (SBB) de LDT et des copies d'écrans de TC.

Les touches rouges et blanches décrites dans la notice, correspondent à ce qu'on peut avoir avec une Intellibox.

Pour mémoire, chaque adresse d'un décodeur à 4 adresses est pilotée par une paire de touches du clavier.



Ainsi, pour le décodeur ayant les adresses 1 à 4, il sera piloté par les paires de touches 1 et 4 pour l'adresse 1; 2 et 5 pour l'adresse 2 etc. Les images de la notice LDT reprennent simplement les couleurs des paires de touches sur l'Intellibox. Le pilotage par une autre centrale, obéit, je pense aux mêmes règles aux couleurs près.

C'est ce principe de paires de touches qui est repris par TC, sachant qu'on ne pilote pas directement les adresses du décodeur depuis le logiciel, c'est le logiciel qui se débrouille pour appeler la bonne adresse.

Dans TC, si on a un signal à 3 ou 4 aspects, il occupera deux adresses de décodeur, qu'on inscrit dans les paramètres du signal.

Reste à régler le problème de la configuration de sortie dans TC.

Chaque aspect du signal peut être obtenu par une paire de touches du clavier ou la combinaison de deux paires de touches du clavier. C'est ce qu'on retrouve dans les paramètres sous la forme de boutons:



Si, maintenant, on prend l'exemple des pages 4 et 5 de la notice de LDT, nous avons à paramétrer un signal à 3 aspects.

Sur la notice, on voit que:



- pour l'aspect "Stop", on doit utiliser la touche rouge de la première paire et rien sur la deuxième paire. J'active donc la touche rouge de la première paire dans TC. (voir image ci-dessus, en face de l'aspect rouge du signal)

- Pour l'aspect "Train proceed" du signal, on doit activer la touche verte de la deuxième paire de touches et rien dans la première paire. J'active donc la touche verte de la deuxième paire dans TC (voir image ci-dessus, en face de l'aspect vert du signal)

- Pour l'aspect "slow approach" du signal, on doit activer la touche rouge de la deuxième paire de touches, ce que j'ai fait dans l'image ci-dessus.

Le paramétrage du signal est terminé. On remarque que chaque aspect est géré par des combinaisons 'différentes. Si, lors d'un paramétrage vous avez deux aspects gérés avec des combinaisons identiques, vous aurez des problèmes. C'était le cas du paramétrage d'Albula et l'origine de ses problèmes. Smile Smile

Pour une centrale Lenz, l'aspect graphique de TC n'est pas le même, et cela devrait donner l'image suivante:



TC n'affiche toujours que deux paires de touches, il fait son affaire de savoir à quelles adresses du décodeur il doit envoyer les ordres correspondants aux combinaisons de paires de touches.

Ce petit exemple montre que lorsque la notice du décodeur est bien faite, il n'y a pas de hasard lors du paramétrage des aspects des signaux. Smile Smile

Jean



_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
ALBULA



Nombre de messages : 68
Date d'inscription : 17/08/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Mer 22 Sep - 15:21

Jean, chapeau bas, tes explications sont limpides et m'enlèvent une grosse épine du pied.

En fait, il fallait savoir que :

1/ les touches rouges et vertes de la notice correspondaient aux paires de touches de TC;
2/ Pour les utilisateurs de centrales Lenz (dont je fais partie), le (-) correspond au vert et le (+) au rouge.

Ces "petits détails" changent toute la vie....

Merci encore
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Yann

avatar

Nombre de messages : 1664
Age : 35
Localisation : Suisse - Entre Lausanne et Vevey
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Mer 22 Sep - 15:28

Bon ben voilà Jean à fait le boulot à ma place....

_________________
A+ Yann  
Mes tuto vidéo sur TrainController => http://www.youtube.com/TheDigitrain <=
Mon blog => http://blogyann.blogspot.ch <=
TC 8 Gold-Silver/+SmartHand Mobile/+Net/H0 3 rails/2rails/Tams MasterControl/rétro. bus Selectrix SLX 852/Compaq 2 GHz, iMac 3.5 GHz Intel Core i5/VMWare Fusion/Windows 7/XP Pro SP3/iPhone 6 iOS 11.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.digi-train.ch/
DiCoS69

avatar

Nombre de messages : 9916
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Mer 22 Sep - 17:26

C'est l'avantage du décodeur dédié, avec un décodeur standard type SA-DEC-4, c'est un peu moins simple. Il faut combiner avec les différents états des relais bi-stables, et en plus, il y a quelques aberrations de croisement.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
RAILO5

avatar

Nombre de messages : 857
Age : 58
Localisation : VISE (BELGIQUE)
Date d'inscription : 21/01/2009

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Mer 22 Sep - 18:06

Bonsoir et merci à vous deux pour les explications claires Very Happy

Y'apuka ......
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ALBULA



Nombre de messages : 68
Date d'inscription : 17/08/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Jeu 23 Sep - 14:09

Jean et Yann,

Je suis désolé d'insister mais j'ai encore une interrogation :

Dans l'exemple de Jean, les 3 aspects des signaux se répartissent sur 2 paires de contacts représentées dans TC par des points rouge et vert ou + et - pour Lenz, pas de problème...Mais dans le cas de signaux à 4 ou 5 aspects, ceux-ci se répartissent sur 4 paires de contacts (voir la notice des décodeurs LS-DEC-SBB après la page 5) ; or apparemment, TC n'affiche que 2 paires de contacts par aspect.

Comment programme-t-on les 3èmes et les quatrièmes paires ?

Merci...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5380
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Jeu 23 Sep - 15:12

TC ne sait gérer que des signaux ayant au maximum 4 aspects et gérés par 2 adresses de décodeur.

Si on veut gérer plus d'aspects et plus d'adresses, il va falloir répartir les différents aspects sur plusieurs signaux dans le TCO, même si physiquement, tous les fils du signal sont reliés au même boitier de décodeur.

Par exemple, le signal de la page 8 à gauche de l'image du décodeur. Il occupe 4 adresses et on peut voir que chaque paire d'adresses donne 3 aspects du signal.

Dans TC, on va pouvoir, par exemple, créer deux signaux à 3 aspects. Le premier signal sera paramétré pour les aspects définis pour les adresses 1 et 2, le deuxième signal sera défini pour les aspects des adresses 3 et 4.

Si, dans l'exploitation, l'aspect 1 du signal 1 doit être affiché en même temps que l'aspect 3 du signal 2 (par exemple), on aura le choix:

- soit de mettre des déclencheurs identiques pour ces aspects des deux signaux
- soit de mettre l'aspect 1 du signal 1 comme déclencheur de l'aspect 3 du signal 2.

Je n'ai pas testé réellement car je n'ai pas de signal si complexe sur mon réseau. Cela dit, je ne vois pas d'autre façon de procéder.

Jean

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
ALBULA



Nombre de messages : 68
Date d'inscription : 17/08/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Jeu 23 Sep - 19:11

Voici un exemple concret :

En fait les seuls signaux que j'aurai à piloter par des LS-DEC-SBB sont les signaux à 4 feux et 4 aspects de la page 12 de la notice de ce décodeur (a priori Yann en pilote aussi un à l'aide de ce décodeur).
Les 2 premières adresses permettent de commuter 3 aspects et la 3ème adresse se charge du 4ème aspect (d'ailleurs pourquoi ne pas avoir mis le 4ème aspect sur la 2ème paire de la 2ème adresse, ça aurait simplifié les choses...).

Concrètement :

- la touche rouge de la 1ère adresse fait afficher la led rouge ;
- la touche verte de la 1ère adresse fait afficher la 1ère led verte ;
- la touche rouge de la 2ème adresse fait afficher la 1ère led verte et la led jaune ;
- la touche verte de la 2ème adresse ne fait rien afficher du tout (malheureusement)
- la touche rouge de la 3ème adresse (que TC ne gère donc pas) fait afficher les 2 leds vertes.

Comment je peux programmer ça dans TC avec 2 paires de contacts ?

Yann, si tu nous regardes....
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5380
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Jeu 23 Sep - 19:56

Bonsoir,

C'est un peu tard pour faire une réponse complète. Relis ce que j'ai écrit dans mon dernier post, il va te falloir utiliser deux symboles de signaux dans TC.

TC va gérer aussi l'adresse 3, mais sur un autre signal. Il va gérer 3 aspects avec un signal 1 et les adresses 1 et 2 et gèrera le 4ème aspect sur un deuxième signal, d'adresse 3 dans le TCO. Cela ne t'empêchera pas d'avoir un seul signal physique installé sur le réseau.

Je te fais demain une réponse avec l'image de ton signal et le paramétrage à faire.

Jean

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
Yann

avatar

Nombre de messages : 1664
Age : 35
Localisation : Suisse - Entre Lausanne et Vevey
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Jeu 23 Sep - 19:57

Bonsoir,

Voilà donc comment est paramètre mon signal à 4 positions dans TrainController.

Comme je l'avais dit l'aspect du signal sur le pupitre n'est pas tout à fait réaliste mais fonctionne.
J'ai mis également 4 bouton poussoir pour pouvoir appeler les différentes images.


Il s'agit donc bien de 2 objets différents:
1x un signal à 2 feux de type "stackable" en français superposable (à gauche)
1x un signal à 4 feux (à droite)
Ce qu'il faut comprendre c'est qu'avec le décodeur LS-DEC on demande l'affichage d'images au décodeur qui lui s'occupe d'activer les sorties correspondantes. pour donner la bonne image.

Configuration du signal de gauche qui appel l'image "1 vert" ou "1 rouge":


Configuration du signal de droite qui appel l'image "2 verts" ou "1 vert + 1 orange":


On constate que pour la couleur rouge et blanche aucun ordre n'est envoyé au décodeur.

Ensuite dans les boutons poussoir je commande mes 2 signaux:









Bien sûr on pourrait améliorer, dans la version Gold, l'aspect du signal pour qu'il soit plus réaliste sur le pupitre.
En espérant que ça puisse vous aider.

_________________
A+ Yann  
Mes tuto vidéo sur TrainController => http://www.youtube.com/TheDigitrain <=
Mon blog => http://blogyann.blogspot.ch <=
TC 8 Gold-Silver/+SmartHand Mobile/+Net/H0 3 rails/2rails/Tams MasterControl/rétro. bus Selectrix SLX 852/Compaq 2 GHz, iMac 3.5 GHz Intel Core i5/VMWare Fusion/Windows 7/XP Pro SP3/iPhone 6 iOS 11.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.digi-train.ch/
Jean_01

avatar

Nombre de messages : 5380
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Jeu 23 Sep - 20:18

Bon, cette fois, c'est Yann qui m'a devancé Smile Smile

Sa solution est très semblable à celle que je voulais réaliser.

Ce qu'il est important de noter, sachant que TC ne sait gérer qu'une paire de touches:

1) dans TC, on va utiliser deux signaux, comme je le disais.

2) Remarquer les adresses dans les images de son post:

- le signal 1 a deux aspects et appelle l'adresse 149, soit l'adresse 1 des explications de la notice LDT. Il reproduit les aspect vert et rouge seuls du signal

- Le signal 2 a 3 aspects et appelle les adresses 150 et 151, soit les adresses 2 et 3 de la notice LDT. Il reproduit les aspects 2 verts et vert/jaune du signal

3) le signal physique, sur le réseau est, quant à lui, câblé selon le schéma de la notice de LDT.

Jean


_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
BUBU10

avatar

Nombre de messages : 139
Age : 68
Localisation : TROYES
Emploi : retraité
Loisirs : trains généalogie informatique moto
Date d'inscription : 18/03/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 6:58

Bonjours,
TC devrait être remboursé par la Sécu comme remède contre la maladie d’Alzheimer.geek
Amicalement train.
Claude
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ALBULA



Nombre de messages : 68
Date d'inscription : 17/08/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 8:44

Super !!
Merci à Yann et à Jean.

Par contre, au niveau du paramétrage des déclencheurs, une petite précision par rapport au post de Jean de 17h12 hier :
-On est bien d'accord que mettre le même déclencheur pour un aspect des 2 "sous-signaux" de TC n'a d'intérêt que si l'aspect souhaité du signal réel représente la somme de celui de ces 2 "sous-signaux" (?).

Dans mon cas (qui est aussi celui de Yann), il suffit de mettre comme déclencheur :
- sur le 1er sous-signal (2 feux) : le rouge vide (état par défaut) et le vert déclencheur X ;
- sur le 2ème sous-signal (4 feux) : le jaune comme déclencheur Y et le vert comme déclencheur Z.

- Lorsque le vert seul sera requis, TC déclenche la led verte du premier sous-signal et il ne se passe rien au niveau du 2ème, donc le signal réel affiche bien la seule led verte ;

- lorsque le vert et jaune sera requis, TC déclenche l' aspect jaune du 2ème sous-signal donc le signal réel affichera bien le jaune et le vert (car sur le décodeur ces 2 leds sont bien reliées) ;

- lorsque les 2 verts seront requis, TC déclenche l'aspect vert du 2ème sous-signal donc le signal réel affichera bien les 2 leds vertes (car sur le décodeur ces 2 leds vertes sont bien reliées) .

J'ai bon ?

Reste une interrogation : j'espère que la led rouge (état par défaut du premier sous-signal) ne se déclenchera pas dès lors qu' un aspect du 2ème sous-signal doit se déclencher...La doc dit qu'un déclencheur non-vide a toujours la priorité sur un déclencheur vide, mais on parle d'un même signal : là TC croit qu'il y a 2 signaux !!??

Merci...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5380
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 9:24

ALBULA a écrit:
Super !!
Merci à Yann et à Jean.

Par contre, au niveau du paramétrage des déclencheurs, une petite précision par rapport au post de Jean de 17h12 hier :
-On est bien d'accord que mettre le même déclencheur pour un aspect des 2 "sous-signaux" de TC n'a d'intérêt que si l'aspect souhaité du signal réel représente la somme de celui de ces 2 "sous-signaux" (?).

Dans mon cas (qui est aussi celui de Yann), il suffit de mettre comme déclencheur :
- sur le 1er sous-signal (2 feux) : le rouge vide (état par défaut) et le vert déclencheur X ;
- sur le 2ème sous-signal (4 feux) : le jaune comme déclencheur Y et le vert comme déclencheur Z.

- Lorsque le vert seul sera requis, TC déclenche la led verte du premier sous-signal et il ne se passe rien au niveau du 2ème, donc le signal réel affiche bien la seule led verte ;

- lorsque le vert et jaune sera requis, TC déclenche l' aspect jaune du 2ème sous-signal donc le signal réel affichera bien le jaune et le vert (car sur le décodeur ces 2 leds sont bien reliées) ;

- lorsque les 2 verts seront requis, TC déclenche l'aspect vert du 2ème sous-signal donc le signal réel affichera bien les 2 leds vertes (car sur le décodeur ces 2 leds vertes sont bien reliées) .

J'ai bon ?

Je crois bien que oui

ALBULA a écrit:


Reste une interrogation : j'espère que la led rouge (état par défaut du premier sous-signal) ne se déclenchera pas dès lors qu' un aspect du 2ème sous-signal doit se déclencher...La doc dit qu'un déclencheur non-vide a toujours la priorité sur un déclencheur vide, mais on parle d'un même signal : là TC croit qu'il y a 2 signaux !!??

Merci...

Cela, il faut le tester.

La règle du déclencheur vide est une règle générale et, comme toute règle générale, elle a des exceptions. Il est recommandé mais il n'est pas obligatoire d'avoir un déclencheur vide sur un signal

Au cas où le rouge du premier signal s'allumerait de façon intempestive, il suffira de mettre les déclencheurs qui vont bien au niveau de cet état du signal. Par exemple ne déclencher le rouge du signal 1 que si aucun état du signal 2 n'est actif.

L'utilisation de la clause NOT facilitera les choses. Sauf erreur de ma part, le déclencheur du rouge pour le signal 1 devrait alors ressembler à ça:

OR
NOT signal 2 = vert
NOT signal 2 = jaune

Tout ça fait partie des joies du paramétrage de TC Smile Smile Smile

Jean

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
ALBULA



Nombre de messages : 68
Date d'inscription : 17/08/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 10:35

Merci Jean.

Si je suis le raisonnement, il faudrait rajouter aussi comme déclencheur du rouge pour le signal 1 :
NOT signal 1 = vert
Sinon, lorsque l'aspect vert du signal 1 sera requis, on aurait les déclencheurs des 2 états de ce signal valides, et TC choisirait au hasard lequel afficher...

Yann, est-ce comme cela que tu as paramétré tes déclencheurs pour chacun des états de ton signal 4 feux ?

Sinon, pour éviter cette tambouille, il aurait été beaucoup plus simple que TC puisse gérer non pas 2 mais 3 ou 4 adresses par signal....Peut être une future évolution que l'on pourrait demander à Freiwald ?....
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5380
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 12:03

ALBULA a écrit:
Merci Jean.

Si je suis le raisonnement, il faudrait rajouter aussi comme déclencheur du rouge pour le signal 1 :
NOT signal 1 = vert
Sinon, lorsque l'aspect vert du signal 1 sera requis, on aurait les déclencheurs des 2 états de ce signal valides, et TC choisirait au hasard lequel afficher...


A mon avis c'est inutile, car l'ordre qu'envoie TC est identique à celui envoyé au décodeur quand on appuie sur les boutons Rouge (+ chez lenz) ou Vert (- chez Lenz) de la centrale. Or, le rouge et le vert du signal 1 sont sur la même paire de touches et on ne peut pas appuyer en même temps sur les deux touches d'une même paire.

Je laisse Yann répondre à la partie du message qui le concerne Smile

Jean

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
ALBULA



Nombre de messages : 68
Date d'inscription : 17/08/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 12:56

OK Jean, bien noté...

Et que penses-tu de ma suggestion de faire évoluer TC pour qu'il puisse prendre en compte les signaux à 3 ou 4 adresses ? Qu'en penserait Freiwald ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5380
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 13:18

ALBULA a écrit:
OK Jean, bien noté...

Et que penses-tu de ma suggestion de faire évoluer TC pour qu'il puisse prendre en compte les signaux à 3 ou 4 adresses ? Qu'en penserait Freiwald ?

Je n'ai aucune idée de ce qu'en penserait Freiwald.

Les décodeurs qu'il faudrait prendre en charge ne sont pas légion, du moins à ma connaissance. Ces décodeurs sont conçus pour des signaux complexes de règlementations ferroviaires spécifiques et comportent 8 adresses.

Jusqu'à maintenant, le souci de Freiwald a été de concevoir un produit qui reste dans les standards du digital plutôt qu'un produit adapté à des règlementations ferroviaires particulières. Avec la version actuelle de TC, on arrive à gérer quasiment toutes les situations. L'amélioration ne serait qu'une question de confort utilisateur.

Si, personnellement, j'avais à améliorer TC, je ne suis pas sûr que la gestion des décodeurs à 8 adresses serait ma première priorité. Mais, comme je l'ai dit, je ne suis pas dans la tête de Freiwald.

Jean


_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
ALBULA



Nombre de messages : 68
Date d'inscription : 17/08/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 14:04

Certes, sauf que c'est le décodeur qui a 8 adresses : chaque signal en a 4 au maximum...Ca représente 4 aspects de signal a minima...ce n'est pas si énorme...

Peut-être que pour nous Français (en tout cas pour ceux qui font de la SNCF) c'est rare, mais pour tous ceux qui font de l'allemand, du suisse, de l'autrichien, du néerlandais, du belge etc... (ça doit être des bons clients de Freiwald)...ce n'est pas si rare : la preuve, LDT a conçu des décodeurs à multi-adresses dédiés à ces réseaux...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9916
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 14:34

Jean_01 a écrit:
Avec la version actuelle de TC, on arrive à gérer quasiment toutes les situations. L'amélioration ne serait qu'une question de confort utilisateur.
Jean

Bien d'accord sur ce point.
Par contre, je revendique pour l'adressage direct des actions loco sans nécessité de passer par un canton ou un trajet.
De même, le matériel roulant apparait dans les listes de "déclencheurs" ou de "conditions", mais n'est pas utilisable. Pourquoi ?
Les intervenants sur le forum Freiwald seraient sympas d'en parler.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5380
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 15:40

DiCoS69 a écrit:

Par contre, je revendique pour l'adressage direct des actions loco sans nécessité de passer par un canton ou un trajet.

Je ne te suis pas bien. Pourrais-tu nous dire ce que tu aimerais faire grâce à cela et que tu ne peux pas faire aujourd'hui?

DiCoS69 a écrit:


De même, le matériel roulant apparait dans les listes de "déclencheurs" ou de "conditions", mais n'est pas utilisable. Pourquoi ?

Si, si, c'est utilisable dans les Groupes Combi de la version Gold. Smile Smile et c'est même assez puissant comme truc Smile

Jean


_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
DiCoS69

avatar

Nombre de messages : 9916
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 17:35

Jean_01 a écrit:


Je ne te suis pas bien. Pourrais-tu nous dire ce que tu aimerais faire grâce à cela et que tu ne peux pas faire aujourd'hui?
Jean

Et bien :
- 1 trajet et plusieurs trains utilisateurs de ce trajet.
- Au départ, des fonctions différentes à activées suivant les trains bien que ces fonctions soient présentes sur tous.

Comment faire la sélection sans indiquer d'adresse ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
BUBU10

avatar

Nombre de messages : 139
Age : 68
Localisation : TROYES
Emploi : retraité
Loisirs : trains généalogie informatique moto
Date d'inscription : 18/03/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 18:51

Bonsoir,
pour les fonctions, il suffit de créer de nouvelles icones de fonction spécifiques à chaque loco, mais ça peut devenir vite ingérable.
Amicalement train.
claude
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   

Revenir en haut Aller en bas
 
Affichage du signal ne correspond pas à la programmation
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 2 sur 3Aller à la page : Précédent  1, 2, 3  Suivant
 Sujets similaires
-
» Affichage du signal ne correspond pas à la programmation
» Erreur java affichage didacticiel fourni avec E-Anim
» [Résolu] Affichage images dans un mail
» Affichage sous IE des smileys et gif animés
» [Résolu] Problème affichage diapo powerpoint sous firefox

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Signalisation sur le réseau-
Sauter vers: