Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Affichage du signal ne correspond pas à la programmation

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : Précédent  1, 2, 3
AuteurMessage
DiCoS69

avatar

Nombre de messages : 9703
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 20:06

BUBU10 a écrit:
Bonsoir,
pour les fonctions, il suffit de créer de nouvelles icones de fonction spécifiques à chaque loco, mais ça peut devenir vite ingérable.
Amicalement train.
claude
Oui, mais bon ! Avec le numérique et l'outil informatique, y'a moyen de faire mieux.
Tous les ingrédients sont là, il suffit que le développeur ait la volonté de le faire...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Christophe

avatar

Nombre de messages : 2037
Age : 59
Localisation : Nantes
Emploi : Journaliste
Date d'inscription : 07/06/2009

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 20:24

DiCoS69 a écrit:
- Au départ, des fonctions différentes à activées suivant les trains bien que ces fonctions soient présentes sur tous.
Comment faire la sélection sans indiquer d'adresse ?

Demande à Rico, il m'a passé une bonne "recette" que je peux résumer ainsi, on fait un bouton de fonction associé à une macro en fonction de la loco, on indique dans le trajet l'action de ce bouton... et voilà !

J'espère ne rien oublier, ça fait déjà un moment que je les ai faites :
On crée un bouton associé à une liste dans la loco,




Dans la liste on indique quelle macro, dont voici un exemple de contenu,




Puis dans le trajet et le block voulu on indique quel bouton on veut actionner.




Dans cet exemple, on actionne le changement de position des feux d'une rame réversible (loco + voiture pilote), certaines locos repartent avec un feu rouge arrière d'autre sans aucun feu ! Selon la macro associée au bouton...

Rico me corrigera si ce n'est pas exactement ça !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://traindejardin.free.fr
Jean_01

avatar

Nombre de messages : 5302
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 20:26

DiCoS69 a écrit:
Et bien :
- 1 trajet et plusieurs trains utilisateurs de ce trajet.
- Au départ, des fonctions différentes à activées suivant les trains bien que ces fonctions soient présentes sur tous.

Comment faire la sélection sans indiquer d'adresse ?

C'est très simple, les groupes Combi sont tes amis, comme je le disais Smile Smile

Mettons deux locos A et B qui ont toutes deux les fonctions 1, 2, 3, 4.

Sur le trajet X, je veux que lors du départ du trajet, si c'est la loco A qui démarre, on déclenche les fonctions 1 et 2 et si c'est la loco B qui démarre, on déclenche les fonctions 3 et 4.

Je pense que c'est ce que tu veux faire.

A créer, deux macros:

- Macro 1:
a) dans l'onglet Opérations je mets les fonctions 1 et 2
b) dans l'onglet Condition, je mets un groupe Combi avec la loco A et le canton de départ du trajet X

- Macro 2:
a) dans l'onglet Opérations je mets les fonctions 3 et 4
b) dans l'onglet Condition, je mets un groupe Combi avec la loco B et le canton de départ du trajet X

Dans le trajet X, je mets dans les opérations au départ, une liste avec Macro 1 et Macro 2

Résultat: si c'est la loco 1 qui est dans le canton de départ, c'est la macro 1 qui va s'exécuter et donc les fonctions 1 et 2 de cette locomotive; Si c'est la loco 2 qui est dans le canton de départ, c'est la Macro 2 qui s'exécute et donc les fonctions 3 et 4 de cette locomotive.

Essaye, tu vas voir, ça marche pile poil Smile Smile

Jean

P.S: les groupes Combi n'existent que dans la version Gold Embarassed

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
Jean_01

avatar

Nombre de messages : 5302
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 20:32

Christophe a écrit:
DiCoS69 a écrit:
- Au départ, des fonctions différentes à activées suivant les trains bien que ces fonctions soient présentes sur tous.
Comment faire la sélection sans indiquer d'adresse ?

Demande à Rico, il m'a passé une bonne "recette" que je peux résumer ainsi, on fait un bouton de fonction associé à une macro en fonction de la loco, on indique dans le trajet l'action de ce bouton... et voilà !


Euhhhh ... je ne pense pas que ce soit la bonne solution. Cette solution revient au même, me semble-t-il, que celle préconisée par BUBU10, c'est à dire à avoir des fonctions différentes par loco. Smile Smile

Jean Smile

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
DiCoS69

avatar

Nombre de messages : 9703
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Ven 24 Sep - 21:49

Jean_01 a écrit:

C'est très simple, les groupes Combi sont tes amis, comme je le disais Smile Smile
Essaye, tu vas voir, ça marche pile poil Smile Smile

Jean

P.S: les groupes Combi n'existent que dans la version Gold Embarassed
Certes, ces "groupes combi" permettent de s'en sortir avec la Gold, mais autant de trains, autant de macros et de groupes combi.
Ce que je ne m'explique pas, c'est pourquoi la fonctionnalité directe par l'adresse n'existe pas, alors qu'avec nos centrales, tu appelles une adresse, tu tapes la fonction et hop, c'est emballé. Idem en manuel avec les tableaux de conduite. Il n'y a donc plus, dans le logiciel, qu'à lier une adresse à une suite d'actions.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Yann

avatar

Nombre de messages : 1661
Age : 35
Localisation : Suisse - Entre Lausanne et Vevey
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Sam 25 Sep - 8:24

ALBULA a écrit:
Yann, est-ce comme cela que tu as paramétré tes déclencheurs pour chacun des états de ton signal 4 feux ?
J'avais fait cette programmation avant l'apparition de l'onglet "Déclencheur" dans les signaux. J'ai donc utilisé des drapeau pour chaque image avec les conditions qui vont bien.
À l'occasion je pourrais essayé de supprimer les drapeaux et de mettre les conditions dans les signaux directement mais vu le cas ça me semble plus compliqué et honnêtement parlant pour avoir fait quelques essais lors de l'apparition des déclencheurs dans les signaux je trouve le fonctionnement un peu bizarre, c'est pourquoi je suis resté sur les drapeaux.

_________________
A+ Yann  
Mes tuto vidéo sur TrainController => http://www.youtube.com/TheDigitrain <=
Mon blog => http://blogyann.blogspot.ch <=
TC 8 Gold-Silver/+SmartHand Mobile/+Net/H0 3 rails/2rails/Tams MasterControl/rétro. bus Selectrix SLX 852/Compaq 2 GHz, MacPro 2.66 GHz Quad-Core Intel Xeon/VMWare Fusion/Windows 7/XP Pro SP3/iPhone 6 iOS 9.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.digi-train.ch/
Jean_01

avatar

Nombre de messages : 5302
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Sam 25 Sep - 9:18

DiCoS69 a écrit:

Certes, ces "groupes combi" permettent de s'en sortir avec la Gold, mais autant de trains, autant de macros et de groupes combi.

Ce que je ne m'explique pas, c'est pourquoi la fonctionnalité directe par l'adresse n'existe pas, alors qu'avec nos centrales, tu appelles une adresse, tu tapes la fonction et hop, c'est emballé.

Elie,

J'ai un peu de mal à te suivre. Peux-tu nous expliquer, comment, en automatique, tu vas demander à TC d'appeler une adresse et de taper une fonction?

Comment pourrait-on appeler une adresse autrement qu'avec une macro ou une liste d'actions?

C'est exactement ce qu'on fait en appelant le train dans un groupe Combi. La seule différence avec ce que tu préconises, c'est qu'on appelle le train par son nom alors que tu voudrais l'appeler par son adresse.

Avec ton système, le jour où tu modifies l'adresse d'une loco, tu devras modifier toutes les actions dans lesquelles tu appelles ta loco par son adresse. Avec le système actuel, tu peux modifier toutes les adresses de tes locos sans modifier leurs noms et tes actions continueront à fonctionner.

Jean

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
Yann

avatar

Nombre de messages : 1661
Age : 35
Localisation : Suisse - Entre Lausanne et Vevey
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Sam 25 Sep - 10:55

Jean_01 a écrit:

Avec ton système, le jour où tu modifies l'adresse d'une loco, tu devras modifier toutes les actions dans lesquelles tu appelles ta loco par son adresse. Avec le système actuel, tu peux modifier toutes les adresses de tes locos sans modifier leurs noms et tes actions continueront à fonctionner.

Oui et c'est bien ça les avantages de l'adressage indirect! Ce qui n'est pas le cas de tout les logiciels.
Ta Re 460 restera la Re 460 peu importe l'adresse qu'elle a et même si elle change tu le fais qu'à un endroit, dans les propriétés de ta loco.

_________________
A+ Yann  
Mes tuto vidéo sur TrainController => http://www.youtube.com/TheDigitrain <=
Mon blog => http://blogyann.blogspot.ch <=
TC 8 Gold-Silver/+SmartHand Mobile/+Net/H0 3 rails/2rails/Tams MasterControl/rétro. bus Selectrix SLX 852/Compaq 2 GHz, MacPro 2.66 GHz Quad-Core Intel Xeon/VMWare Fusion/Windows 7/XP Pro SP3/iPhone 6 iOS 9.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.digi-train.ch/
DiCoS69

avatar

Nombre de messages : 9703
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Sam 25 Sep - 14:12

Jean_01 a écrit:

Comment pourrait-on appeler une adresse autrement qu'avec une macro ou une liste d'actions?
Je trouverais intéressant d'avoir la possibilité de sélectionner un train dans les listes d'actions des "options du canton" dans un trajet, par exemple.
Ou d'avoir la possibilité d'ouvrir une fenêtre "Options du train" dans un trajet, celle-ci permettant des actions de train avec des "déclencheurs", voire des "conditions".
Heu, en fait, ça revient un peu à faire une macro...

Jean_01 a écrit:
C'est exactement ce qu'on fait en appelant le train dans un groupe Combi. La seule différence avec ce que tu préconises, c'est qu'on appelle le train par son nom alors que tu voudrais l'appeler par son adresse.
Avec ton système, le jour où tu modifies l'adresse d'une loco, tu devras modifier toutes les actions dans lesquelles tu appelles ta loco par son adresse. Avec le système actuel, tu peux modifier toutes les adresses de tes locos sans modifier leurs noms et tes actions continueront à fonctionner.
Jean
Quand je dis "adresse", ce peut être le nom de la loco, je n'y vois aucun inconvénient, d'autant plus que je suis d'accord avec l'argument invoqué.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5302
Age : 70
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Sam 25 Sep - 16:28

DiCoS69 a écrit:

Je trouverais intéressant d'avoir la possibilité de sélectionner un train dans les listes d'actions des "options du canton" dans un trajet, par exemple.

Ben cela tu l'as déjà.
Dans les options du canton, tu choisis, à l'entrée du canton, par exemple et tu cliques sur le bouton "Liste". Là tu mets n'importe quelle opération de locomotive et dans l'onglet "Condition", tu mets un groupe Combi avec le canton et la ou les locos que tu veux Smile Smile

DiCoS69 a écrit:

Ou d'avoir la possibilité d'ouvrir une fenêtre "Options du train" dans un trajet, celle-ci permettant des actions de train avec des "déclencheurs", voire des "conditions".


Cela, on n'a pas, mais tel que je te connais, tu ne tarderais pas à me dire, que dans cette fenêtre il faudrait pouvoir spécifier si l'action doit se faire au départ, à l'arrivée ou dans un canton du trajet ... ce qu'on peut déjà faire aujourd'hui Smile Smile

DiCoS69 a écrit:

Heu, en fait, ça revient un peu à faire une macro...


Smile Smile Smile

Jean taquin Smile Smile

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
DiCoS69

avatar

Nombre de messages : 9703
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   Sam 25 Sep - 17:20

En résumé, quand tu n'as pas ce que tu veux, va au "groupe Combi", y font tout ! Very Happy Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Affichage du signal ne correspond pas à la programmation   

Revenir en haut Aller en bas
 
Affichage du signal ne correspond pas à la programmation
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 3 sur 3Aller à la page : Précédent  1, 2, 3
 Sujets similaires
-
» Affichage du signal ne correspond pas à la programmation
» Erreur java affichage didacticiel fourni avec E-Anim
» [Résolu] Affichage images dans un mail
» Affichage sous IE des smileys et gif animés
» [Résolu] Problème affichage diapo powerpoint sous firefox

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Signalisation sur le réseau-
Sauter vers: