Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 signaux dans les AE

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2  Suivant
AuteurMessage
dudule

avatar

Nombre de messages : 1139
Age : 65
Localisation : fourques
Emploi : Papé à temps plein. au 01 01 14
Loisirs : modélisme air et fer et autres conceptions inutiles stockeur de stylo publicitaire (+ de 3000 dans les caisses)
Date d'inscription : 05/04/2008

MessageSujet: signaux dans les AE   Jeu 13 Avr - 20:27

bonsoir
j'ai créé un signal dans les accessoires étendus et maintenant j'aimerais créé un sémaphore qui soit dans les mêmes proportions si je le crée dans les signaux je n'arrive pas à rester dans les mêmes proportions,puis je le créé dans les AE sans que cela pose problème ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9825
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: signaux dans les AE   Jeu 13 Avr - 23:27

Je ne vois pas pourquoi tu n'obtiens pas les même proportions au TCO...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dudule

avatar

Nombre de messages : 1139
Age : 65
Localisation : fourques
Emploi : Papé à temps plein. au 01 01 14
Loisirs : modélisme air et fer et autres conceptions inutiles stockeur de stylo publicitaire (+ de 3000 dans les caisses)
Date d'inscription : 05/04/2008

MessageSujet: Re: signaux dans les AE   Ven 14 Avr - 7:42

bonjour Elie
ci joint deux captures d'écran pour explication Embarassed
en bas à gauche on voit mon Sémaphore bien plus petit que la partie de gauche de mon autre signal




Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rico

avatar

Nombre de messages : 5395
Age : 52
Localisation : Région de Vitré (35)
Emploi : Formation technique en automatismes
Loisirs : Train HO et bricolage en tout genre
Date d'inscription : 11/05/2008

MessageSujet: Re: signaux dans les AE   Ven 14 Avr - 8:11

Si tu mettais le même nombre de carreau sur chaque AE...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9825
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: signaux dans les AE   Ven 14 Avr - 12:58

dudule a écrit:
bonjour Elie
ci joint deux captures d'écran pour explication Embarassed
en bas à gauche on voit mon Sémaphore bien plus petit que la partie de gauche de mon autre signal

Même constat que Rico...
Évidemment, sur l'AE, non seulement tu utilises 2 carreaux, mais ton signal de base est un 4 feux (C).
Si tu veux effectivement la taille identique, il te faut soit réduire ton AE, soit créer un autre AE avec 2 carreaux pour le sémaphore, ce qui est faisable, mais donne un peu plus de travail...
Je me demande également si tu es dans le bon format... essaie de faire le dessin en 16x16 au lieu de 28x28
Un conseil, déporte un peu le dessin du côté voie.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dudule

avatar

Nombre de messages : 1139
Age : 65
Localisation : fourques
Emploi : Papé à temps plein. au 01 01 14
Loisirs : modélisme air et fer et autres conceptions inutiles stockeur de stylo publicitaire (+ de 3000 dans les caisses)
Date d'inscription : 05/04/2008

MessageSujet: Re: signaux dans les AE   Ven 14 Avr - 14:25

merci à vous deux pour les réponses
bon je me suis mal expliqué
en fait la première image représente un dessin dans les AE
la deuxième image représente un dessin dans les signaux (édition image pour un signal trois feux)
pour éviter ce problème ,puis je créé un Sémaphore dans les AE sans que cela pose de problèmes pour sa programmation ( c'était la question initiale Embarassed ) en espérant avoir été plus clair Question
ou dit autrement; y a il contre indication à réaliser un objet simple dans les AE

pour Elie j'ai fait sur deux carreaux et là çà correspond à ce que je veux mais pour la programmation sur les cartes 100401 çà peut le  faire?


Dernière édition par dudule le Ven 14 Avr - 14:44, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dudule

avatar

Nombre de messages : 1139
Age : 65
Localisation : fourques
Emploi : Papé à temps plein. au 01 01 14
Loisirs : modélisme air et fer et autres conceptions inutiles stockeur de stylo publicitaire (+ de 3000 dans les caisses)
Date d'inscription : 05/04/2008

MessageSujet: Re: signaux dans les AE   Ven 14 Avr - 14:43

remoi
je viens de m’apercevoir que si je veux actionner mon signal sur le TCO la petite lanterne n'est pas utilisable sur le Sémaphore alors quelle l'est sur l'autre signal ? avez vous une idée du pourquoi?

bon à plus, j'ai la pitchounette qui réclame
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9825
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: signaux dans les AE   Ven 14 Avr - 18:02

Gérard, il faudrait un peu te concentrer, parce que la "petite lanterne" comme tu dis, elle fonctionne sur tous les accessoires... que ce soit signaux, aiguilles ou boutons.
Peut-être as-tu essayé avec le programme non actif... ou en mode édition sans l'avoir sélectionnée... ou alors, tu n'as pas créé les différents états de l'AE...


Dernière édition par DiCoS69 le Ven 14 Avr - 18:39, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9825
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: signaux dans les AE   Ven 14 Avr - 18:14

dudule a écrit:
merci à vous deux pour les réponses
bon je me suis mal expliqué
en fait la première image représente un dessin dans les AE
la deuxième image représente un dessin dans les signaux (édition image pour un signal trois feux)
pour éviter ce problème ,puis je créé un Sémaphore dans les AE sans que cela pose de problèmes pour sa programmation ( c'était la question initiale Embarassed ) en espérant avoir été plus clair Question
ou dit autrement; y a il contre indication à réaliser un objet simple dans les AE

pour Elie j'ai fait sur deux carreaux et là çà correspond à ce que je veux mais pour la programmation sur les cartes 100401 çà peut le  faire?

Est-ce que tu lis entièrement les réponses..? Smile
J'ai dit que c'était faisable...
C'est faisable, à condition de programmer l'AE convenablement sur 2 adresses.
Ça ne changera rien pour le décodeur, mais tu te compliques la vie...
As-tu essayé le dessin en 16x16... j'ai les deux types (signal et AE) sur mon TCO et je n'ai pas une telle différence de taille, mais il y en a une quand même. Ce qui n'est pas gênant vu qu'ils ne sont pas côte à côte...
Si tu prends 2 pixels de plus en largeur, ça lui donnera plus de "corps".
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dudule

avatar

Nombre de messages : 1139
Age : 65
Localisation : fourques
Emploi : Papé à temps plein. au 01 01 14
Loisirs : modélisme air et fer et autres conceptions inutiles stockeur de stylo publicitaire (+ de 3000 dans les caisses)
Date d'inscription : 05/04/2008

MessageSujet: Re: signaux dans les AE   Ven 14 Avr - 20:22

OK merci Elie
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dudule

avatar

Nombre de messages : 1139
Age : 65
Localisation : fourques
Emploi : Papé à temps plein. au 01 01 14
Loisirs : modélisme air et fer et autres conceptions inutiles stockeur de stylo publicitaire (+ de 3000 dans les caisses)
Date d'inscription : 05/04/2008

MessageSujet: Re: signaux dans les AE   Lun 17 Avr - 19:20

bonjour
bon pour le problème concernant la (petite lanterne) j'ai trouvé à la création de mon signal dans contrôle j'ai sélectionné contrôle d'indicateur au lieu de interrupteur voila maintenant tous mes signaux seront crées en AE je trouve que cela fonctionne bien ; j'ai déjà créé un à 8 états et un à 6 états raccordés à des cartes 100401 une merveille
merci Elie
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Phil95



Nombre de messages : 94
Localisation : Val d'Oise
Date d'inscription : 07/09/2012

MessageSujet: Re: signaux dans les AE   Mar 18 Avr - 11:32

Bonjour à tous,

Je suis aussi intéresse par les signaux complexes.

Quel document vous sert de base pour développer ces signaux ?
Est-ce qu'il existe un tuto ?

Merci.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9825
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: signaux dans les AE   Mar 18 Avr - 16:57

Phil95 a écrit:
Bonjour à tous,

Je suis aussi intéresse par les signaux complexes.

Quel document vous sert de base pour développer ces signaux ?
Est-ce qu'il existe un tuto ?

Merci.

Salut Phil,
J'ai pondu un bout de notice pour créer des signaux en "accessoires étendus" et les commander avec le décodeur 100401.
Si je ne te l'ais pas encore fait passé, je peux te l'envoyer si ça t'intéresse.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
claude1



Nombre de messages : 641
Age : 67
Localisation : region parisienne et Arreau
Emploi : retraité
Loisirs : trains
Date d'inscription : 10/09/2011

MessageSujet: Re: signaux dans les AE   Mar 18 Avr - 18:09

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dudule

avatar

Nombre de messages : 1139
Age : 65
Localisation : fourques
Emploi : Papé à temps plein. au 01 01 14
Loisirs : modélisme air et fer et autres conceptions inutiles stockeur de stylo publicitaire (+ de 3000 dans les caisses)
Date d'inscription : 05/04/2008

MessageSujet: Re: signaux dans les AE   Mar 18 Avr - 19:22

bonsoir phil95 , j'ai suivi les indications d'Elie j'ai ses docs qu'il ma fourni avec les 100401 ,super matos facile à programmer. pour ce qui est des AE je commence à apprivoiser c'est formidable.
de toutes façons ici il y a les supers experts de TC pour nous aider
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Phil95



Nombre de messages : 94
Localisation : Val d'Oise
Date d'inscription : 07/09/2012

MessageSujet: Re: signaux dans les AE   Mar 18 Avr - 22:09

DicoS69, dudule,

Si la notice "accessoire étendu" créer pour le 100401 peut etre adaptée à d'autres décodeurs,
je suis preneur.

Claude1,

Merci pour le lien vers le tuto: je me suis basé sur ce tuto et le suivant pour créer mon signal à 8 états en accessoire étendu:
En fait 2 versions différentes: les 2 en bas à droite, car j'ai un problème: le mode "test" ne fonctionne pas. Mais la commande via les équations ("déclencheur" et "condition") fonctionne correctement sur le TCO.
" />

Ma centrale étant rarement connectée à mon PC, je n'ai pas eu le temps de tout sortir pour essayer "pour de vrai" de commander mon décodeur de signal (Unisem648) avec mon signal créé sous TC.
J'espère avoir le temps pour le faire demain soir.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9825
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: signaux dans les AE   Mar 18 Avr - 22:30

Si tu as trouvé un tuto, il ne sert à rien que je t'envoie ma notice...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Phil95



Nombre de messages : 94
Localisation : Val d'Oise
Date d'inscription : 07/09/2012

MessageSujet: Re: signaux dans les AE   Mer 19 Avr - 6:51

DicoS69,

Pour l'instant, j'ai "partiellement" réussi à créer mon signal: le mode test ne fonctionne pas !

Donc, si la méthode que vous utilisez permet d'avoir un mode test, je suis preneur !

Phil
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9825
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: signaux dans les AE   Mer 19 Avr - 20:44

Qu'entends-tu par "mode test" ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9825
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: signaux dans les AE   Jeu 20 Avr - 11:10

Phil95 a écrit:
DicoS69,

Pour l'instant, j'ai "partiellement" réussi à créer mon signal: le mode test ne fonctionne pas !

Phil

Pour tester un AE, il faut que TC soit "Actif", aller dans les propriétés de l'accessoire, onglet "Connexion", sélectionner le picto dans la grille et utiliser le levier d'activation manuelle.
Autre possibilité, si l'AE est déposé au TCO, l'activer directement avec le levier.
Si ton AE est correctement créé, les états changent successivement.
Tu dois avoir créé une image par état...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Phil95



Nombre de messages : 94
Localisation : Val d'Oise
Date d'inscription : 07/09/2012

MessageSujet: Re: signaux dans les AE   Jeu 20 Avr - 15:33

Le mode test dont je parle c'est bien celui avec le levier: " />

Cela ne fonctionne pas, ni dans l'AE/propriété/connexion,

Ni pour l'AE posé dans un TCO

Le curseur est remplacé un panneau "interdit":  " />


Par contre, si je programme les 4 premiers états de mon AE pour recopier un signal standard a 4 états, le levier me permet de basculer (tester) les 4 états du signal, et mon AE recopie bien ces changement d'états.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9825
Age : 70
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: signaux dans les AE   Jeu 20 Avr - 15:59

Alors, où est le problème...?
Le levier ne peut pas faire afficher des états qui n'existent pas...!
Quand tu utilises un signal "classique", les différents états (images) sont déjà créés, c'est pour ça que tu peux les faire afficher directement avec le levier... ce n'est pas le cas avec l'AE.
Ce n'est pas seulement la couleur des feux qui change, mais la totalité de l'image qui est reprise pour chaque état.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Phil95



Nombre de messages : 94
Localisation : Val d'Oise
Date d'inscription : 07/09/2012

MessageSujet: Re: signaux dans les AE   Jeu 20 Avr - 20:39

J'ai bien créer mes 8 états avec 8 dessins différents, 8 commandes d’accessoires DCC, et j'ai renseigné les équations (declenchement et condition) de chacun des 8 états.

Quand je test en modifiant une des variables des équations (je commute un aiguillage sur le TCO par ex.), j'ai bien l'état de l'AE qui change. Mais je ne peux pas vérifier tous les états car certains états dépendent des cantons que je ne peux pas modifier avec le levier (occupés ou libres).

Du coup, je comptait sur le mode test, mais, sur le TCO, quand j’amène la souris sur mon AE, le levier n'apparait pas, à la place j'ai le panneau "interdit". Mais le mode test (levier) fonctionne sur les signaux et les aiguillages.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Phil95



Nombre de messages : 94
Localisation : Val d'Oise
Date d'inscription : 07/09/2012

MessageSujet: Re: signaux dans les AE   Jeu 20 Avr - 21:02

Bon, finalement, j'ai utilisé le mode "simulator" pour faire circuler une loco sur mon ovale, et je vois bien mon AE passer dans les 4 états selon l’occupation des cantons et la position de l'aiguillage M1.

Reste à simuler un autre trajet pour vérifier les 4 autres etats:
Ça marche correctement, les 8 états basculent correctement en fonction de mes 3 aiguillages et des 7 cantons.

Mais le mode test (levier) ne fonctionne toujours pas.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Geo69



Nombre de messages : 3687
Age : 69
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

MessageSujet: Re: signaux dans les AE   Ven 21 Avr - 7:43

Bonjour,

Phil95 a écrit:
... Mais le mode test (levier) ne fonctionne toujours pas.
Essaie de repartir d'un cas le plus simple possible :
- Création d'un AE (mode édition/menu outils/Accessoires/AE/Gérer/nouveau)
- Dans l'onglet contrôles :
.. Cliquer sur interrupteur à droite pour le déposer au centre à gauche.
.. Cliquer sur propriétés à droite et mettre au moins une opération pour l'un des deux états (par exemple commande de vitesse).
- Sur le TCO, sélectionner l'AE crée et le déposer.
- Sortir du mode édition et là on a bien l'outil de manoeuvre lorsque l'on passe le curseur de la souris sur l'AE.
- Idem, en mode édition, après avoir cliqué sur l'icône dans les propriétés de l'AE (onglet connexion).

Cela se passe aussi comme cela chez toi pour ce cas de base ?

A+
Georges
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: signaux dans les AE   

Revenir en haut Aller en bas
 
signaux dans les AE
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 2Aller à la page : 1, 2  Suivant

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Signalisation sur le réseau-
Sauter vers: