Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez
 

 activation des aiguillages

Aller en bas 
AuteurMessage
Jacques Detaille

Jacques Detaille

Nombre de messages : 43
Age : 67
Localisation : Herbeumont ( Belgique)
Loisirs : Train de jardin Ech IIm
Date d'inscription : 25/06/2007

activation des aiguillages Empty
MessageSujet: activation des aiguillages   activation des aiguillages EmptyDim 10 Fév - 8:38

Bonjour.
Dans le cadre d'un réseau d' exposition, j' ai créé un TCO reprenant l' ensemble du réseau. J' ai également créé une vingtaine de "routes" qui n'ont pour but que de simplifier la gestion d' aiguillages à l' entrée ou à la sortie des 3 gares.
Lorsque j' active l' une ou l' autre de ces "routes", il arrive que certains aiguillages ne s' activent pas; sur le TCO, ils ont pourtant changé de position.
Ils fonctionent pourtant sans problèmes individuellement.
Toutes les adresses sont correctes.
J' utilise une centrale ZIMO et des modules "Lenz" LS150 .
Quelqu'un aurait il une explication ?
Merci.
Jacques.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.atmsl.eu
Jean_01
Ignare immobile
Jean_01

Nombre de messages : 5981
Age : 72
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

activation des aiguillages Empty
MessageSujet: Re: activation des aiguillages   activation des aiguillages EmptyDim 10 Fév - 14:58

Bonjour,

Je pense que c'est un problème de rapidité d'envoi des commandes et de temps de réaction des décodeurs d'aiguilles.
Votre problème, je pense, survient avec des aiguilles connectées au même décodeur. Si la commande envoyée à la première aiguille n'est pas terminée lorsque la commande vers l'aiguille suivante est envoyée, cette dernière n'est pas exécutée.

Il faut faire un petit réglage au niveau du fichier Railroad.ini, dans la variable SendInterval. Cette variable règle l'intervalle d'envoi entre deux commandes d'aiguilles ou de signaux.

Si mes souvenirs sont bons, les valeurs pour cette variable sont en millisecondes.

Jean
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
Yann

Yann

Nombre de messages : 1815
Age : 37
Localisation : Suisse - Entre Lausanne et Vevey
Date d'inscription : 25/06/2007

activation des aiguillages Empty
MessageSujet: Re: activation des aiguillages   activation des aiguillages EmptyLun 11 Fév - 0:13

Jean_01 a écrit:
Il faut faire un petit réglage au niveau du fichier Railroad.ini, dans la variable SendInterval. Cette variable règle l'intervalle d'envoi entre deux commandes d'aiguilles ou de signaux.

Si mes souvenirs sont bons, les valeurs pour cette variable sont en millisecondes.

Pas besoin d'aller toucher le fichier .INI. Dans TrainController allez simplement sous:
RRTC > Configurer les systèmes numériques
Dans la liste double cliquez sur votre système Zimo. Dans la fenêtre qui apparaît vous pouvez mettre une valeur de 100 (millisecondes), par exemple, sous "Intervalle aiguillage". Faites des essais et si ceci n'est pas concluant augmenter la valeur.

_________________
A+ Yann  
Mes tuto vidéo sur TrainController => https://www.youtube.com/TheDigitrain <=
Mon site => http://www.digi-train.ch <=
TC 9 Gold / +SmartHand Mobile / +Net / H0 3 rails / H0 2 rails / Tams MasterControl / Rétro. et commande des signaux: Selectrix Businterface Peter Stärz / PC 3,3 GHz / Win XP, 7, 10 / iPhone 6 iOS 12.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.digi-train.ch/
Pierrot

Pierrot

Nombre de messages : 98
Age : 81
Localisation : 13400 AUBAGNE
Emploi : Retraité
Loisirs : Modélisme train - Randonnées pédestres
Date d'inscription : 28/09/2007

activation des aiguillages Empty
MessageSujet: Re: activation des aiguillages   activation des aiguillages EmptyLun 11 Fév - 9:04

J'ai eu le même problème et en augmentant la valeur "intervalle aiguillage" comme dit Yann tout est rentré dans l'ordre.

Un petit consiel, faire plusieurs essais car suivant la position des aiguilles au moment où tu actives ta route, il y aura plus ou moins d'aiguilles qui seront maneuvrées et il y aura donc plus ou moins besoin de courant instentanément pour les manoeuvrer.

Pour cotroler que la valeur d'intervale etait bonne, j'avais pour une route donnée mis manuellement par le TCO toutes les aiguilles concernées par cette route dans la position opposée et donc quand j'activais ma route, c'était le nombre maximum d'aiguilles qui étaient manoeuvrées à la cadence de l'intervalle d'aiguilles.

Bonne journée

Pierrot
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jacques Detaille

Jacques Detaille

Nombre de messages : 43
Age : 67
Localisation : Herbeumont ( Belgique)
Loisirs : Train de jardin Ech IIm
Date d'inscription : 25/06/2007

activation des aiguillages Empty
MessageSujet: Re: activation des aiguillages   activation des aiguillages EmptyLun 11 Fév - 14:46

Bonjour,
J' ai bien suivi vos conseils.
Avec 500 ms dans l"Intervalle aiguillage", tout est rentré dans l' ordre.
Encore merci.
Jacques.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.atmsl.eu
coquelicot94

coquelicot94

Nombre de messages : 3899
Age : 66
Localisation : MAROEUIL 62
Emploi : Retraité
Loisirs : Devinez
Date d'inscription : 03/09/2008

activation des aiguillages Empty
MessageSujet: Re: activation des aiguillages   activation des aiguillages EmptyMar 20 Oct - 18:22

Jacques Detaille a écrit:
Bonjour,
J' ai bien suivi vos conseils.
Avec 500 ms dans l"Intervalle aiguillage", tout est rentré dans l' ordre.
Encore merci.
Jacques.
bonsoir, j'ai un ou 2 aiguillages (aiguillages numériques) sur plus de 60 qui ne prennent pas la bonne position sur un trajet en particulier. Je suis en 500ms d'intervalle aiguillage. Que faut-il faire pour éviter cela et s'il n'y a rien à faire, comment interdire à la machine de s'engager sur cette mauvaise route?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Bernard

Bernard

Nombre de messages : 2329
Age : 67
Localisation : Sailly lez Lannoy
Emploi : Architecte
Loisirs : Modélisme.... alpinisme...
Date d'inscription : 20/02/2009

activation des aiguillages Empty
MessageSujet: Re: activation des aiguillages   activation des aiguillages EmptyMer 21 Oct - 5:34

Bonjour,
J'ai eu la même chose récemment l'aiguille se mettait en bonne position quand elle était commandée droite, mais ne basculait pas quand elle devait être déviée.
La tendance est d'accuser le trajet ou le logiciel puisque "avant cela marchait"
Après moult tentative je me suis aperçu que le problème n'était que mécanique. Un dur s'était créé dans le fonctionnement et l'aiguille rebondissait. A l'écran sur le TCO l'aiguille était belle et bien déviée, elle en avait reçu l'ordre et sur la voie elle avait rebondie et était revenue en position droite.
As tu regardé celé?
Cordialement Bernard
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
coquelicot94

coquelicot94

Nombre de messages : 3899
Age : 66
Localisation : MAROEUIL 62
Emploi : Retraité
Loisirs : Devinez
Date d'inscription : 03/09/2008

activation des aiguillages Empty
MessageSujet: Re: activation des aiguillages   activation des aiguillages EmptyMer 21 Oct - 6:22

bonjour , je vais essayer de changer l'aiguillage ou le moteur..
A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

DiCoS69

Nombre de messages : 11856
Age : 71
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

activation des aiguillages Empty
MessageSujet: Re: activation des aiguillages   activation des aiguillages EmptyMer 21 Oct - 14:19

Bernard a écrit:

Après moult tentative je me suis aperçu que le problème n'était que mécanique. Un dur s'était créé dans le fonctionnement et l'aiguille rebondissait. A l'écran sur le TCO l'aiguille était belle et bien déviée, elle en avait reçu l'ordre et sur la voie elle avait rebondie et était revenue en position droite.
As tu regardé celé?
Cordialement Bernard
C'est assez fréquent sur les aiguilles à solénoïdes qui n'ont pas de verrouillage. Ce défaut n'existe pas avec des moteurs lents, fil à mémoire ou servos.
A+
Elie
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
coquelicot94

coquelicot94

Nombre de messages : 3899
Age : 66
Localisation : MAROEUIL 62
Emploi : Retraité
Loisirs : Devinez
Date d'inscription : 03/09/2008

activation des aiguillages Empty
MessageSujet: Re: activation des aiguillages   activation des aiguillages EmptyMer 21 Oct - 14:57

bonjour le mien il ne rebondit pas, on dirait qu'il n'a pas eu d'ordre. J'ai changé l'aiguillage, on verra...à moins que ce soit le moteur mais c'est assez aléatoire.
J'ai trouvé une parade pour un aiguillage qui se mettait en bonne position 8 fois sur 10, j'ai ajouté la fonction éxécuter l'aiguillage dans la macro de départ. Le résultat est OK. Smile
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




activation des aiguillages Empty
MessageSujet: Re: activation des aiguillages   activation des aiguillages Empty

Revenir en haut Aller en bas
 
activation des aiguillages
Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Les Trajets et Itinéraires-
Sauter vers: