Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Problème avec modulre RS-8

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2  Suivant
AuteurMessage
maxime_lec



Nombre de messages : 14
Localisation : Tours
Emploi : Cheminot
Date d'inscription : 30/10/2016

MessageSujet: Problème avec modulre RS-8   Ven 30 Déc - 16:03

Bonjour à tous,

Je rencontre un soucis avec mon module de rétrosignalisation RS-8 de chez LDT.

Après avoir raccordé correctement le module (alimentation du transfo, bus RS et bornes J K sur IN1 et IN2), j'appuie sur la touche S1. La LED clignote bien. J'envoie alors ma commande d'accessoire (+ ou  - avec F5 et l'adresse 66 sur la LH100). Après cela la diode se met à clignoter très rapidement en permanence.

De plus il m'est impossible de vérifier les positions de rétrosignalisation avec la fonction F6 de ma LH100 pour l'adresse de base 65 ou la nouvelle que j'essaie de saisir l'adresse 66. Par ce test j'ai toujours un "-" à la suite de l'adresse qui m'indique qu'il n'y a pas de module de rétrosignalisation.

Est-ce que quelqu'un a déjà rencontré ce soucis ? Je n'arrive pas à trouver sur le net ce que signifie le clignotement rapide de la LED après avoir essayé de changer l'adresse.

Merci d'avance pour votre aide
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Geo69



Nombre de messages : 3364
Age : 68
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

MessageSujet: Re: Problème avec modulre RS-8   Ven 30 Déc - 18:02

Bonsoir,

maxime_lec a écrit:
... Je rencontre un soucis avec mon module de rétrosignalisation RS-8 de chez LDT...
Rare ... C'est un modèle tout monté ? Je suppose que tu en as qu'un seul ?

maxime_lec a écrit:
... Après avoir raccordé correctement le module ...
Si tu le dis ...  Very Happy

maxime_lec a écrit:
... Après cela la diode se met à clignoter très rapidement en permanence...
J'ai déjà vu une led de RS8 continuer de clignoter (en principe sur un mauvais branchement) mais jamais se mettre à clignoter plus rapidement ...  scratch Lorsque tu appuies à nouveau sur la touche S1, que se passe t-il ?

maxime_lec a écrit:
... De plus il m'est impossible de vérifier les positions de rétrosignalisation avec la fonction F6 de ma LH100 pour l'adresse de base 65 ou la nouvelle que j'essaie de saisir l'adresse 66. Par ce test j'ai toujours un "-" à la suite de l'adresse qui m'indique qu'il n'y a pas de module de rétrosignalisation...
Effectivement, si tu n'as pas un petit "b" en bas à gauche de l'écran, c'est qu'il n'y a pas de module de rétro à cette adresse ... Mad

Ton RS8 est-il le seul module raccordé à la centrale ? Si ce n'est pas le cas, fais un branchement unitaire directement sur la centrale et le transfo le plus simple possible. Si ça ne marche pas, je ne vois que le module HS ... Mad

Nota : Au fait, tu arrives bien à commander un accessoire (par exemple aiguillage) avec la fonction F5 de ta centrale ? Désolé pour les questions basiques mais je ne sais pas quelle maîtrise tu as de ta centrale et commande à main ...  Embarassed

A+
Georges
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
maxime_lec



Nombre de messages : 14
Localisation : Tours
Emploi : Cheminot
Date d'inscription : 30/10/2016

MessageSujet: Re: Problème avec modulre RS-8   Ven 30 Déc - 19:27

Merci Georges pour ta réponse.

Donc en fait oui je n'ai qu'un seul module pour le moment. Dès que la LED clignote plus rapidement je ne peux plus rien faire (même en appuyant à nouveau sur le bouton S1).

J'ai refais le câblage plusieurs fois, pour finir avec le plus simple possible en le raccordant directement à la centrale et au transfo mais toujours le même résultat.

Pour l'instant je n'ai pas encore testé d'autres commandes avec la fonction F5. Mais c'est surprenant de ne pas avoir de réponse avec la fonction F6.

J'ai envoyé un mail à LDT, à voir si je vais avoir une réponse et une explication.

A +
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Geo69



Nombre de messages : 3364
Age : 68
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

MessageSujet: Re: Problème avec modulre RS-8   Sam 31 Déc - 11:28

Bonjour,

maxime_lec a écrit:
... Dès que la LED clignote plus rapidement je ne peux plus rien faire (même en appuyant à nouveau sur le bouton S1)...
Normalement l'appui sur le bouton S1 arrête la programmation, donc le clignotement "standard" de la led ...  Rolling Eyes
Je viens d'essayer divers cas de mauvais branchements, je ne suis pas arrivé à reproduire ton cas de clignotement rapide ...  scratch Tu ne nous a pas dit, ton module n'était pas en kit ?

maxime_lec a écrit:
... Pour l'instant je n'ai pas encore testé d'autres commandes avec la fonction F5. Mais c'est surprenant de ne pas avoir de réponse avec la fonction F6.

J'ai envoyé un mail à LDT, à voir si je vais avoir une réponse et une explication...
Tu as essayé de piloter une loco avec ta centrale voir de programmer un décodeur ? A ce stade, beaucoup d'hypothèses sont possibles depuis la panne d'un composant (centrale, LH100, transfo, module de rétro) jusqu'à plus probablement l'erreur humaine ...  Wink
L'idéal serait d'avoir un utilisateur pas trop loin de chez toi pour tester le module... En attendant une réponse de LDT, familiarise toi bien avec ta centrale, cela ne sera pas du temps de perdu ...  Smile  

A+
Georges
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Phil95



Nombre de messages : 67
Localisation : Val d'Oise
Date d'inscription : 07/09/2012

MessageSujet: Re: Problème avec modulre RS-8   Sam 31 Déc - 16:23

Un copain du club a reçu un GBM-8 qui ne fonctionnait pas, acheté "tout fini" chez LDT:
il y avait des composants avec de mauvaises valeurs de montés !

Module LDT en défaut: Rare mais pas impossible !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
claude1



Nombre de messages : 595
Age : 66
Localisation : region parisienne et Arreau
Emploi : retraité
Loisirs : trains
Date d'inscription : 10/09/2011

MessageSujet: Re: Problème avec modulre RS-8   Sam 31 Déc - 16:50

Bonjour,
Cela m'est arrivé sur le même type de module.
Une moitié fonctionnait sur les deux, cela était lié à une mauvaise valeur d'un réseau de résistances.
Ayant du stock dans mes réserves de composants j'ai remplacé le composant objet du délit plutôt que de renvoyer le module.
Cela n'a concerné qu'un module sur l'ensemble.
Claude
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
maxime_lec



Nombre de messages : 14
Localisation : Tours
Emploi : Cheminot
Date d'inscription : 30/10/2016

MessageSujet: Re: Problème avec modulre RS-8   Lun 2 Jan - 10:58

Encore merci pour vos retours.

Quand la LED clignote rapidement, même si j'appuie sur le bouton S1 rien ne change. J'ai acheté ce module directement sur le site de LDT et c'est un modèle fini. Du coup je vais regarder si je trouve la liste des composants histoire de voir si ce n'est pas le même soucis que pour Claude.

Sinon pour l'instant je n'ai pas rencontré d'autre soucis avec la centrale ou la LH100. Donc le problème viendrait à priori du module.

A +
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
claude1



Nombre de messages : 595
Age : 66
Localisation : region parisienne et Arreau
Emploi : retraité
Loisirs : trains
Date d'inscription : 10/09/2011

MessageSujet: Re: Problème avec modulre RS-8   Lun 2 Jan - 11:26

Bonjour,
A priori il ne s'agit pas du même type de problème, dans mon cas c'était la détection qui ne se faisait pas.
Dans ton cas, à moins d'un défaut de liaison entre le bouton S1 et les autres composants, je penserais à un problème logiciel.
Il est préférable de renvoyer le module à LDT.
Claude
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Phil95



Nombre de messages : 67
Localisation : Val d'Oise
Date d'inscription : 07/09/2012

MessageSujet: Re: Problème avec modulre RS-8   Mar 3 Jan - 12:41

maxime_lec a écrit:
Donc en fait oui je n'ai qu'un seul module pour le moment. Dès que la LED clignote plus rapidement je ne peux plus rien faire (même en appuyant à nouveau sur le bouton S1).

Je pense qu'à ce stade, il faudrait d'abord envisager de faire marcher le RS8 en rétrosignalisation sur l'adresse de base (65 ?) avant de vouloir le programmer. Cela permettrait au moins de confirmer que le branchement est correct.


maxime_lec a écrit:
Pour l'instant je n'ai pas encore testé d'autres commandes avec la fonction F5. Mais c'est surprenant de ne pas avoir de réponse avec la fonction F6.

Dans le principe de fonctionnement du bus RS, les infos ne sont envoyées que sur des changements d'état.
Je ne pense pas que les infos soit transmises à la mise sous tension.
Il faut donc rebrancher le RS-8 à la centrale et un un morceau de voie et poser une loco et vérifier qu'elle fonctionne, puis poser/retirer la loco, pour réaliser ces changements d'état (occupé/libre) pour voir si il y a bien des infos remontées à la centrale et la manette en mode F6 sur l'adresse 65.
(ou utiliser une résistance de 1k à la place de la loco comme indiqué dans la notice du RS-8 )

Au pire, tester toutes les adresses de 65 à 128 sur la manette.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Geo69



Nombre de messages : 3364
Age : 68
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

MessageSujet: Re: Problème avec modulre RS-8   Mar 3 Jan - 15:39

Bonjour,

Phil95 a écrit:
... Dans le principe de fonctionnement du bus RS, les infos ne sont envoyées que sur des changements d'état.
Je ne pense pas que les infos soit transmises à la mise sous tension...
Avec la fonction F6 de la LH100, la centrale "interroge" l'adresse qui lui est donnée et la réponse est immédiate sur la LH100 :
- Avec un "-" qui suit l'adresse si pas de réponse à cette adresse.
- Avec un petit "b" en bas à gauche de l'écran si un module répond à cette adresse plus les éventuels occupations (notées de 1 à 8 )
C'est ce qui est écrit dans les doc's des RS8 LDT et LH100 LENZ et c'est comma ça que ça fonctionne chez moi ... Smile

A+
Georges
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Phil95



Nombre de messages : 67
Localisation : Val d'Oise
Date d'inscription : 07/09/2012

MessageSujet: Re: Problème avec modulre RS-8   Mar 3 Jan - 16:28

Geo69 a écrit:

Avec la fonction F6 de la LH100, la centrale "interroge" l'adresse qui lui est donnée et la réponse est immédiate sur la LH100 :

Georges

Quiproquo

Le bus RS de retro-signalisation est unidirectionnel: les infos ne peuvent circuler QUE du module vers la centrale.
La centrale ne peut PAS "interroger" le module.
La centrale se contente de mémoriser les infos émise par le module et les "redonner" à la manette quand elle les demande (via F6 sur sur une LH100).
Si le module n'a rien envoyé (parce que pas de changement d'état), la centrale n'a aucune info à répondre à la manette (ou au logiciel de gestion de train).
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Geo69



Nombre de messages : 3364
Age : 68
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

MessageSujet: Re: Problème avec modulre RS-8   Mar 3 Jan - 16:52

Bonsoir,

Phil95 a écrit:
... Le bus RS de retro-signalisation est unidirectionnel: les infos ne peuvent circuler QUE du module vers la centrale...
On est bien d'accord ...   Smile  

Phil95 a écrit:
... La centrale ne peut PAS "interroger" le module...
Je ne fais qu'une hypothèse, mais la centrale pourrait très bien envoyer un ordre spécifique sur le bus DCC à une adresse donnée et recevoir une réponse du module RS8 sur le bus RS, non  ?  

Phil95 a écrit:
... La centrale se contente de mémoriser les infos émise par le module et les "redonner" à la manette quand elle les demande (via F6 sur sur une LH100)...
Surement ...  Smile  

Phil95 a écrit:
... Si le module n'a rien envoyé (parce que pas de changement d'état), la centrale n'a aucune info à répondre à la manette (ou au logiciel de gestion de train).
En tous cas, dès la mise sous tension de la centrale, les infos d'occupation(s) des modules RS8 sont disponibles même sans changement d'état ... Smile

A+
Georges


Dernière édition par Geo69 le Mar 3 Jan - 17:52, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9100
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Problème avec modulre RS-8   Mar 3 Jan - 17:45

Phil95 a écrit:
Geo69 a écrit:

Avec la fonction F6 de la LH100, la centrale "interroge" l'adresse qui lui est donnée et la réponse est immédiate sur la LH100 :

Georges

Quiproquo

Le bus RS de retro-signalisation est unidirectionnel: les infos ne peuvent circuler QUE du module vers la centrale.
La centrale ne peut PAS "interroger" le module.

Tu me parais bien affirmatif sur ce coup...
Je ne connais pas spécifiquement le bus RS, mais dans les autres systèmes de rétro, la centrale lance bien une interrogation dès qu'un changement d'état est détecté sur un des modules, et c'est seulement à ce moment que l'état global des sorties est transmis à la centrale.
Ceci est primordial pour ne pas encombrer en permanence la centrale avec des informations inutiles.
Cela m'étonnerait que le bus RS soit totalement unidirectionnel... sinon, à quoi servirait une électronique de communication avec un protocole...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Phil95



Nombre de messages : 67
Localisation : Val d'Oise
Date d'inscription : 07/09/2012

MessageSujet: Re: Problème avec modulre RS-8   Mar 3 Jan - 19:04

Le bus RS est décrit là:

http://www.der-moba.de/index.php/RS-R%C3%BCckmeldebus

Je ne connais pas l'Allemand, mais un coup de google traduction (vers l'Anglais de préférence, en Français c'est du grand n'importe) + mes connaissance en électronique et un petit tour sur le site de PACO,  et cela m'a suffit à faire mes propre modules de retro-signalisation en bus RS qui fonctionnent très bien sur la centrale LENZ LZV100 du club et sur mon interface RS2PC (de PACO).

Si vous dites que les infos sont disponible dès qu'on branche, alors c'est soit que le câblage de Maxime est mauvais, soit que son module RS-8 est en panne.

Sinon, j'ai lu sur un forum en Anglais que certain avait des probleme avec le bus RS si ils n'utilsaient pas de fils torsadés.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Geo69



Nombre de messages : 3364
Age : 68
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

MessageSujet: Re: Problème avec modulre RS-8   Mar 3 Jan - 19:54

Bonsoir,

Phil95 a écrit:
... Si vous dites que les infos sont disponible dès qu'on branche...
Je ne ferai pas plus d'hypothèse sur le "comment ça marche" mais je viens encore de faire l'exercice suivant :
- 1 - Mise sous tension du réseau
- 2 - Fonction F6 sur LH100 avec adresse d'un RS8 qui a ses 8 "cantons" libres. Réponse avec uniquement "b"
- 3 - Mise hors tension du réseau
- 4 - Placement d'une loco sur le canton alimentée par la position 2 du RS8
- 5 - Mise sous tension du réseau
- 6 - Fonction F6 sur LH100 avec adresse du même RS8. Réponse avec "b" et "2"

A+
Georges
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean_01

avatar

Nombre de messages : 5168
Age : 69
Localisation : Annecy-Le-Vieux
Date d'inscription : 25/06/2007

MessageSujet: Re: Problème avec modulre RS-8   Mar 3 Jan - 20:22

Personnellement, j'ai plus confiance dans la méthode empirique de Georges que dans la méthode "père emptoire" que j'avais déjà eu l'impression de déceler chez Phil95.

Cela n'engage que moi, bien sûr et jusqu'à preuve du contraire.Very Happy Very Happy

Jean Smile

_________________
V5.8, V7F1 à F8, V8A3 à G2 Gold (Silver) Intellibox I et S88, DCC,  PCs sous Vista(32 bits) et W7(64 bits)
Beta en test de TC et en lecture de bouquins :-)))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://perso.numericable.fr/dagron.jean
Mcar

avatar

Nombre de messages : 1034
Age : 60
Localisation : Budapest (HU) / Longwy (54)
Loisirs : Modelisme ferroviaire et moto sur piste
Date d'inscription : 29/03/2010

MessageSujet: Re: Problème avec modulre RS-8   Mar 3 Jan - 22:14

Phil95 a écrit:


Sinon, j'ai lu sur un forum en Anglais que certain avait des probleme avec le bus RS si ils n'utilsaient pas de fils torsadés.

Mon bus RS côtoie du 220V (passe par le même trou), n'est pas torsadé, et pour autant fonctionne très bien sans soucis.
Par ailleurs, je partage à 100% les commentaires de Georges
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Phil95



Nombre de messages : 67
Localisation : Val d'Oise
Date d'inscription : 07/09/2012

MessageSujet: Re: Problème avec modulre RS-8   Mar 3 Jan - 22:57

C'est pas contradictoire, c'est complémentaire:
J'ai essayé d'expliquer le principe de fonctionnement du bus RS (entre le module de rétro-signalisation et la centrale) et Georges a décrit le maniement de la manette LH100 pour obtenir les infos de rétro-signalisation disponible dans la centrale (via le bus Xpressnet).

C'est vrai qu'il n'est nécessaire de comprendre comment fonctionne le bus RS ou le bus Xpressnet pour utiliser la centrale LENZ.

La méthode de Georges n'est pas empirique, c'est quasiment ce qui écrit dans la notice du module LDT.
Donc Georges fait très bien !

C'est juste que je ne savais pas si le module envoyait une info à la mise sous tension ou pas.
Grace à Georges, je sais que c'est le cas. (Ce qui est du bon sens dans ce genre de système)
Donc, pour ma part, j'en conclus que Maxime a soit un pb de câblage, soit un composant défectueux (RS-8 ou centrale ?)

Pour ceux qui lisent l'Anglais, un autre site ou le fonctionnement du bus RS est décrit:

https://sites.google.com/site/dcctrains/rs-bus-feed

il est dit:
Access control: The RS-bus is one directional: data bytes can be send from a slave (decoder) to the master, but the master can not send data bytes to the slaves

C'est une particularité du bus RS d’être uni-directionnel, contrairement au bus LNET ou R-bus ROCO par ex, ou là effectivement, la centrale demande l'info.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Phil95



Nombre de messages : 67
Localisation : Val d'Oise
Date d'inscription : 07/09/2012

MessageSujet: Re: Problème avec modulre RS-8   Mar 3 Jan - 23:01

Geo69 a écrit:

Phil95 a écrit:
... La centrale ne peut PAS "interroger" le module...
Je ne fais qu'une hypothèse, mais la centrale pourrait très bien envoyer un ordre spécifique sur le bus DCC à une adresse donnée et recevoir une réponse du module RS8 sur le bus RS, non  ?  

Georges

Le protocole DCC est "libre" et diffusé par la NMRA:
il est facile d'ouvrir la spec et de vérifier qu'il n'y a pas une telle requête définie dans le protocole.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9100
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Problème avec modulre RS-8   Mer 4 Jan - 2:04

Phil95 a écrit:

il est dit:
Access control: The RS-bus is one directional: data bytes can be send from a slave (decoder) to the master, but the master can not send data bytes to the slaves

C'est une particularité du bus RS d’être uni-directionnel, contrairement au bus LNET ou R-bus ROCO par ex, ou là effectivement, la centrale demande l'info.

Si tu avais lu la totalité de la description du fonctionnement, tu aurais su que c'est bien la centrale qui déclenche l'envoi des bits de données des "esclaves" vers le "maitre"...
Il n'y a effectivement pas de communication bi-directionnelle à proprement parler, mais une séquence d'impulsions est envoyée par la centrale en direction des "décodeurs esclaves" qui en font le comptage afin de savoir lequel doit envoyer ses informations en direction du "maitre" (le nombre d'impulsions comptées correspondant à l'adresse visée).

Il y a cependant une phase pendant laquelle des données circulent en sens contraire (centrale --> module), c'est au moment de l'adressage, mais, cela se fait par quel bus, RS ou JK..?
Je pencherais pour JK car l'esclave se comporte alors comme un décodeur d'accessoire.
Il semblerait donc que c'est cette communication qui est défectueuse sur le module RS-8 de Maxime.
Et se pose donc la question :
Maxime, as-tu bien connecté correctement les 2 entrées JK marquées IN1 et IN2...?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Phil95



Nombre de messages : 67
Localisation : Val d'Oise
Date d'inscription : 07/09/2012

MessageSujet: Re: Problème avec modulre RS-8   Mer 4 Jan - 8:36

DiCoS69 a écrit:

Si tu avais lu la totalité de la description du fonctionnement, tu aurais su que c'est bien la centrale qui déclenche l'envoi des bits de données des "esclaves" vers le "maitre"...
Il n'y a effectivement pas de communication bi-directionnelle à proprement parler, mais une séquence d'impulsions est envoyée par la centrale en direction des "décodeurs esclaves" qui en font le comptage afin de savoir lequel doit envoyer ses informations en direction du "maitre" (le nombre d'impulsions comptées correspondant à l'adresse visée).

Comme tu le dis toi même, la séquence d'impulsions n'est pas de la "communication" mais simplement un moyen pour la centrale de savoir quel module à "parler".


DiCoS69 a écrit:

Il y a cependant une phase pendant laquelle des données circulent en sens contraire (centrale --> module), c'est au moment de l'adressage, mais, cela se fait par quel bus, RS ou JK..?
Je pencherais pour JK car l'esclave se comporte alors comme un décodeur d'accessoire.

Il n'y a pas d'adressage "sélectif". En aucun cas, la centrale ne peut "forcer" un module à répondre.
Les 130 impulsions donnent juste une "fenêtre" à chacun des 128 modules (possibles) pour transmettre leurs donnés.


Revenir en haut Aller en bas
Voir le profil de l'utilisateur
maxime_lec



Nombre de messages : 14
Localisation : Tours
Emploi : Cheminot
Date d'inscription : 30/10/2016

MessageSujet: Re: Problème avec modulre RS-8   Mer 4 Jan - 10:02

Je vois que mon problème fait parler pas mal sur le principe de fonctionnement du RS-bus. Laughing

J'ai bien essayé d'interroger le module avec la fonction F6 pour les adresses 65 et 66 mais j'ai toujours un "-" à la suite de l'adresse donc je n'ai pas de réponse de mon module.

Concernant le câblage, pour l'avoir refait plusieurs fois je peux être sûr à 99% qu'il est bon, et que les entrées IN1 et IN2 sont bien reliées.

En tout cas il faut voir le bon côté des choses, ce petit problème me permet de voir pas mal de choses sur le fonctionnement de tout ça.  Shocked  Mais j'attends avec impatience mon autre module RS-8 pour le tester et faire avancer ce schmilblick...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Geo69



Nombre de messages : 3364
Age : 68
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

MessageSujet: Re: Problème avec modulre RS-8   Mer 4 Jan - 14:45

Bonjour,

Comme j'aime bien essayer de comprendre, j'ai refait quelques tests :

Phil95 a écrit:
Geo69 a écrit:

Phil95 a écrit:
... La centrale ne peut PAS "interroger" le module...
Je ne fais qu'une hypothèse, mais la centrale pourrait très bien envoyer un ordre spécifique sur le bus DCC à une adresse donnée et recevoir une réponse du module RS8 sur le bus RS, non  ?  

Georges

Le protocole DCC est "libre" et diffusé par la NMRA:
il est facile d'ouvrir la spec et de vérifier qu'il n'y a pas une telle requête définie dans le protocole.
Il a été plus facile pour moi, de vérifier que la fonction F6 fonctionnait très bien avec le module RS8 alimenté par le courant DCC d'une autre source (SPROG) ... Very Happy Donc, on est d'accord mon hypothèse n'était pas bonne !...  Embarassed

Donc, de ma compréhension :
Un module RS8 envoi les infos d'occupations à la centrale :
- A sa mise sous tension    
- A chaque changement d'état d'une de ses 8 E/S
La centrale mémorise ces infos (à la mise hors tension d'un RS8, les états des E/S de celui-ci sont toujours mémorisés dans la centrale).  
La fonction F6 de la LH100 interroge la centrale pour connaître l'état d'un RS8.

Phil95 a écrit:
... Donc, pour ma part, j'en conclus que Maxime a soit un pb de câblage, soit un composant défectueux (RS-8 ou centrale ?)...
Le câblage entre la LZV100 et un RS8 n'étant quand même pas compliqué, c'est pour cela que j'avais demandé à Maxime de se familiariser avec sa centrale et de vérifier qu'il pouvait commander au moins une loco et un accessoire afin de cerner le pb.

maxime_lec a écrit:
...  Mais j'attends avec impatience mon autre module RS-8 pour le tester et faire avancer ce schmilblick...
On attend aussi de tes nouvelles ...  Smile

A+
Georges
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DiCoS69

avatar

Nombre de messages : 9100
Age : 69
Localisation : Haut Beaujolais 69
Emploi : Retraité
Loisirs : Tous loisirs techniques
Date d'inscription : 10/12/2008

MessageSujet: Re: Problème avec modulre RS-8   Mer 4 Jan - 20:05

Phil95 a écrit:


DiCoS69 a écrit:

Il y a cependant une phase pendant laquelle des données circulent en sens contraire (centrale --> module), c'est au moment de l'adressage, mais, cela se fait par quel bus, RS ou JK..?
Je pencherais pour JK car l'esclave se comporte alors comme un décodeur d'accessoire.

Il n'y a pas d'adressage "sélectif". En aucun cas, la centrale ne peut "forcer" un module à répondre.
Les 130 impulsions donnent juste une "fenêtre" à chacun des 128 modules (possibles) pour transmettre leurs donnés.


Ce n'est pas la réponse que j'attendais pour cette question... qui ne concerne plus la rétro...Very Happy
RS ou JK pour l'adressage...?

Cependant, pour en revenir aux impulsions, chacun des modules se conforme aux impulsions pour transmettre "à son tour" les infos...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Geo69



Nombre de messages : 3364
Age : 68
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

MessageSujet: Re: Problème avec modulre RS-8   Mer 4 Jan - 20:51

Bonsoir,

DiCoS69 a écrit:
...RS ou JK pour l'adressage...? ...
Pour l'adressage, pas de doute c'est JK car celui-ci fonctionne très bien sans raccorder le bus RS ... Smile Dans ce cas, le RS8 se comporte bien comme un décodeur d'accessoires ...  Smile

A+
Georges
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Problème avec modulre RS-8   

Revenir en haut Aller en bas
 
Problème avec modulre RS-8
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 2Aller à la page : 1, 2  Suivant
 Sujets similaires
-
» [/résolu] problème avec java à l'instalation :-/
» Problème avec Java
» Problème avec l'hébergeur d'images servimg
» problème avec mon anti clic droit
» Problème avec mes balises [code]

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Technique-
Sauter vers: