Tout sur TrainController™

Forum de support et d'entraide consacré à TrainController™ logiciel d'exploitation d'un réseau modèle de trains.
 
PortailPortail  AccueilAccueil  CalendrierCalendrier  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Pb avec les variables privées dans un PB affecté à un canton

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
fhp2

avatar

Nombre de messages : 829
Age : 55
Localisation : Paris
Date d'inscription : 25/01/2012

MessageSujet: Pb avec les variables privées dans un PB affecté à un canton   Mer 15 Nov - 9:24

Bonjour,
Je viens de m'apercevoir d'un comportement bizarre de TC quand on utilise des vatiables textuelles ou numériques "privées" dans les opérations d'un bouton poussoir ou d'un interrupteur affecté à un canton.
En effet, si ce canton est occupé par un train, alors le contenu de ces variables disparait (les variables textuelles sont affichées vides et les variables numériques affichent 0).
Dès que le canton se libére, ces variables retrouvent leurs valeurs...!!
Ce phénomène n'affecte que les variables privées et pas les variables globales...
J'ai un fichier exemple si ça intéresse certains d'entre vous.
J'ai posté aussi ce point sur le forum Freiwald.
François
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Geo69



Nombre de messages : 3699
Age : 69
Localisation : Ouest Lyonnais
Emploi : Retraité
Loisirs : VAE / Moto et ... Trains
Date d'inscription : 21/01/2012

MessageSujet: Re: Pb avec les variables privées dans un PB affecté à un canton   Mer 15 Nov - 11:00

Bonjour François,

fhp2 a écrit:
... J'ai posté aussi ce point sur le forum Freiwald...
Je pense que c'est le bon endroit car je ne sais pas si beaucoup de TC'istes sont allés aussi loin que toi dans l'utilisation des variables de la V9 ...  Smile Perso, j'en ai fait qu'une seule utilisation (variable "privée" de type "objet" pour changer le nom d'un indicateur dans un prérequis d'une macro ... et cela marche bien ...  Very Happy

A+
Georges
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Mcar

avatar

Nombre de messages : 1103
Age : 60
Localisation : Budapest (HU) / Longwy (54)
Loisirs : Modélisme ferroviaire
Date d'inscription : 29/03/2010

MessageSujet: Re: Pb avec les variables privées dans un PB affecté à un canton   Mer 15 Nov - 18:45

fhp2 a écrit:
Bonjour,
Je viens de m'apercevoir d'un comportement bizarre de TC quand on utilise des vatiables textuelles ou numériques "privées" dans les opérations d'un bouton poussoir ou d'un interrupteur affecté à un canton.
En effet, si ce canton est occupé par un train, alors le contenu de ces variables disparait (les variables textuelles sont affichées vides et les variables numériques affichent 0).
Dès que le canton se libére, ces variables retrouvent leurs valeurs...!!
Ce phénomène n'affecte que les variables privées et pas les variables globales...
J'ai un fichier exemple si ça intéresse certains d'entre vous.
J'ai posté aussi ce point sur le forum Freiwald.
François
Bonsoir François,
c'est bizarre,
j’utilise des variables "block" dans les opérations d'un bouton poussoir pour mes procédures d'empilage et destockage en LIFO sur un canton en impasse, et je n'ai jamais remarqué ce comportement.
Egalement, j'ai crée plusieurs accessoires étendus pour créer un sélecteur de trajet , pas vu de problème,
J'ai downloadé ton fichier , je regarde
mais tu as deja eu un debut de reponse sur le forum de Freiwald
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Mcar

avatar

Nombre de messages : 1103
Age : 60
Localisation : Budapest (HU) / Longwy (54)
Loisirs : Modélisme ferroviaire
Date d'inscription : 29/03/2010

MessageSujet: Re: Pb avec les variables privées dans un PB affecté à un canton   Mer 15 Nov - 19:29

donc je viens de regarder
même constat que toi, avec une variable dans un environnement privé ne fonctionne pas
en revanche une variable en mode local ça fonctionne,

je pense que le mode privé évalue la situation du bloc puisse que tu  attribue l’opération au block2 avec d'abord  la loco dessus
la situation privée  sans loco n’étant pas la même, la variable privée ne se rattache donc pas à la même situation privée puisse que celle ci à changée (la loco a disparue), mais la variable qui a été définie en situation 1 est la même et ne peut pas représenter la situation 2, en fait elle n'a pas été crée dans la situation 2
bon .... pas très clair ....
la doc dit cela, et je le comprends comme decrit plus haut
" />
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Pb avec les variables privées dans un PB affecté à un canton   

Revenir en haut Aller en bas
 
Pb avec les variables privées dans un PB affecté à un canton
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» comment faire avec la carte sd
» Ouverture de port avec DMZ ou NAT impossible
» Je grimpe tout doucement dans le pommier ! 4/4
» [Résolu] allèger sur mon DD la partition " C "
» Enlèvement de Elise 3 ans 1/2.

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tout sur TrainController™ :: RRTC :: Divers-
Sauter vers: